ISPConfig & certbot (LetsEncrypt) with ServerAlias (Alias Domains)

Discussion in 'Installation/Configuration' started by Stokesy, Aug 4, 2017.

  1. Stokesy

    Stokesy Member

    I have ispconfig 3.1 (which has been upgraded over the years from ISPConfig 2) but have had a problem with Certbot (LetsEncrypt)...
    I have a WordPress Multisite installation with about 15 domains redirected to it - these are setup as 'Alias Domains' in ISPConfig. Every time I tried to get ISPConfig to generate and install a certificate for the parent domain, it would fail. After looking through the logs I found that there were some old sub-sites that I wasn't hosting anymore... This was causing the authorization of the cert to fail as they were no longer linked to the IP of my server, so I made these inactive in their respective ISPConfig panel entries. However it still failed and I tracked this down to an alias domain for '' (which I didn't put there). Once I had made this inactive the certificate succesfully generated... :)
    ISPConfig + Certbot is a great combination!
    I have one question however. What happens if I want to add another sub-site - i.e add another Alias Domain? How do I add the new domain to the master domain certificate? Is this automated (best case) or do I have to manually revoke and delete the existing certificate and reinitiate it (worst case)?
    Many Thanks to Till and the others who have been providing so much help and support over many years!
  2. Stokesy

    Stokesy Member

    pS my ISPConfig is version 3.1.2 - I see ver 3.1.6 is now out - guess it's time to upgrade huh? :) what should I backup before doing so?

Share This Page