ISPConfig CentOS 4.3

Discussion in 'Installation/Configuration' started by tbtucholka, Mar 30, 2006.

  1. tbtucholka

    tbtucholka New Member

    Does anyone know of any workarounds to get the ISPConfig installer to run on CentOS v4.3 ?
     
  2. JLChafardet

    JLChafardet New Member

    waiting for the same thing, want to check it out, and the box where i want to install this software runs Centos 4.3
     
  3. till

    till Super Moderator

    You can try this:

    1) Make a backup of the file /etc/redhat-release
    2) Edit /etc/redhat-release and set the version number to centos 4.2
    3) Run the ISPConfig setup
    4) Restore your backup of the file /etc/redhat-release
     
  4. tbtucholka

    tbtucholka New Member

    I made the change to the redhat-release file, and ran the setup again until I ran into this:

    ########## WEB SERVER ##########

    Checking for program httpd...
    /usr/sbin/httpd
    OK
    Checking the syntax of the httpd.conf...
    Syntax OK
    The syntax is ok!

    ########## INSTALLATION ##########

    ERROR: MySQL is not running! Please start your MySQL database and run the ISPConfig setup again.

    ----

    I then did:

    service mysqld start
    Starting MySQL: [ OK ]
    service mysqld status
    mysqld (pid 24427) is running...

    ----

    I tried running the ISPSetup again, and got the same MySQL is not running error again.

    When I check the status of the mysqld service, I get:

    mysqld dead but subsys locked
     
  5. tbtucholka

    tbtucholka New Member

    I removed mysqld, and re-installed it and I was able to get further with the ISPConfig.

    Now I am stuck at the following error :

    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!

    php -v
    PHP 4.3.9 (cgi) (built: Nov 10 2005 20:38:14)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

    ---

    I tried adding the mysql-devel packages -- still no luck
     
    Last edited: Mar 30, 2006
  6. tbtucholka

    tbtucholka New Member

    I installed zlib and got much further through the installation until I got:

    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    ./setup2: line 777: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
     
  7. Tzvook

    Tzvook New Member

    What about CentOS 3.5

    Hello All
    Is there any chance of hacking it to work with CentOS 3.5 ? :confused: ?
     
  8. till

    till Super Moderator

    There must be a compiule error before this. Please post this error here.

    http://www.howtoforge.com/forums/showthread.php?t=1646
     
  9. JLChafardet

    JLChafardet New Member

    i am going to try the following.

    formating the server with 4.2, installing ISPConfig then upgrade to 4.3

    I'll let you know how does it goes
     
  10. falko

    falko Super Moderator

    Try what Till said in post #3 of this thread.
     
  11. xianusa

    xianusa New Member

    now ISPconfig works on centos 4.3

    :D
    Hi All,

    I just got ISPconfig working with centos 4.3 and this is what I did:

    after installing 4.3 , login as root

    edit /etc/redhat-release file and change 4.3 to 4.2 ( thanks Falko)

    Install zlib as both user --shared and user

    stop mysqld
    start mysqld
    install ISPconfig

    change /etc/redhat-release 4.2 to 4.3

    Good Luck
     
  12. Tzvook

    Tzvook New Member

    partlyworked

    Hello falko
    thank you for the quick reply
    It actually worked, but then I got into this one:

    Code:
    ########## WEB SERVER ##########
    
    which: no httpd in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    which: no apache in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    which: no apache2 in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    Checking for program httpd...
    which: no httpd in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    which: no httpd2 in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    ERROR: httpd not found!
    
    Should I have used the "advanced mode" ?

    Tzvook

    ////// EDIT //////
    o.k. - found this thread:
    http://www.howtoforge.com/forums/showthread.php?t=2740&page=2
    will try that ...
     
    Last edited: Apr 2, 2006
  13. till

    till Super Moderator

    Either you do not have an apache webserver installed or the apache binary has an uncommon name or is not in your path "/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec".
     

Share This Page