ispconfig can't receive emails

Discussion in 'Installation/Configuration' started by r3el, Dec 6, 2018.

  1. r3el

    r3el New Member

    hello

    we have a ispconfig running without problems
    the single problem is
    my email domain is : mydomain .com
    i have Email mailbox : info @ mydomain .com
    i can send messages but i can't receive any messages

    so we need some help in this .. thank you
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the mail log file of your system for errors. And ensure that port 25 incoming is not blocked by your provider.
     
    r3el likes this.
  3. r3el

    r3el New Member

    thank you and
    this is : "tail -100 /var/log/mail.log" in the attachment file
    please can you help me to fix this problem
     
    Last edited by a moderator: Dec 7, 2018
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Login to webmail on your ispconfig server, then send an email to the address that you used for webmail login, wait a bit and check in webmail if the email arrived locally.

    And check the dns records of your domain to ensure that the mx record points to a domain or subdomain which points to the Ip of your server.
     
    r3el likes this.
  5. r3el

    r3el New Member

    thank you for this
    yes the email arrived locally
    i try to check dns , and see what i have here

    Code:
    [email protected]:/# dig mydomain.com ANY +noall +answer
    
    ; <<>> DiG 9.11.3-1ubuntu1.3-Ubuntu <<>> mydomain.com ANY +noall +answer
    ;; global options: +cmd
    mydomain.com.             0       IN      A       127.0.1.1
    
    i replace my domain name with "mydomain"
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Fine, so the mail system works.

    Regarding DNS: I hope you replaced the IP too as 127.0.1.1 is not a valid IP for this, this must show your external server IP. And you need a MX record, you can check for the MX record with:

    dig MX mydomain.com

    You should check your DNS settings with intodns.com
     
  7. r3el

    r3el New Member

    so should i replace 127.0.1.1 with my server ip in /etc/hosts ?

    i checked it and i sent the resulte to you in PM
     
  8. r3el

    r3el New Member

    and this is "dig MX mydomain.com"

    Code:
    ;; ANSWER SECTION:
    mydomain.com.             247     IN      MX      10 mail.mydomain.com.
    mydomain.com.             247     IN      MX      5 alt1.aspmx.l.google.com.
    mydomain.com.             247     IN      MX      10 alt4.aspmx.l.google.com.
    mydomain.com.             247     IN      MX      5 alt2.aspmx.l.google.com.
    mydomain.com.             247     IN      MX      10 alt3.aspmx.l.google.com.
    mydomain.com.             247     IN      MX      1 aspmx.l.google.com.
    
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    You configured the domain so that email is handled by Google mail and not by your own servers, that's why you don't receive any mails. Remove all MX records from google.

    The nexts tep is that you ensure that you have a dns A-Record for mail.mydomain.com. that points to the Ip of your server.
     
  10. r3el

    r3el New Member

    sloved ! great and thank you

    i have other thing .
    in hosts
    i found it like this
    Code:
    127.0.1.1 mydomain.com
    127.0.0.1 localhost
    
    should i replace this 127.0.1.1 with my server ip ?
     
    Last edited: Dec 7, 2018
  11. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    No.
     
    r3el likes this.
  12. r3el

    r3el New Member

    well thank you
     

Share This Page