ISPConfig bugs/suggestions noticed in 2.2.24

Discussion in 'Developers' Forum' started by FractalizeR, Aug 26, 2008.

  1. FractalizeR

    FractalizeR New Member


    I would like to suggest the following:
    - When creating db_ispconfig DB the following SQL statement should be used:
    CREATE DATABASE `db_ispconfig` /*!40100 DEFAULT CHARACTER SET latin1 */
    This will force latin1 encoding ol all tables, that will be later created in this DB by db_ispconfig.sql.
    This correction will make ISPConfig installation working even on systems, where latin1 is not a default MySQL charset.
    Comments in SQL statement will ensure compatibility with pre-4.1 MySQL servers, which didn't support that feature (if ISPConfig can work with them. 4.0 is rather old).

    - When user is requested if he wants to encrypt SSL certificate with password, there should be a big huge warning about that he will need to enter this password on next and each server startup.
    Users, which bought dedicated server usually have no physical access to it and their server will not boot after ISPConfig installation and next server reboot. They will need to ask support to enter password for certificate using keyboard as I understand.

    - In installer there is a request to enter MySQL server address. It is like this: "Please enter MySQL server:" in English. I prefer this string to be "Please enter MySQL server hostname/IP/socket" or something like this. This phrase got me stuck for some moments before I realized, that I need to enter host ;)

    - When creating HostingPlan there is an untranslated German string "Traffic-?berschreitung:"
    - When navigating to Management -> Server -> Services there is an untranslated string "?berwachung"

    P.S. I think I incorrectly named the title of the topic. These are not bugs, but rather "notices" or "suggestions".
    Last edited: Aug 26, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

    I've added this to our bugtracker.
  3. FractalizeR

    FractalizeR New Member

    Thank you.
  4. radim_h

    radim_h Member HowtoForge Supporter

    This string (and there is more of them uncorrectly appearing in ISPConfig 2.2.24) is shown uncorrectly probably in all languages different from german (i tried English and Czech), but the string line in language module is in placed correctly
    $wb["Traffic-�berschreitung"] = "Traffic Exceedance"; in

    $wb["Traffic-܁berschreitung"] = "P�ekro聅en큅 p�enosu

    i'm using
    $go_info["theme"]["charset"] = "iso-8859-2";
    in /home/admispconfig/ispconfig/lib/
    but the problem is same also when $go_info["theme"]["charset"] = "iso-8859-1"; is set
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks as if the editor you used to open the language file does not support multi byte encodings.
  6. radim_h

    radim_h Member HowtoForge Supporter

    Yes, it was nano, i havent edited the files after installation, just wanted to show you that translation is on place, but doesnt working
  7. radim_h

    radim_h Member HowtoForge Supporter

    solved ?

    As i found now, there was some problem with doctype table since upgrade do 2.2.4 - Traffic-?berschreitung instead of Traffic-Überschreitung (and probably in all worlds with German accent as Log-Grösse etc..)

    i tried update to 2.2.25 and nothing changed.

    I have solved it by installing clean ISPC on different computer and replacing my problematic doctype table with that one from clean installation (both 2.2.25 version) Hope i did not screwed anything
  8. falko

    falko Super Moderator ISPConfig Developer

    I've just implemented this and will test it.

    I guess this is related to the MySQL charset because on my test installation I see the correct translations.

Share This Page