ISPConfig Broken After Update

Discussion in 'Installation/Configuration' started by NoobsOnline, Jul 4, 2012.

  1. NoobsOnline

    NoobsOnline New Member

    Hi all...

    I am one of the very satisfied ISPConfig users and all I can say is: Great Job!!!

    But every now and then, problems do occur (what would we do without problems, right?)

    I was happily running 3.0.4.5 and I got popped up a thingy saying 3.0.4.6 was available, so I clickidy click click and I installed it...

    At first, everything seamed to be normal, but...

    I tried adding couple of DBs and a subdomain for my website, and this is where the problem appeared. When I would try to login to the newly created database, it would give me two errors (not both at the same time):

    #1045 Cannot log in to the MySQL server
    Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

    and as for subdomain problem, I create it, put target directory but when I open it in browser, it says it works bla bla bla, the default page for apache

    So, I am stuck here at the moment.

    Any good soul would be able to help me out?

    Thanks in advance.

    BTW, I use debian 6
     
  2. till

    till Super Moderator

    Please login to ispconfig and then go to the monitor module and take a llok at the jobqueue. Are there any jobs listed?
     
  3. NoobsOnline

    NoobsOnline New Member

    Hi till.

    Yes, there are about four pages of things in queue.

    how do I process the queue and prevent queue from building up like that?
     
  4. till

    till Super Moderator

    Most likely a process dies and left a lock file. Try this to start the process again:

    rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock

    then wait a few minutes and check the jobqueue again.
     
  5. NoobsOnline

    NoobsOnline New Member

    I have done the command, so will wait and see now...

    Why is this happening and how do I prevent it from happening in the future?

    Thanks Till, will report it in few minutes how does it look with job queue.
     
  6. till

    till Super Moderator

    It can happen sometimes that a program like the PHP interpreter dies, e.g. caused by a ram failure or a problem in the binary or other reasons. This is nothing that can be totally prevented, your system may run for years without a problem and then it happens one time and then it runs for yaers again.
     
  7. NoobsOnline

    NoobsOnline New Member

    Unfortunately, job queue is still there, I tried making more changes to push the queue, but no go, just added 2 changes to the queue and nothing...queue is still 4 pages long like it was before.

    Anything else I can do?
     
  8. till

    till Super Moderator

    Are there any errors listed in monitor > system state > show system log
     
  9. NoobsOnline

    NoobsOnline New Member

    No, system log is empty, nothing in there.

    However, in server state is this:

    Server: vps0144 (Debian Squeeze/Sid)
    ISPConfig 3.0.4.5
    State: info (0 unknown, 0 info, 2 warning, 0 critical, 0 error)
    ok:
    The state of your Hard-Disk space is ok [More...]
    Your Mail queue load is ok [More...]
    Your Server load is ok [More...]
    All needed services are online [More...]
    The System Log is O.K. [More...]

    warning:
    Your virus protection is OUTDATED! [More...]
    One or more components needs an update [More...]

    Says there 3.0.4.5, but I upgraded to .6, so I am confused now, because when I run update.sh on ispconfig, it tell me I have latest version
     
  10. till

    till Super Moderator

    You mix up ispconfig and Linux updates here. The message tells you that there are linux updates available and not that there are updates for ispconfig avalable. Linux updates are installed with:

    apt-get upgrade

    on Debian and Ubuntu. The message about the antivirus can be ignored as its a false positive because clamav does not detect correctly that it gets patched by the linux distribution without increasing the version number.

    Both messages are not related to your problem.

    Regarding your original problem, you can use these instructions to debug this:

    http://www.faqforge.com/linux/debugging-ispconfig-3-server-actions-in-case-of-a-failure/
     

Share This Page