ISPConfig breaks /etc/passwd

Discussion in 'General' started by willy-na, Jan 16, 2007.

  1. willy-na

    willy-na New Member


    I have been running ISPConfig for a while now.

    Occasionally, after adding an email user or deleting one, my customers phone and say they can't log in.

    When looking at my /etc/passwd, shadow, group, gshadow files I see some files is 0 size, others have a few users in...
    every time my root user is missing... this requires me to boot into single mode, and use my backup files to restore those files.

    Why does this happen ? I mean all my non ISPConfig (WebX_) users are missing and only a few of the WebX users are in the file ...

    I checked and checked, re installed servers, moved from FC3 to FC6 etc etc ... version 2.2.6, 2.2.7, and 2.2.9 all does it.

    I used the perfect install instructions to a tee....

    Anyone with any help are most welcome.


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use another software except of ISPConfig that adds and modifies passwords like webmin?
  3. willy-na

    willy-na New Member

    Yes webmin is installed but not used. Should I perhaps uninstall it ?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No.There should be no problem as long as you dont use it.

    Please check the consistency of your passwd and group file with the commands:



  5. willy-na

    willy-na New Member


    I detected some problems with pwck and grpck.

    I have fixed them, and hopefully all should go well from now on.

    Thank you for the help.



Share This Page