ISPConfig breaks access to phpmyadmin

Discussion in 'Installation/Configuration' started by vondie, Oct 16, 2009.

  1. vondie

    vondie New Member

    I have just installed a full LAMP server on a Windows 2008 Hyper-V VM following the guide "The Perfect Server - CentOS 5.3 x86_64 [ISPConfig 3]" guide. I have successfully installed this scenario on a bare machine, this is my first go as a VM. Everything worked as expected until I got to the ISCConfig 3 step. Prior to that step, I could access both phpmyadmin and webmail using http://server_IP/phpmyadmin and http://server_IP/webmail respectively. When I installed the ISPConfig 3 program (version, version would prevent httpd from starting), I could no longer access phpmyadmin or webmail. The server would throw the error:

    You don't have permission to access /phpmyadmin on this server.
    Apache/2.2.3 (Red Hat) Server at server_IP Port 80

    Since it's a VM, I had taken a snapshot prior to the installation of ISPConfig 3 so I went back to before the install. phpmyadmin and webmail returned to expected operation and I tried the install again with the same resulting error.

    I can access the ISPConfig admin console via http://server_IP:8080 without issue. I'm guessing there is a permissions difference between version and, but I'm very new to Linux and am having trouble figuring this out.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig uses higher security settings since Please post the exact error message from the error log of the website.
  3. vondie

    vondie New Member

    From the /var/log/https/error_log

    [error] [client <local IP address>] client denied by server configuration: /usr/share/phpmyadmin

    Checking, I believe I need to modify my VirtualHost configuration directives? Am I on the right track? If so, what is the suggested, best practice approach?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. vondie

    vondie New Member

    Thanks very much!

Share This Page