ISPConfig - Blue Flat Theme

Discussion in 'Tips/Tricks/Mods' started by adam2661, Oct 26, 2014.

  1. adam2661

    adam2661 New Member

    Hello everyone this is my first post and I would like to present you my version of the default theme ISPConfig. This is not anything special but it works a little faster and I think it looks better. Please assess my work. Thanks in advance for yours opinions.

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
     
    jossmalo likes this.
  2. frprim

    frprim New Member

    well

    Looks better than default ISPconfig theme. If not mistaken ISPconfig team is about to create new bootstrap theme for ISPconfig 3.6 .
     
  3. adam2661

    adam2661 New Member

    Thanks for the reply and sharing your opinion. Yes I know that they have to release a new theme with the release of the next version of ISPConfig but I think 3.1 and not 3.6 because the current version is 3.0.5. I'll also want to release my own version of the new theme and in the meantime I want to make public this to have the opportunity to correct any errors that I can not for some reason catch yourself.
     
    Last edited: Oct 27, 2014
  4. frprim

    frprim New Member

    I belive this is a good theme for ispconfig. I like clean design you choose.
    Take care and keep us posted on the progress :D
     
  5. adam2661

    adam2661 New Member

    Welcome to the link below to download Blue Flat Theme. Please tell me the error in displaying this theme. I tried all the repair as soon as possible.

    http://www26.zippyshare.com/v/53165271/file.html

    Installation

    1. Copy the flatblue folder to your /usr/local/ispconfig/interface/web/themes
    2. Edit /usr/local/ispconfig/interface/lib/config.inc.php and change
      $conf['theme'] = 'default'; to $conf['theme'] = 'flatblue';
    3. Enjoy the theme.

    I would like to thank dclardy
     
    Last edited: Nov 3, 2014
  6. Eksperten

    Eksperten New Member

    thanks m8 looks nice.

    I found one minor layout error. the home button/icon is off center. this is in latest isp 3 ind both chrome and ie
     
    Last edited: Nov 3, 2014
  7. adam2661

    adam2661 New Member

    Thanks for the info. The layout was designed for Polish language so the error is a result of the length of the word home. Below a link to the revised version 1.0.1

    https://mega.co.nz/#!t4w0FRzR!94R7Uiin_8rIEyenkro8vyt515rrDYbLsHslEPVxTAU
     
    Last edited: Nov 4, 2014
  8. Eksperten

    Eksperten New Member

    thanks m8.

    I found one more small layout "error"

    Go to sites then the icon for delete and go to site has no text or wrong color text so it just shows whit box when howering over the buttons.
    also the serch box in the header area gows down over the top menu vserver. (i am on a small lap-top now)

    i have not checkd this in the file you just uploaded!
     
    Last edited: Nov 4, 2014
  9. adam2661

    adam2661 New Member

    For all tooltips was that error but been removed in version 1.0.1
    Thanks for the info regarding the search box. Change over this in the next version.
     
  10. webguyz

    webguyz Member HowtoForge Supporter

    Looks good! Very clean looking layout.

    Thanks!
     
  11. andypl

    andypl Member

    Change in the file dashboard.html

    From:
    HTML:
         
    <div id = "dashboard-left-col">
             <TMPL_LOOP name = 'leftcol'>
                 {tmpl_var name = 'content'}
                 <p> & nbsp; </ p>
             </ TMPL_LOOP>
         </ div>
    To:
    HTML:
    <div id = "dashboard-left-col">
             <TMPL_LOOP name = 'leftcol'>
                 {tmpl_var name = 'content'}
                 <p style = "clear: left"> & nbsp; </ p>
             </ TMPL_LOOP>
         </ div>
     
  12. Eksperten

    Eksperten New Member

    Hi looks great now m8
     
  13. andypl

    andypl Member

    Is it a version available for the latest version of the ISPConfig?
     

Share This Page