ISPConfig Bind offline

Discussion in 'Installation/Configuration' started by bobwdn, Oct 7, 2008.

  1. bobwdn

    bobwdn HowtoForge Supporter

    Built an Ubuntu 8.04LTS ISPConfig server per Falko's instructions and two weeks ago, all was working fine. Lately, I have been working my way through getting my server recognized by my ISP nameservers.

    Because I need to run one nameserver, I followed "How To Run Your Own Name Server With ISPConfig and providerdomain.de" how to. Struggled with the German graphics (on page 2), but I think I got through it with the help of "How To Run Your Own Servers With ISPConfig And GoDaddy" how to.

    And now I have discovered that my bind9 is not running. "Services" shows it is "offline" as does natstat -tap shows not listening to ports 53 or 953.

    The syslogd captures the following:

    Oct 7 10:11:32 web02 named[22030]: starting BIND 9.4.2-P1 -u bind -t /var/lib/named
    Oct 7 10:11:32 web02 named[22030]: found 1 CPU, using 1 worker thread
    Oct 7 10:11:32 web02 named[22030]: loading configuration from '/etc/bind/named.conf'
    Oct 7 10:11:32 web02 named[22030]: none:0: open: /etc/bind/named.conf: permission denied
    Oct 7 10:11:32 web02 named[22030]: loading configuration: permission denied
    Oct 7 10:11:32 web02 named[22030]: exiting (due to fatal error)
    Oct 7 10:11:32 web02 kernel: [950173.520670] audit(1223392292.562:23): type=1503 operation="inode_permission" requested_mask="r::" denied_mask="r::" name="/var/lib/named/etc/bind/named.conf" pid=22031 profile="/usr/sbin/named" namespace="default"

    I checked the permissions of /var/lib/named/etc/bind/named.conf and it is bind:bind.

    Did something update bind recently that I overlooked when upgrading?

    I need help. Please. :confused:
     
  2. zinovsky

    zinovsky New Member

    I have the same probleme

    i have the same probleme as you just for me the server is installed on centos5.2.
     
  3. falko

    falko Super Moderator

    What's the output of
    Code:
    ls -la /etc/bind/
    ?
     
  4. bobwdn

    bobwdn HowtoForge Supporter

    ls -la output

    ls -la /etc/bind gives the following output.

    nrobert@web02:~$ ls -la /etc/bind
    lrwxrwxrwx 1 root root 23 2008-09-24 09:11 /etc/bind -> /var/lib/named/etc/bind
     
  5. bobwdn

    bobwdn HowtoForge Supporter

    move?

    Not getting any action here. Bind was working and then stopped. Should this be moved to some Bind forum?

    Anybody?
     
  6. falko

    falko Super Moderator

    I need the output of
    Code:
    ls -la /etc/bind[B][COLOR="Red"]/[/COLOR][/B]
     
  7. bobwdn

    bobwdn HowtoForge Supporter

    Oops sorry

    nrobert@web02:~$ ls -la /etc/bind/
    total 64
    drwxr-sr-x 2 bind bind 4096 2008-10-06 09:30 .
    drwxr-xr-x 3 root root 4096 2008-09-24 09:11 ..
    -rw-r--r-- 1 bind bind 237 2008-07-07 16:06 db.0
    -rw-r--r-- 1 bind bind 271 2008-07-07 16:06 db.127
    -rw-r--r-- 1 bind bind 237 2008-07-07 16:06 db.255
    -rw-r--r-- 1 bind bind 353 2008-07-07 16:06 db.empty
    -rw-r--r-- 1 bind bind 270 2008-07-07 16:06 db.local
    -rw-r--r-- 1 bind bind 2878 2008-07-07 16:06 db.root
    -rw-r--r-- 1 bind bind 813 2008-10-06 09:29 named.conf
    -rw-r--r-- 1 bind bind 907 2008-10-06 09:29 named.conf~
    -rw-r--r-- 1 bind bind 165 2008-07-07 16:06 named.conf.local
    -rw-r--r-- 1 bind bind 695 2008-07-07 16:06 named.conf.options
    -rw-r--r-- 1 bind bind 1062 2008-10-06 09:37 pri.ourdomain.com
    -rw-r--r-- 1 bind bind 1017 2008-10-06 09:37 pri.ourdomain.com~
    -rw-r----- 1 bind bind 77 2008-09-24 09:08 rndc.key
    -rw-r--r-- 1 bind bind 1317 2008-07-07 16:06 zones.rfc1918
     
    Last edited: Oct 10, 2008
  8. falko

    falko Super Moderator

    What's in /etc/bind/named.conf?

    Can you also post the output of
    Code:
    ls -la /var/lib/named/etc/bind/
    ?
     
  9. bobwdn

    bobwdn HowtoForge Supporter

    requested info

    contents of /etc/bind/named.conf:

    nrobert@web02:~$ cat /etc/bind/named.conf
    options {
    pid-file "/var/run/bind/run/named.pid";
    directory "/etc/bind";
    auth-nxdomain no;
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;
    };

    //
    // a caching only nameserver config
    //
    zone "." {
    type hint;
    file "db.root";
    };

    zone "0.0.127.in-addr.arpa" {
    type master;
    file "db.local";
    };


    zone "ourdomain.com" {
    type master;
    file "pri.ourdomain.com";
    };



    //// MAKE MANUAL ENTRIES BELOW THIS LINE! ////



    ********************************************

    And . . . . . . . .

    nrobert@web02:~$ ls -la /var/lib/named/etc/bind/
    total 64
    drwxr-sr-x 2 bind bind 4096 2008-10-06 09:30 .
    drwxr-xr-x 3 root root 4096 2008-09-24 09:11 ..
    -rw-r--r-- 1 bind bind 237 2008-07-07 16:06 db.0
    -rw-r--r-- 1 bind bind 271 2008-07-07 16:06 db.127
    -rw-r--r-- 1 bind bind 237 2008-07-07 16:06 db.255
    -rw-r--r-- 1 bind bind 353 2008-07-07 16:06 db.empty
    -rw-r--r-- 1 bind bind 270 2008-07-07 16:06 db.local
    -rw-r--r-- 1 bind bind 2878 2008-07-07 16:06 db.root
    -rw-r--r-- 1 bind bind 813 2008-10-06 09:29 named.conf
    -rw-r--r-- 1 bind bind 907 2008-10-06 09:29 named.conf~
    -rw-r--r-- 1 bind bind 165 2008-07-07 16:06 named.conf.local
    -rw-r--r-- 1 bind bind 695 2008-07-07 16:06 named.conf.options
    -rw-r--r-- 1 bind bind 1062 2008-10-06 09:37 pri.ourdomain.com
    -rw-r--r-- 1 bind bind 1017 2008-10-06 09:37 pri.ourdomain.com~
    -rw-r----- 1 bind bind 77 2008-09-24 09:08 rndc.key
     
  10. falko

    falko Super Moderator

    Can you try this:
    Code:
    chmod 755 /var/lib/named/etc/bind
    and restart BIND?
     
  11. bobwdn

    bobwdn HowtoForge Supporter

    did not work

    As requested, I did:

    nrobert@web02:~$ sudo chmod 755 /var/lib/named/etc/bind
    [sudo] password for nrobert:

    Then I did:

    nrobert@web02:~$ sudo /etc/init.d/bind9 restart
    * Stopping domain name service... bind rndc: connect failed: 127.0.0.1#953: connection refused
    [fail]
    * Starting domain name service... bind [fail]

    I also tried:

    nrobert@web02:~$ sudo /etc/init.d/bind9 stop
    * Stopping domain name service... bind rndc: connect failed: 127.0.0.1#953: connection refused
    [fail]

    Next . . . . . .
     
  12. bobwdn

    bobwdn HowtoForge Supporter

    need help

    Had a few days to think about the setup configuration I have installed.

    To better "fit" my situation, I had to use (in combination) two howto's. Those being "How To Run Your Own Name Server With ISPConfig And providerdomain.de" and How To Run Your Own Name Servers With ISPConfig And GoDaddy."

    Prior to initiating this Bind configuration, Bind tested as working, so it must be something within these howto's.

    I will return to my setup notes and try to determine if this is caused by my human error.

    However, if anyone comes up with an idea or suggestion, please post it. :(
     
  13. falko

    falko Super Moderator

    Unfortunately I don't know what it is :(, but I know that these tutorials work for me.
     
  14. bobwdn

    bobwdn HowtoForge Supporter

    Will rebuild

    First, Falko, thank you for all your help. I really appreciate it.

    As I see this I am left with no other alternative than to rebuild the software in this computer. And as it is my first attempt, I see this all as part of learning about Linux.

    (I really believe that it is something I may have inadvertently configured incorrectly and my inexperience does not allow me to locate that error.)

    So, to conclude, I am actually looking forward to "doing it again." Yes, extra work, but I learn something every time.

    Once again, thanks for your help. :)
     
  15. falko

    falko Super Moderator

    To get the best results, I'd connect to the server with an SSH client like PuTTY and then copy & paste the commands from the tutorial (except the parts where you should place your own passwords, hostnames, etc.).
     
  16. bobwdn

    bobwdn HowtoForge Supporter

    Thanks

    To all,

    I do not and will never figure out exactly what was wrong but, re-installing the software went well.

    (And yes, Falko, I cut and paste the instructions as your suggested. That way I do not miss any forward slashes.) ;)

    Second time works like a charm, again, thanks.

    I have a DNS, bind question I will be starting a new thread about (in a few minutes.)

    Please consider this issue closed. And thanks again.
     
  17. megabitdragon

    megabitdragon New Member

    I have the same problem. I also followed the tutorials dns with godaddy.com.
    In my case if I add only the master dns server, bind works as expected. However, when I add the slave DNS as described in the tutorial bind fails to start.
    I should mention that I am using Ubuntu 8.04 LTS with ISPconfig2 SVN version and I am trying to use the same ip address for both master and slave DNS.

    Any ideas?

    Thanks.
     
  18. falko

    falko Super Moderator

    So master and slave are on the same box?
     
  19. megabitdragon

    megabitdragon New Member

    You are absolutely right. Both the master and slave DNS as well as the webserver are on the same box .
     
  20. falko

    falko Super Moderator

    Then all you have to do is set up a master zone, but no slave. A slave makes no sense in this case.
     

Share This Page