ISPConfig / Bind Help

Discussion in 'ISPConfig 3 Priority Support' started by jbennett, May 31, 2019.

  1. jbennett

    jbennett New Member HowtoForge Supporter

    I think I am having an issue with Bind more than with ISPConfig but I could be wrong.

    From a fresh install of Ubuntu 18.04 I followed the instructions found here: https://www.howtoforge.com/tutorial...l-pureftpd-bind-postfix-doveot-and-ispconfig/. The guide was great and ISPConfig seemed to worked just fine.

    I did not install the following packages:
    • 8.3 HHVM
    • 9. Lets Encrypt
    • 13. Install Vlogger, Webalizer, and AWStats
    • 14. Install Jailkit

    After I installed ISPConfig I registered a new domain.

    Within ISPConfig, I created a DNS zone for the domain I just registered which created the standard default records. I then created 2 additional A records, one for ns1 and one for ns2.

    When I try to update the nameservers at the registers site (Godaddy) it gives the following error, “the data provided cannot be used, please correct it and resubmit your request”. I am also not able to ping the nameserver. The configuration has been set for over 48 hours so enough time should have pass for propagation to have taken place.

    Is there a step I am missing to get the DNS server to serve up the records? Looking in /etc/bind there is a pri.doamin file but no .err files. The pri file has all the records listed that showup in the CP in ISPConfig.

    Running dig from the server hosting ISPConfig:
    dig @localhost domain.org

    ; <<>> DiG 9.11.3-1ubuntu1.7-Ubuntu <<>> @localhost domain.org
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39016
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3

    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ; COOKIE: f347b6a64214a95776a63cd75cf18e549eb78c4ebfa7f7df (good)
    ;; QUESTION SECTION:
    ;domain.org. IN A

    ;; ANSWER SECTION:
    domain.org. 3600 IN A 147.xxx.x.xx

    ;; AUTHORITY SECTION:
    domain.org. 3600 IN NS ns2.domain.org.
    domain.org. 3600 IN NS ns1.domain.org.

    ;; ADDITIONAL SECTION:
    ns1.domain.org. 3600 IN A 147.xxx.x.xx
    ns2.domain.org. 3600 IN A 147.xxx.x.xx

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Fri May 31 20:28:04 UTC 2019
    ;; MSG SIZE rcvd: 161


    Running dig from a different system:
    ; <<>> DiG 9.9.5-3ubuntu0.17-Ubuntu <<>> domain.org
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26245
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;domain.org. IN A

    ;; ANSWER SECTION:
    domain.org. 600 IN A 147.xxx.x.xx

    ;; AUTHORITY SECTION:
    domain.org. 85111 IN NS ns53.domaincontrol.com.
    domain.org. 85111 IN NS ns54.domaincontrol.com.

    ;; Query time: 14 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Fri May 31 16:42:22 EDT 2019
    ;; MSG SIZE rcvd: 120

    The nameservers here still point to Godaddy.com's nameservers which makes sense because I cannot update them at Godaddy.

    Any suggestions? Did I miss something?

    Thanks!
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. jbennett

    jbennett New Member HowtoForge Supporter

    Perfect, that fixed it. Thanks for the quick response.
     

Share This Page