ISPConfig & Bind chroot not starting

Discussion in 'Installation/Configuration' started by awd.pt, Apr 9, 2006.

  1. awd.pt

    awd.pt New Member

    Hi all,

    Running CentOS 4.3, bind-chroot (rpm) this info might help you.

    I think I've found an issue in /root/ispconfig/isp/conf/named.conf.master. Each time a change is made to DNS ISPConfig restarts BIND and copy that file (root/ispconfig/isp/conf/named.conf.master) to /etc/named.conf (simlink to /var/chroot/etc/named.conf), however there is a configuration mistake in named.conf.master, where is writen :
    pid-file "/var/named/chroot/var/run/named/named.pid";
    should be changed to :
    pid-file "/var/run/named/named.pid";
    because BIND is running in a chroot mode.
    or
    you HAVE TO:
    cd /var/named/chroot/
    mkdir -p var/named/chroot/var/run/named/
    chmod 770 var/named/chroot/var/run/named/
    chown root.named var/named/chroot/var/run/named/
    or bind wil not work.

    Please review this and correct me if I'm wrong.

    Thanks
    srosa
     
  2. public_domain

    public_domain New Member

    Running CentOS 4.3, bind-chroot (rpm) this info might help you.

    get a reply? am having problem in centos 5.1 with bind chrooted
     
  3. till

    till Super Moderator

    Please configure the permissions of the bind directories as described in the perfect setup guide. Then make sure that the path for the bind config files is set correctly in ISPConfig under managament > server > settings.
     

Share This Page