ISPConfig beta, no phpmyadmin

Discussion in 'Installation/Configuration' started by odonel, Dec 25, 2008.

  1. odonel

    odonel New Member

    Hello all,

    I followed the howto etch (perfect setup) to install debian with ISPConfig I got through ok, but I don;t see any tabs for phpmyadmin nor any tabs for customers to manage their databases. Am I missing something ??

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    First, the perfect setup guide is not compatible with ISPConfig 3, the system will not work! The best is to format the server and reinstall it as described in the install documentation for ISPConfig 3 which can be found in the ispconfig 3 tar.gz file.

    The customer databases in ispconfig can be created in the site module, please take a look at the left menu. To phpmyadmin: please install the phpmyadmin package from your Linux distribution.
    Last edited: Dec 25, 2008
  3. pan69

    pan69 New Member


    I'm able to create a new database in beta 3 but I'm unable to login to phpmyadmin. I've tried the username and password for the newly created database (didn't work), I've tried the account (client) username and password (didn't work, btw shouldn't the account be able to administer all databases created under the account?) and I've tried various combinations of username and passwords of account and database settings. Nothing works.

    Can anyone confirm that there is an issue with this?

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no such issue known. I guess there is a misconfiguration on your system. Please make sure that you did not enable external access for the database if you want to access it with the local phpmyadmin. If you want to access it from external and internal, you have to remove the global catchall record in the mysql user database which prevents access from localhost.
  5. pan69

    pan69 New Member

    Hmm. This is odd. I only seem to be able to log in when I tick 'remote access' and untick 'active'. I'm currently using ISPConfig Are there any known issues with that?


    UPDATE: There seems to be something really weird going on here. When I am finally able to login and I select 'Show MySQL runtime information' from the phpmyadmin home page I'm kicked out. Then, I'm not longer able to log back in. I have to fiddle with the 'remote access' and 'active' ticks in the ISPConfig database settings and save a couple of times to make it work again. Unfortunately I haven't been able to find a clear path that will reproduce this behavior.
    Last edited: Dec 30, 2008
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess I know waht your problem is. You should be aware that it takes about a minute until a change that you make gets active. So if you change things fast without waiting the changes are not active yet while you are trying out other things already.

    I tested the mysql database access on the ispconfig virtual machine and it works fine for me.

Share This Page