ispconfig behind a router

Discussion in 'General' started by cocoyriv, Jan 11, 2007.

  1. cocoyriv

    cocoyriv New Member

    i'm not sure if this topic has been posted anywhere. i just need some help regarding how i setup my ispconfig. im new to ispconfig so please bear with me. the server i have with ispconfig is connected to an adsl router. i am using port forwarding (virtual server) on the router so that the http and ftp ports are available from outside. i have two computers hooked up to the router. one is the server with ispconfig and the other is my workstation. i use the server also as dns server for the workstation. when i type in the domain name (www.mydomain.com) of one of the sites in the server with ispconfig i get the default directory /var/www and not the website itself. ftp seems to be working since ftp-ing to any of the sites brings me to their corresponding directory (/var/web/web#). however, if i change the ip address to point directly to the server ip and not the router everything works fine. do you find anything wrong with my setup? i hope everything is clear. thanks
     
  2. till

    till Super Moderator

    Please make sure that you selected the internal IP in ISPConfig in the settings of the website. It must be the IP where you forwarded port 80 to. If you configured the Domain in the DNS-Manager of ISPCOnfig, make sure that you selected the external IP of your router there.
     
  3. cocoyriv

    cocoyriv New Member

    i'm sure that the dns-manager of ispconfig is pointing to the external ip address of the router and that port 80 is forwarded to the internal address of the ispconfig server. but i still get the /var/www directory and not the website that i typed in the address bar. am i missing something here?
    thanks.
     
  4. till

    till Super Moderator

    And you selected the internal IP for the website and not the external?

    Is the file Vhost_ispconfig.conf empty ore are ther copies of this file with a date appended in the same directory? The directory of the file is normally /etc/apache2/vhosts/
     
  5. cocoyriv

    cocoyriv New Member

    the ip for the websites in ispconfig point out to the external router ip. the ip in the router where port 80 is forwarded is the internal ip of the server. regarding the vhost_ispconfig.conf file, i saw other copies of the file with dates appended in the same directory. i tried experimenting by moving all the other files to a directory but it still didn't work as i expected. thanks.
     
  6. till

    till Super Moderator

    Thats wrong. You must use the internal IP for the websites.

    Please do the steps described here to locate the error in your apache configuration:

    http://www.howtoforge.com/forums/showthread.php?t=7719
     

Share This Page