ISPconfig behind a nat router and firewall

Discussion in 'General' started by laser, Feb 10, 2007.

  1. laser

    laser New Member

    I have ISPconfig installed on a Fedora Core 6 system. I'm behind nat router (firewall) and I have made a rule that port 80 is forwarded to this server.
    I have now only one IP address from my ADSL. I will register a domainname that point to my WAN IP. Now is my question. How does this server with ISPconfig know wich website he must give (I like to use only subdomains on it.) And How must i set the DNS in ISPconfig??
     
  2. edge

    edge Active Member Moderator

    If you want to use the DNS withing ISPconfig, you will need to open and forward port 53 also (UDP and TCP). Port 53 is used by the DNS server

    If you want to keep things really simple, register a domain, and use the DNS from the registrar.

    All you need to do than, is change the IP's that are in the registrar DNS to your IP (use the same IP in NS1 and NS2 from the registrar)
     
  3. laser

    laser New Member

    ISPconfig behind a NAT router/firewall

    Hi, in my server I use one ethernetcard. I like to host more than one domain on it. If I forward port 80 http and 81 https to the ISPconfig machine how does it know wich website he must display?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig uses so called namebased vhosts, that means the the apache server uses the domain name to decide which website to display. You can host hundreds of websites on one IP address, as long as your hardware resources allow this ;)
     
  5. laser

    laser New Member

    How FTP works

    Hi, I have it working and works ok. If I add a site it is working. If I connect to that site with FTP I get a loginsreen as I susspected but If I use the username and passwordt for that site I can't connect. How does this works And what password and username must I use for it?
     
  6. mphayesuk

    mphayesuk New Member

    You must enable ftp access on the site in ISPConfig Control Panel and then use the username and password of the administrator of the account/site ie web1_user.
     
  7. laser

    laser New Member

    steps to take

    Ok so I have to make first a new client than a new site for that client and than I have allso create 1 mailbox with admin right to make it complete isn't it? The last step I forgot so that maybe the issue that I can't login into FTP.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Make sure that FTP is enabled on the Basis tab of that web site in ISPConfig, and then use an FTP client and log in with the user name and password of the user you created.
     
  9. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    I have my test server inside a NAT as well and had issues where I had 2 scenarios.
    1. I used the internal address which made apache work but DNS then recorded the internal IP or
    2. I used the external address and apache wouldn't work because it listened to the external address which it didn't have (ie <VirtualHost 203.x.x.x:80>)

    I ended up patching ISPconfig to use the *:80 method instead and works fine no matter if it's multihomed server, NATed or whatever.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Or you use may use iSPConfig wihout a patch by adding the external IP address in the DNS-Manager which is the recommended way.
     
  11. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    thats what I did the first time until you start forgetting when setting up new sites and so on and having to remember to go back into the DNS manager and change it all the time.

    anyway, works for me.
     

Share This Page