ISPConfig backup : corrupted zip file

Discussion in 'General' started by DrJohn, Aug 13, 2008.

  1. DrJohn

    DrJohn New Member

    Using ISPConfig 2.2.23, Ubuntu server 8.04, all functions well, EXCEPT, running Tools, Backup, Download chosen, and selecting one or all sites in the Admin panel plus the default Web Data, User Data, and MySQL Database, after about a minute wait I get only 211 bytes in the resulting zip and the zip cannot be opened: "The compessed (zipped) file is invalid or corrupted." The target PC is Windows XP Pro or Ubuntu 8.04 desktop (same result on both) thru Firefox 3.0.1.

    Choosing instead Management, BackupData, Download, I get a zip file with what appears to be a valid MySQLDump .SQL backup of the configuration database.

    So, any ideas on what might be wrong with the web backups?

    Thanks,

    D.J.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess that the size of the site is too big for the browser based backup function. Either you activate the automatic daily backup which is run on the shell in the config.inc.php file or you run a custom backup script.
     
  3. Doug G

    Doug G Member HowtoForge Supporter

    Take a look at the 211-byte zip file with a text editor, it probably is complaining about insufficient php memory allocation. I had to increase the max memory in php.ini on my testing server.
     
  4. DrJohn

    DrJohn New Member

    That's absolutely correct, Doug: the zip is html with this content:

    Code:
    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 363653928 bytes) in /home/admispconfig/ispconfig/web/tools/tools/backup/backup.php on line 157
    php.ini has a 128M memory limit (as you can see).

    I already run a cron-based backup script for one of the sites, but now with quite a few more sites now it makes more sense (I think) to use the built-in capability, so I've enabled it in config.inc.php, see here: http://howtoforge.org/forums/showthread.php?t=12063. Now we'll see how it works tonight.

    -- DJ
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You should set the memory limit to a higher value in /root/ispconfig/php/php.ini and then restart ispconfig.
     
  6. DrJohn

    DrJohn New Member

    Thanks Til,

    I doubled the mem limit to 256M. The automated backup ran fine overnight.

    Another question: does the automated backup not also perform the equivalent function of Management, ISPConfig Database, Backup data?

    If so, where is this information stored by the automated backup? If not, how to automate this too?

    Thanks,

    DJ
     

Share This Page