ispconfig apache configuration

Discussion in 'Installation/Configuration' started by it0007, Nov 13, 2006.

  1. it0007

    it0007 New Member

    Hello

    i have the folowing problem with ispconfig

    i try to move a site from one server (sme server 7) to ispconfig 2.2.7 + centos 4.4

    the site works without a problem on sme7
    with open_basedir & safe_mode = off

    and when i move the site to ispconfig, everything is working except when i click an image to open a popup window no image is opening

    the code to open the image is:
    Code:
    javascript:popupWindow('popup.php?img=image_name.jpg');
    i tried with different Apache Directives in ISPconfig to emulate sme 7 apache config:
    Code:
    php_flag magic_quotes_gpc On
    php_admin_value open_basedir /var/www/web32/:/var/www/web32/phptmp/
    php_admin_value file_uploads 1
    php_admin_value upload_tmp_dir /var/www/html/web32/phptmp/
    php_admin_value session.save_path /var/www/html/web32/phptmp/
    php_admin_value memory_limit 32M
    php_flag register_globals Off
    
    i check on both server with
    Code:
    <?
    phpinfo()
    ?>
    
    and this settings are the same on both servers:
    - magic_quotes
    - open_basedir (different path)
    - register_globals

    in /var/log/httpd/error.log
    Code:
    ....[error] an unknown filter was not added: PHP
    and when i look in popup windows source code:
    in old (working server) i see: <a href="javascript: self.close();"><img src="images/image.jpg" border=0></a>
    in new (isp config) i see: <a href="javascript: self.close();"><img src="images/" border=0></a>

    the file popup.php contains:
    Code:
    <?php
    $img = $HTTP_GET_VARS["img"];
    ?>
    <html>
    <a href="javascript: self.close();"> <img src="images/<?=$img?> </a>
    </html>
    
    what shoul i do?
    thanks
     
  2. till

    till Super Moderator

    Does it work when you replace:

    $img = $HTTP_GET_VARS["img"];

    with:

    $img = $_GET["img"];

    Do you have this line in your php.ini:

    short_open_tag = On
     
  3. it0007

    it0007 New Member

    Yes I have short_open_tag = On in my php.ini

    and after i change

    $img = $HTTP_GET_VARS["img"];

    with:

    $img = $_GET["img"];

    it's working

    Thanks a lot till
     
  4. till

    till Super Moderator

    Then your problem is related to the fact that the (old) long GET and POST arrays where not enabled anymore in PHP. If you dont want to change your code, you can enable them in your php.ini.
     
  5. it0007

    it0007 New Member

    Is there a security issue if i enable old GET & POST ?

    hot to enable old GET & POST arrays ?

    thanks
     
  6. falko

    falko Super Moderator

    No, it's just another naming convention.

    I'm not sure if you can enable this in new PHP versions as these arrays are deprecated since PHP 4.1.0: http://www.php.net/manual/en/reserved.variables.php#reserved.variables.get
     

Share This Page