ISPConfig and Wordpress installation | Error 500.

Discussion in 'Installation/Configuration' started by Maurizio Paolo, Jul 15, 2020.

  1. Maurizio Paolo

    Maurizio Paolo New Member

    I started the installation of Wordpress from the page: http://mysite.com/wp-admin/setup-config.php.
    The installation starts regularly. I entered the database data:

    NAME database
    USER database
    PASSWORD database
    HOSTDATABASE localhost
    Table Prefix wp_

    I get a page with error 500.

    I checked the database with PhpMyadmin.
    The following settings are perhaps incorrect:

    - 1 Database with no privileges;
    - 2 Configuration of pmadb ... not OK
    General characteristics of relations Disabled
    Create a database called 'phpmyadmin' and set the phpMyAdmin storage configuration there.

    Are the indications above correct?

    Database Server:
    Server: Localhost via UNIX socket
    Server type: MariaDB
    Server Connection: SSL inactive Documentation
    Server version: 10.3.22-MariaDB-1ubuntu1 - Ubuntu 20.04
    Protocol version: 10
    User: my --------- me @ localhost
    Server character encoding: UTF-8 Unicode (utf8mb4)

    Web server
    nginx / 1.18.0
    Database client version: libmysql - mysqlnd 7.4.3
    PHP extension: mysqliDocumentation curlDocumentation mbstringDocumentation
    PHP version: 7.4.3

    How can I correctly install wordpress?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Have a look at the error.log file which is in the log folder of the website to find out what the reason for your error is.
     
  3. Maurizio Paolo

    Maurizio Paolo New Member

    There are no errors in the file related to installation or access to pages.

    With the browser I can see the index.html and readme.html page in the "web" directory but the wordpress installation is blocked.

    Do you have any idea?
    Thank you
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Delete the index.html page and access the website again. There must be an error .ogged in the error.log of that website (not the global error,.log, I speak about the error.log of the website) when you get a 5oo error.
     
  5. Maurizio Paolo

    Maurizio Paolo New Member

    I have deleted the index.html file.
    Loading the site starts the installation of Wordpress, but after entering the data the error page 500 appears.

    Unfortunately I don't see log files in the web folder.

    The Error directory contains only the html pages of the errors.
    There are no errors in the log contained in the / log directory.

    Do you have any idea?
    Thank you
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The log files are in the log folder (not the web folder) and it must contain an error when you get a 500 error. The log folder of the website is /var/www/yourdomain.tld/log/ and inside there should be a file with the name error.log and this file contains the error message.
     
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Have you created the website with ISPConfig, and created database user and database for that website?
     
  8. Maurizio Paolo

    Maurizio Paolo New Member

    Thanks for your interest.
    I looked at the error.log file. Unfortunately, there is no error in the file that refers to error 500.

    I only found this line but it refers to my mistake in opening a file in an incorrect path:
    2020/07/15 09:03:23 [error] 791 # 791: * 1611 open () "/var/www/mysite.com/web/home/web1/readme.html" failed (2: No such file or directory), client: 192.1>

    In reference to the question if I created the database, the answer is yes, see also the text of my first post for all the clarifications.
    Do you have an idea about what the problem is?

    Thanks so much.
     
  9. ahrasis

    ahrasis Well-Known Member

    You could have missed nginx directive for wordpress.
     
    Last edited: Jul 15, 2020
  10. Maurizio Paolo

    Maurizio Paolo New Member

    I didn't know this code. In which form should I insert it? Thank you
     
  11. ahrasis

    ahrasis Well-Known Member

     
  12. Maurizio Paolo

    Maurizio Paolo New Member

    Thank you for your answer but the problem is not solved, error 500 always appears.
    Do you have any other ideas?

    Thank you
     
  13. ahrasis

    ahrasis Well-Known Member

    Other than the right nginx directive for WP which must be reflected in its vhost, you should follow @till advise to troubleshoot your problems. Without detail from error.log, nobody can properly help you but keep guessing.
     
  14. Maurizio Paolo

    Maurizio Paolo New Member

    Perhaps a clue may be the fact that errors are not recorded in the log file. What process produces the log file? Nginx, PHP or all together? Which application do you recommend reinstalling? Could it be a permission problem in the database? (see my first post). Thank you.
     
  15. Maurizio Paolo

    Maurizio Paolo New Member

    I send the server log to allow an error reading. The Wordpress installation process started at around 7:19 am. Do you have any idea? Thank you

    Jul 16 07:15:05 maumac systemd-resolved[484]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP.

    Jul 16 07:15:05 maumac systemd-resolved[484]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP.

    Jul 16 07:15:07 maumac dbus-daemon[497]: [system] Activating via systemd: service name='org.freedesktop.PackageKit' unit='packagekit.service' requested by ':1.41' (uid=0 pid=131351 comm="/usr/bin/gdbus call --system --dest org.freedeskto" label="unconfined")

    Jul 16 07:15:07 maumac systemd[1]: Starting PackageKit Daemon...

    Jul 16 07:15:07 maumac PackageKit: daemon start

    Jul 16 07:15:07 maumac dbus-daemon[497]: [system] Successfully activated service 'org.freedesktop.PackageKit'

    Jul 16 07:15:07 maumac systemd[1]: Started PackageKit Daemon.

    Jul 16 07:16:01 maumac CRON[131485]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)

    Jul 16 07:16:01 maumac CRON[131486]: (root) CMD (/usr/local/ispconfig/server/cron.sh 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)

    Jul 16 07:17:01 maumac CRON[131542]: (root) CMD (/usr/local/ispconfig/server/cron.sh 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)

    Jul 16 07:17:01 maumac CRON[131545]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)

    Jul 16 07:17:01 maumac CRON[131547]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)

    Jul 16 07:18:01 maumac CRON[131561]: (root) CMD (/usr/local/ispconfig/server/cron.sh 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)

    Jul 16 07:18:01 maumac CRON[131562]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)

    Jul 16 07:18:17 maumac ntpd[778]: 194.0.5.123 local addr 192.168.1.11 -> <null>

    Jul 16 07:18:25 maumac ntpd[778]: 91.189.89.199 local addr 192.168.1.11 -> <null>

    Jul 16 07:18:26 maumac ntpd[778]: 91.189.89.198 local addr 192.168.1.11 -> <null>

    Jul 16 07:18:26 maumac ntpd[778]: 51.38.27.129 local addr 192.168.1.11 -> <null>

    Jul 16 07:18:32 maumac ntpd[778]: 2001:678:8::123 local addr 2001:b07:5d26:76e8:8def:1bc1:443f:9dc0 -> <null>

    Jul 16 07:18:32 maumac ntpd[778]: 5.249.149.117 local addr 192.168.1.11 -> <null>

    Jul 16 07:19:01 maumac CRON[131574]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)

    Jul 16 07:19:01 maumac CRON[131575]: (root) CMD (/usr/local/ispconfig/server/cron.sh 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)

    Jul 16 07:19:33 maumac wpa_supplicant[532]: wls4: WPA: Group rekeying completed with 28:41:c6:5e:04:d0 [GTK=CCMP]

    Jul 16 07:20:01 maumac CRON[131588]: (getmail) CMD (/usr/local/bin/run-getmail.sh > /dev/null 2>> /dev/null)

    Jul 16 07:20:01 maumac CRON[131590]: (root) CMD (/usr/local/ispconfig/server/cron.sh 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)

    Jul 16 07:20:01 maumac CRON[131591]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
     
  16. nhybgtvfr

    nhybgtvfr Active Member

    i don't use nginx, so not familiar with anything specific to that. but that log file you posted isn't going to be much use.
    you need to post /var/www/<domainname.tld>/log/error.log even if you don't see anything relevant to the problem in it yourself, we might see something you're dismissing as unrelated.

    also you say you're just getting a page with error 500, is that actually during the installation stage, or trying to visit/login to the site after the installation has completed?

    you could also try adding:
    Code:
    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    
    to the sites wp-config.php file, and then try accessing the site again, assuming any part of wordpress is working in some way, it should create a debug log in the wp-content folder, which may give more information than the websites normal error.log
     
  17. Maurizio Paolo

    Maurizio Paolo New Member

    Thanks for the reply. I see page 500 as soon as I start installing Wordpress. The error log file is completely empty. Would I try to reinstall some software, but I'm not sure what the cause may be (Php7.4, Nginx, Database)?

    I checked the database with PhpMyadmin.
    The following settings are perhaps incorrect:

    - 1 Database with no privileges;
    - 2 Configuration of pmadb ... not OK
    General characteristics of relations Disabled
    Create a database called 'phpmyadmin' and set the phpMyAdmin storage configuration there.

    Are the indications above correct?Thanks for any new problem solving ideas.
     
  18. nhybgtvfr

    nhybgtvfr Active Member

    well that just looks like the phpmyadmin database wasn't created and populated when phpmyadmin was installed.

    i would assume that php is ok, since you wouldn't even get the install process started if php wasn't working.
    is this just a single server install or a multi-server?
    is mysql running? can you connect to it as root? can you connect to it as the wordpress sites db user?
    does the wordpress site's database exist?
    i'd make sure mysql is running correctly, and you can connect to it first.
    then try re-installing phpmyadmin and make sure it installs it's database.
    once all that's going ok, can relook at the wordpress problem then.
     
  19. Maurizio Paolo

    Maurizio Paolo New Member

    I checked the database with PhpMyadmin.
    The following settings are perhaps incorrect:
    - 1 Database with no privileges;
    - 2 Configuration of pmadb ... not OK
    General characteristics of relations Disabled
    Create a database called 'phpmyadmin' and set the phpMyAdmin storage configuration there.

    I believe the problem is due to an incorrect installation of PhpMyadmin.

    1- I stopped nginx.
    2- I uninstalled PhpMyadmin with: sudo apt purge phpmyadmin

    3- I redid the installation by typing: sudo apt install phpmyadmin php-mbstring (the recommended procedure in the instructions: apt-get -y install phpmyadmin php-mbstring php-gettext no longer works).

    The procedure didn't ask me the question:
    MySQL application password for phpmyadmin: <- Press Enter

    And so I couldn't build the "phpmyadmin" database and reset the configuration.

    What is the correct procedure to reinstall PhpMyadmin and reconfigure ISPconfig?

    Thanks for your answer.
     
  20. nhybgtvfr

    nhybgtvfr Active Member

    you shouldn't need to reconfigure ispconfig, at least not just for phpmyadmin.

    did it at least ask you
    and if so, did you answer yes or no?
    you can reinstall/reconfigure phpmyadmin with
    or
     

Share This Page