IspConfig and PostFix

Discussion in 'Installation/Configuration' started by Shella, Apr 30, 2009.

  1. Shella

    Shella New Member

    Hi all, I installed IspConfig as Perfect Setup for Debian 4.
    I'm actually try to understand hot to create and use emails.
    If I create an email.. then I go on WebMail in Tools menu of ISPConfig, the webmail manager open asking me email and pass but i'm not able to log-in.

    The output of my postconf -n is this:

    Code:
    postfix: invalid option -- n
    postfix: fatal: usage: postfix [-c config_dir] [-Dv] command
    host-78-129-240-70:~# postfix -n
    postfix: invalid option -- n
    postfix: fatal: usage: postfix [-c config_dir] [-Dv] command
    host-78-129-240-70:~# postconf -n
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    append_dot_mydomain = no
    biff = no
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    home_mailbox = Maildir/
    inet_interfaces = all
    inet_protocols = all
    mailbox_command = 
    mailbox_size_limit = 0
    mydestination = /etc/postfix/local-host-names
    myhostname = host-78-129-240-70.rsclientdns.com
    mynetworks = 127.0.0.0/8
    myorigin = /etc/mailname
    recipient_delimiter = +
    relayhost = 
    smtp_tls_note_starttls_offer = yes
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    smtp_use_tls = yes
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain = 
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    tls_random_source = dev:/dev/urandom
    
    Thanks for time.
    Shella
     
  2. falko

    falko Super Moderator ISPConfig Developer

    For the webmail, you must use an email address to log in instead of the username.
     
  3. Shella

    Shella New Member

    Hi Falko, thanks for reply.
    Of course the email address is what i'm using to log on.
    I tried all the possibilities too... it's strange.
    :-(
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the error messages that you get in the mail log file.
     
  5. Shella

    Shella New Member

    Hi Till, this is what I get in the mail.log:

    Code:
    May  2 11:40:43 host-78-129-240-70 courierpop3login: Connection, ip=[::ffff:127.0.0.1]
    May  2 11:40:43 host-78-129-240-70 courierpop3login: chdir Maildir: No such file or directory
    
    I just realized now that in the server vps where I have to set the domain record I miss the MX.
    Probably I have to config this DNS Record. What I don't understand is what I have to write in the "Mail Server" (Fully Qualified, without a trailing .) field to config this MX Record. Any suggestion?
     
  6. trexen

    trexen Member

    Hi, have you put an X in "Management - server - settings - Email "Maildir"" ?

    FQN = mail.youredomain.com or mx.youredomain.com
     
  7. Shella

    Shella New Member

    Hi. the X on maildir was NOT flagged and now I flag it.
    I can access at my webmail now, thanks a lot.
    Now i will check if mail works. For any problem I will write in some other topic.
    Thanks again.
    Shella
     

Share This Page