ISPConfig and Postfix (error only in sending mails)

Discussion in 'Installation/Configuration' started by crash0, Jul 11, 2008.

  1. crash0

    crash0 New Member

    Hi there all of you.

    I would like to consider myself a newbie in Debian OS.
    During the past few days i installed ISPConfig and Webmin along with all the appropriate packages. I faced several problems with the relay error, authentication error and stuff like that. Searching the internet i fould solution to most of them.

    I am one step to finalize my installation but i am facing a problem i could not find anywhere the solution to. I would really appreciate your help on this.

    Along with Postfix and Dovecot pop3 / imapd i can receive mail in my created accounts but when it is to sending, the email client shows me that is sending the mail and several minutes later says that the connection has been timed out (contact your system admin ISP etc). All the internal - external ports have been enabled and my isp does not block ports 110 and 25.

    Thank you all in advance ...

    [edit] Now what i ve done. I checked out the solutions in and now i have a responce from my server (and i still can't send emails). I have checked "this server needs authorization" in my account properties and now i am getting a username and password prompt again and again. The username and password are correct and tested with testsaslauthd -u [username] -p [password] but the prompt won't go away :(

    I am searching to find the answer in this particular error within the mail.log ( sasl authentication problem: unable to open Berkeley db /etc/sasldb2: permission denied ). That is why the usarname and password window keeps coming up.
    Last edited: Jul 11, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

  3. crash0

    crash0 New Member

    falko thank you very much for your reply but i decided to install everything again. Although i didn't mention that i wasn't actually running debian itself but Ubuntu 7.10 not the server version.

    The thing is that now everything seems to be working just fine. I used my domain for web / mail and generally the configuration of ispconfig but i am still facing the same thing (relay access denied) when i am configuring another domain. I did the same moves as in mine. Created mx records etc and now when i am sending email from my mailserver (e.g everything works just fine. When i am setting up in ms outlook another account listening on ( the mail goes in sent items and i receive a relay access denied error. I tried to change the /etc/mailname file to add another domain for the system but postfix crashes.

    I must say that sending mails from my domain doesn't needs the server requires authentication option enabled. I tried enabling this on the other account but didn't worked.

    I would really appreciated pointing out some directions.

    Thank you!
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/postfix/
  5. crash0

    crash0 New Member

    # See /usr/share/postfix/ for a commented, more complete version

    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
    smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    #mydestination =, localhost.localdomain, , localhost
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = $myhostname, localhost.localdomain, $mydomain, /etc/postfix/local-host-names
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_mynetworks permit_inet_interfaces check_relay_domains permit_sasl_authenticated permit_mx_backup
    allow_untrusted_routing = yes
    myhostname =
    mynetworks =,

    I still have the same error. Relay access denied.
    Last edited: Jul 16, 2008
  6. falko

    falko Super Moderator ISPConfig Developer

    Is the not-working domain listed in /etc/postfix/local-host-names?

Share This Page