ISPconfig and OJS

Discussion in 'Installation/Configuration' started by mbria, Sep 27, 2007.

  1. mbria

    mbria New Member


    I'm moving all my webs to ISPconfig and after some tunning with .htaccess most of them perfectly work, so first at all: Thanks a lot for the great work done with this piece of soft. ;-)

    The only little thing I need to fix is related with Open Journal System (OJS) that is a great CMS focused on building and manage an e-journal.

    The problem is that I had pathinfo in my former hosting service and now looks like it didn't work... so urls don't look as nice as before and stored paths don't redirect to the right place.

    I'm running an "perfect setup" ubuntu 7.04 server, with last ISPconfig 2.2.16 and suPHP enabled as described in some manuals of this site.

    phpinfo() reports cgi.fix_pathinfo as enabled.
    But OJS (the only application I have that needs it) is unable to run with this set on.

    Any clue about what it happening? A link with a RTFM is a perfectly acceptable answer... because I know this issue is just in the limit of ISPconfig and OJS, but I don't know what else to look or where else to ask.

    Thanks a lot in advance for your help,

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you get any errors in the error.log of this website? In most cases such problems are related to apache directives which are not allowed in the .htaccess file of the site. You can put these directives in the apache directives field in the website settings instead.
  3. mbria

    mbria New Member

    Sorry... I missed to say that I fixed it.

    Till, thanks a lot to take time to answer.

    Finally I fixed it... and the solution was quite obvious. :eek:
    As I said, cgi.fix_pathinfo was enabled... and OJS expects this to be disabled.
    Changing this at was enough to recover my OJS.

    BTW, is ISPconfig+suPHP changing this? Because normally isn't a good idea to change default settings although it will improve performance, or whatever...

    I post here a link to the OJS thread where I publish all the trouble, just in case others fall in a similar issue:

    So in concussion: You can add an new check in your list of "ISPconfig tested" web applications. ;-)

    Again, thanks for your help,

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig does not change the php.ini file :)

Share This Page