ISPConfig and mcrypt

Discussion in 'ISPConfig 3 Priority Support' started by Tom John, Jun 23, 2019.

  1. Tom John

    Tom John Member HowtoForge Supporter

  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    That shows the command line PHP has mcrypt. Enable it also for your web server.
     
  3. Tom John

    Tom John Member HowtoForge Supporter

    Hi,
    i changed the php.ini already to:
    Code:
    ;extension=interbase
    ;extension=ldap
    extension=mcrypt.so
    ;extension=mbstring
    
    then i restarted apache2
    but however it does not work and i get the same error
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    In which php.ini did you enable it and which PHP mode does this website use?
     
  5. Tom John

    Tom John Member HowtoForge Supporter

    thanks for your answer.
    /etc/php/7.2/apache2/php.ini
    how can i find out which php mode the website use?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You can see it in the website settings in ISPConfig. The file /etc/php/7.2/apache2/php.ini is the wrong php.ini as mod_php is normally not used anymore today. Change the cgi and php-fpm php.ini files and restart php-fpm daemon and apache.
     
  7. Tom John

    Tom John Member HowtoForge Supporter

    You are great like always ;)
    thanks so much for your help it works
     

Share This Page