ispconfig and mambo

Discussion in 'Installation/Configuration' started by shajazzi, Jan 2, 2006.

  1. shajazzi

    shajazzi New Member

    Thanks Falko,
    Does this mean that I cannot offer migration for sites already using mambo/phpshop without disabling php safe mode right across my Linux server?

    Will phpshop just stop working after FTP migration? ie Test site running on Windows http://www.3lions2006.com

    Shajazzi
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Mombo wont work with SafeMode enabled. Have you thought about using PHP as CGI together with SuExec or the suPHP extension. then your installation will be secure without needing PHPSafeMode. But the performance of this solution is not as high as with mod_php.
     
  3. shajazzi

    shajazzi New Member

    OK thanks Till,
    This time I set up a new site in ispconfig and checked all the boxes accept PHP Safe Mode and extracted joomla 1.0.7 eCommerce to the appropriate web folder and started the installation.
    The first page confirms that safe mode is OFF.
    The install goes well and I can log in to back end as administrator but cannot access phpshop when i go to view my site all I get is a blank page.
    If I install joomla first and then phpshop I loose the front end but can log in to the back end.
    Also in the PHP.ini safe mode is OFF.

    I know very little about PHP and even less about CGI.



    shajazzi
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Maybe a permissions problem.
    Anything in the Apache logs?
     
  5. shajazzi

    shajazzi New Member

    Thanks Falko, yes I am getting some Errors

    [Sat Jan 21 08:50:57 2006] [error] [client 192.168.1.100] File does not exist: /srv/www/web13/web/favicon.ico
    [Sat Jan 21 08:52:17 2006] [error] [client 192.168.1.100] PHP Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 92160 bytes) in /srv/www/web13/web/administrator/components/com_virtuemart/classes/ps_session.php on line 203, referer: http://www.3lions2006.co.uk/administrator/index2.php
    [Sat Jan 21 08:52:17 2006] [error] [client 192.168.1.100] File does not exist: /srv/www/web13/web/favicon.ico
    [Sat Jan 21 08:52:40 2006] [error] [client 192.168.1.100] PHP Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 368640 bytes) in /srv/www/web13/web/administrator/components/com_virtuemart/classes/ps_product.php on line 717, referer: http://www.3lions2006.co.uk/administrator/index2.php
    [Sat Jan 21 08:52:40 2006] [error] [client 192.168.1.100] PHP Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 368640 bytes) in /srv/www/web13/web/administrator/components/com_virtuemart/classes/ps_product.php on line 717, referer: http://www.3lions2006.co.uk/administrator/index2.php
    [Sat Jan 21 08:52:44 2006] [error] [client 192.168.1.100] PHP Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 368640 bytes) in /srv/www/web13/web/administrator/components/com_virtuemart/classes/ps_product.php on line 717, referer: http://www.3lions2006.co.uk/administrator/index2.php
    [Sat Jan 21 08:54:03 2006] [error] [client 192.168.1.100] PHP Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 92160 bytes) in /srv/www/web13/web/administrator/components/com_virtuemart/classes/ps_session.php on line 203, referer: http://www.3lions2006.co.uk/administrator/index2.php
    [Sat Jan 21 08:54:04 2006] [error] [client 192.168.1.100] File does not exist: /srv/www/web13/web/favicon.ico
    [Sat Jan 21 08:54:08 2006] [error] [client 192.168.1.100] File does not exist: /srv/www/web13/web/favicon.ico
    [Sat Jan 21 08:54:14 2006] [error] [client 192.168.1.100] PHP Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 23040 bytes) in /srv/www/web13/web/administrator/components/com_virtuemart/classes/ps_html.php on line 404
    [Sat Jan 21 08:54:14 2006] [error] [client 192.168.1.100] File does not exist: /srv/www/web13/web/favicon.ico
    [Sat Jan 21 08:54:38 2006] [error] [client 192.168.1.100] File does not exist: /srv/www/web13/web/favicon.ico

    shajazzi
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You have to set your php memory limit higher. Open your php.ini and set the memory limit to 32 MB for example:

    memory_limit = 32M

    Then restart your apache webserver.


    The php.ini is located in /etc/php5/apache/php.ini or /etc/php4/apache/php.ini or something similar. You can find it with the command:

    locate php.ini

    The correct file is the one located in the /etc/... directory.
     
  7. shajazzi

    shajazzi New Member

    Thanks Till,
    I`ve played around with the data base on my windows server and some how lost the phpshop, but that is not important at the moment as i can sort that out later.
    The problem is I have 404 sef installed, when i change htaccess.txt to .htaccess as requested in mambo global configuration/SEO the file completely disappears.

    shajazzi
     
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Do you get any error messages, also in the Apache error log?
    What's in .htaccess?
     
  9. shajazzi

    shajazzi New Member

    Falko I am getting the following errors:


    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2(/srv/www/web9/web/modules/mod_extcalendar_minical.php) [<a href='function.module2'>function.module2</a>]: failed to open stream: No such file or directory in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2() [<a href='function.include'>function.include</a>]: Failed opening '/srv/www/web9/web/modules/mod_extcalendar_minical.php' for inclusion (include_path='.:') in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2(/srv/www/web9/web/modules/mod_artbanners1.php) [<a href='function.module2'>function.module2</a>]: failed to open stream: No such file or directory in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2() [<a href='function.include'>function.include</a>]: Failed opening '/srv/www/web9/web/modules/mod_artbanners1.php' for inclusion (include_path='.:') in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2(/srv/www/web9/web/modules/mod_artbanners1.php) [<a href='function.module2'>function.module2</a>]: failed to open stream: No such file or directory in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2() [<a href='function.include'>function.include</a>]: Failed opening '/srv/www/web9/web/modules/mod_artbanners1.php' for inclusion (include_path='.:') in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2(/srv/www/web9/web/modules/mod_bookmarkus.php) [<a href='function.module2'>function.module2</a>]: failed to open stream: No such file or directory in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2() [<a href='function.include'>function.include</a>]: Failed opening '/srv/www/web9/web/modules/mod_bookmarkus.php' for inclusion (include_path='.:') in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] File does not exist: /srv/www/web9/web/images/owen, referer: http://www.englandshirt.com/index.php

    I do not have a .htaccess file, but I do have an htaccess.txt.
    If I create an empty file and name it htaccess the file is created.
    I then rename it to .htaccess the file disappears and i cannot access my site.
    Also if I rename the htaccess.txt file to .htaccess the same happens.

    shajazzi
     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I guess you get these warnings without .htaccess?

    Which warnings do you get in the Apache error log when you rename htaccess.txt to .htaccess? What'S in htaccess.txt/.htaccess?
     
  11. shajazzi

    shajazzi New Member

    This is what is in htaccess.txt

    ##
    # @version $Id: htaccess.txt,v 1.5 2005/01/22 23:00:27 spacemonkey Exp $
    # @package Mambo
    # @copyright (C) 2000 - 2005 Miro International Pty Ltd
    # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
    # Mambo is Free Software
    ##

    #
    # mod_rewrite in use
    #

    RewriteEngine On

    # Uncomment following line if your webserver's URL
    # is not directly related to physical file paths.
    # Update YourMamboDirectory (just / for root)

    # RewriteBase /YourMamboDirectory

    #
    # Rules
    #

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*) index.php

    and these are the warnings i get when i change the name to .htaccess

    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2(/srv/www/web9/web/modules/mod_extcalendar_minical.php) [<a href='function.module2'>function.module2</a>]: failed to open stream: No such file or directory in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2() [<a href='function.include'>function.include</a>]: Failed opening '/srv/www/web9/web/modules/mod_extcalendar_minical.php' for inclusion (include_path='.:') in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2(/srv/www/web9/web/modules/mod_artbanners1.php) [<a href='function.module2'>function.module2</a>]: failed to open stream: No such file or directory in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2() [<a href='function.include'>function.include</a>]: Failed opening '/srv/www/web9/web/modules/mod_artbanners1.php' for inclusion (include_path='.:') in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2(/srv/www/web9/web/modules/mod_artbanners1.php) [<a href='function.module2'>function.module2</a>]: failed to open stream: No such file or directory in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2() [<a href='function.include'>function.include</a>]: Failed opening '/srv/www/web9/web/modules/mod_artbanners1.php' for inclusion (include_path='.:') in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2(/srv/www/web9/web/modules/mod_bookmarkus.php) [<a href='function.module2'>function.module2</a>]: failed to open stream: No such file or directory in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2() [<a href='function.include'>function.include</a>]: Failed opening '/srv/www/web9/web/modules/mod_bookmarkus.php' for inclusion (include_path='.:') in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
    [Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] File does not exist: /srv/www/web9/web/images/owen, referer: http://www.englandshirt.com/index.php

    There are no additional errors written to the log.

    Now I try to create a file called .htaccess because i cannot see the file that i have renamed, I recieve FILE ALREADY EXISTS, but where is it?
    I also recieved a crash error from Konqueror The application Konqueror crashed and caused the signal 11(SIGSEGV)

    This appears when i try to access my site .

    Forbidden

    You don't have permission to access /index.php on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.0.53 (Linux/SUSE) Server at www.englandshirt.com Port 80

    OH and by the way I am local at the moment on my Linux server.

    shajazzi
     
  12. shajazzi

    shajazzi New Member

    Sorry Falko, I just refreshed the error log and these are the additional errors:

    [Sun Jan 29 11:00:18 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/index.php
    [Sun Jan 29 11:00:18 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/error/forbidden.html
    [Sun Jan 29 11:00:19 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/favicon.ico
    [Sun Jan 29 11:00:19 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/error/forbidden.html
    [Sun Jan 29 11:06:34 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/, referer: http://www.howtoforge.com/forums/showthread.php?p=13507
    [Sun Jan 29 11:06:34 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/error/forbidden.html, referer: http://www.howtoforge.com/forums/showthread.php?p=13507
    [Sun Jan 29 11:06:34 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/favicon.ico
    [Sun Jan 29 11:06:34 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/error/forbidden.html

    shajazzi
     
  13. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  14. shajazzi

    shajazzi New Member

    Thanks falko,
    I had a look at the threads you mentioned and no luck i`m afraid.
    My problem is i cannot edit the .htaccess file because i haven`t one.
    The closest i can get is to create a file and name it htaccess but this is not going to work so I change the file from htaccess to .htaccess and the file disappears so then i cannot edit it.
    I do not know whats going on. I`ve come this far, all I want is frendly URLS.:(
     
    Last edited: Jan 30, 2006
  15. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Thats normal, files that begin with a dot are hidden files in linux.

    You can either edit it on the commandline, to get a file listing use "ls -la" command or you use a program like winSCP to connect from a windows workstation and edit the file.

    If you want to see the file in FTP, you will have to modify the LsDefaultOption in your ftp server configuration.
     
  16. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Till's right. I guess you use FTP to manage your .htaccess file which normally doesn't work unless you configure your FTP server in a different way (see Till's post above).

    I recommend to manage that file on the command line. You can use an editor like vi to edit the file on the command line. Read here to learn how to use vi: http://www.howtoforge.com/faq/12_15_en.html
     
  17. shajazzi

    shajazzi New Member

    Thanks falko and till,
    you`ve been a great help but i still cannot get .htaccess to work.
    I tried this to see if .htaccess override is allowed:

    I deleted everything from my .htaccess and replaced it with this
    Redirect /google.html http://www.google.com
    then i pionted the browser to http://www.englandshirt.com/google.html and this works fine.
    When replace Redirect /google.html http://www.google.com with the following



    mod_gzip_on Yes

    <Files .htaccess>
    order allow,deny
    deny from all
    </Files>

    ErrorDocument 404 /errordocs/error404.php
    ErrorDocument 400 /errordocs/error404.php

    DirectoryIndex index.htm

    Options +FollowSymlinks +MultiViews


    ##
    # @version $Id: readme.inc,v 1.3 2005/02/13 18:03:41 marlboroman_2k Exp $
    # @package Mambo_4.5
    # @copyright (C) 2000 - 2004 Miro International Pty Ltd
    # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
    # Mambo is Free Software
    ##

    #


    # mod_rewrite in use
    #
    DirectoryIndex index.php

    RewriteEngine On

    # for apache on windows you might need to uncomment
    # this Options line
    #Options +SymlinksIfOwnerMatch

    # Uncomment following line if your webserver's URL
    # is not directly related to physival file paths.
    # Update YourMamboDirectory (just / for root)

    RewriteBase /
    #
    # Rules
    #

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)/ index.php

    and enable SEO in mambo back end i can only see my homepage.

    When I click on a link i get errors like this one:

    Not Found

    The requested URL /component/option,com_contact/Itemid,3/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.0.53 (Linux/SUSE) Server at www.englandshirt.com Port 80


    If I disable SEO in mambo backend, now I can see all the links again but they are no search engine friendly.
     
    Last edited: Feb 4, 2006
  18. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Can you try this instead?

    Code:
    mod_gzip_on Yes
    
    <Files .htaccess>
    order allow,deny
    deny from all
    </Files>
    
    ErrorDocument 404 /errordocs/error404.php
    ErrorDocument 400 /errordocs/error404.php
    
    DirectoryIndex index.htm
    
    Options +FollowSymlinks +MultiViews
    
    
    ##
    # @version $Id: readme.inc,v 1.3 2005/02/13 18:03:41 marlboroman_2k Exp $
    # @package Mambo_4.5
    # @copyright (C) 2000 - 2004 Miro International Pty Ltd
    # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
    # Mambo is Free Software
    ##
    
    #
    
    
    # mod_rewrite in use
    #
    DirectoryIndex index.php
    
    RewriteEngine On
    
    # for apache on windows you might need to uncomment
    # this Options line
    #Options +SymlinksIfOwnerMatch
    
    # Uncomment following line if your webserver's URL
    # is not directly related to physival file paths.
    # Update YourMamboDirectory (just / for root)
    
    RewriteBase /
    #
    # Rules
    #
    
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    [B][COLOR="Red"]RewriteRule ^(.*) index.php[/COLOR][/B]
     
  19. shajazzi

    shajazzi New Member

    Thanks falko,
    I tried as you suggested but recieve this error.

    Not Found

    The requested URL /Contact-Us/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.0.53 (Linux/SUSE) Server at www.englandshirt.com Port 80

    In the address I get this

    http://www.englandshirt.com/Contact-Us/

    I copied the .htaccess that is running on my Windows server but still no joy. I also tried different versions of SEF .I tried about all versions of .htaccess code that I`ve found in the mambo forums but get just slight variations of the same error.

    shajazzi
     
  20. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Can you try these?

    Code:
    mod_gzip_on Yes
    
    <Files .htaccess>
    order allow,deny
    deny from all
    </Files>
    
    ErrorDocument 404 /errordocs/error404.php
    ErrorDocument 400 /errordocs/error404.php
    
    DirectoryIndex index.htm
    
    Options +FollowSymlinks +MultiViews
    
    
    ##
    # @version $Id: readme.inc,v 1.3 2005/02/13 18:03:41 marlboroman_2k Exp $
    # @package Mambo_4.5
    # @copyright (C) 2000 - 2004 Miro International Pty Ltd
    # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
    # Mambo is Free Software
    ##
    
    #
    
    
    # mod_rewrite in use
    #
    DirectoryIndex index.php
    
    RewriteEngine On
    
    # for apache on windows you might need to uncomment
    # this Options line
    #Options +SymlinksIfOwnerMatch
    
    # Uncomment following line if your webserver's URL
    # is not directly related to physival file paths.
    # Update YourMamboDirectory (just / for root)
    
    #RewriteBase /
    #
    # Rules
    #
    
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*) /index.php



    Code:
    mod_gzip_on Yes
    
    <Files .htaccess>
    order allow,deny
    deny from all
    </Files>
    
    ErrorDocument 404 /errordocs/error404.php
    ErrorDocument 400 /errordocs/error404.php
    
    DirectoryIndex index.htm
    
    Options +FollowSymlinks +MultiViews
    
    
    ##
    # @version $Id: readme.inc,v 1.3 2005/02/13 18:03:41 marlboroman_2k Exp $
    # @package Mambo_4.5
    # @copyright (C) 2000 - 2004 Miro International Pty Ltd
    # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
    # Mambo is Free Software
    ##
    
    #
    
    
    # mod_rewrite in use
    #
    DirectoryIndex index.php
    
    # for apache on windows you might need to uncomment
    # this Options line
    #Options +SymlinksIfOwnerMatch
    
    # Uncomment following line if your webserver's URL
    # is not directly related to physival file paths.
    # Update YourMamboDirectory (just / for root)
    
    <IfModule mod_rewrite.c>
     RewriteEngine on
     RewriteCond %{REQUEST_FILENAME} !-f
     RewriteCond %{REQUEST_FILENAME} !-d
     RewriteRule ^(.*)$ /index.php?q=$1 [L,QSA]
    </IfModule>
    Code:
    mod_gzip_on Yes
    
    <Files .htaccess>
    order allow,deny
    deny from all
    </Files>
    
    ErrorDocument 404 /errordocs/error404.php
    ErrorDocument 400 /errordocs/error404.php
    
    DirectoryIndex index.htm
    
    Options +FollowSymlinks +MultiViews
    
    
    ##
    # @version $Id: readme.inc,v 1.3 2005/02/13 18:03:41 marlboroman_2k Exp $
    # @package Mambo_4.5
    # @copyright (C) 2000 - 2004 Miro International Pty Ltd
    # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
    # Mambo is Free Software
    ##
    
    #
    
    
    # mod_rewrite in use
    #
    DirectoryIndex index.php
    
    # for apache on windows you might need to uncomment
    # this Options line
    #Options +SymlinksIfOwnerMatch
    
    # Uncomment following line if your webserver's URL
    # is not directly related to physival file paths.
    # Update YourMamboDirectory (just / for root)
    
    <IfModule mod_rewrite.c>
     RewriteEngine on
     RewriteBase /
     RewriteCond %{REQUEST_FILENAME} !-f
     RewriteCond %{REQUEST_FILENAME} !-d
     RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
    </IfModule>
    Is your Mambo installation in the top-level directory of your web site, or is it in a subdirectory?
     

Share This Page