ispconfig and mambo

Discussion in 'Installation/Configuration' started by shajazzi, Jan 2, 2006.

  1. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I doubt that your Apache user and group are root because you have to compile Apache in a special way so that Apache allows to be run as root.
    You can find the Apache owner and group in the Apache configuration file.

    Please find out to which directory your applications try to upload, and then post the output of
    Code:
    ls -la /path/to/upload_directory
    I'm sure it's a permissions problem.
    Maybe the installation instructions of your applications mention something about directory permissions.
     
  2. shajazzi

    shajazzi New Member

    Thanks for the reply Blu3

    The install new components section looks like this after a failed install::confused:

    Upload Package File

    Upload component - Upload Failed
    ERROR: Could not find an XML setup file in the package.
    [ Continue ... ]
    Upload component - Failed
    Installation file not found:
    /srv/www/web13/web/media/install_43c0519ce09a8/
    [ Continue ... ]

    Install from directory

    Upload new component - Error
    Installation file not found:
    /srv/www/web13/web/administrator/components/com_installer/component/
    [ Continue ... ]

    Everything is writeable:

    media/ Writeable
    administrator/components/ Writeable
    components/ Writeable
    images/stories/ Writeable



    I tried to installing components from from both my desktop and root, both with the same results.
    I also logged into administration from another machine running on windows and tried to upload component from it`s Desktop but unfortunately got the same results.

    shajazzi.
     
  3. shajazzi

    shajazzi New Member

    Thanks falko,
    I could not find anything that relates to owner or group in the etc/apache2/httpd.conf only when I right click on under ownership:

    user root
    group root

    Maybe i am looking at the wrong file or folder.:confused:



    I have just noticed something else.
    There is no .htaccess file but instead htaccess.txt.
    I cannot reach the site from www.mysite.co.uk but I can from www.mysite.co.uk/index.php.

    And another funny thing. I copied mysite folder from my windows server on to a disc so that i could transfer it to my Linux server. I opened the folder and the .htaccess file was missing (something weird going on)

    shajazzi
     
  4. Blu3

    Blu3 New Member

    Hi again,

    Well it looks like that might be your problem all along.

    " ERROR: Could not find an XML setup file in the package. "

    Basically components in Joomla/Mambo use a xml file to tell Joomla what it is and what to do with it.

    What component are you trying to install?

    And are you sure that there is an xml file included with it?

    Also have you checked to be sure you have xml support on your apache/php installation?

    Honestly it sounds like other than, you should be ok. If all your dirs are Writable and you have tried the above, then I would check those two things. I have some experience with joomla, and it seems to be pretty much smooth sailing for everyone of my joomla installs.
     
  5. Blu3

    Blu3 New Member

    Sorry to double post Admins.

    I just read your last post shajazzi, and the htaccess.txt is normal. This is the default and should remain this way. If you change the file to .htaccess then you will not be able to browse your site. joomla uses htaccess.txt, versus .htaccess, for cross compadiblity, ie: Win, Linux, Apache etc...

    Just an fyi
     
  6. shajazzi

    shajazzi New Member

    The component that i am trying to install is Recommend_2_2>zip
    I check for the XML file and it does exist.
    I deleted from my windows server and then reinstalled it and it works ok
    so there is nothing wrong with the Zip folder
    How do i check to see if i have xml support on my apache/php installation?

    sorry I`m a bit lost in Linux:confused:

    shajazzi
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please post the output of
    Code:
    ls -la /srv/www/web13/web/
    ls -la /srv/www/web13/web/administrator/
    ls -la /srv/www/web13/web/images/
    It is possible that there are other files included in /etc/apache2/httpd.conf. Please have a look at those files, too. Normally, under SuSE, the Apache owner is wwwrun, and the group is www.
     
  8. shajazzi

    shajazzi New Member

    Thanks for the reply falko
    The results of the codes are
    :ls -la /srv/www/web13/web/

    total 98
    drwxrwxrwx 15 root web13 792 Jan 7 20:30 .
    drwxr-xr-x 8 root web13 192 Jan 7 20:18 ..
    -rw-rw-rw- 1 500 500 23333 Feb 16 2005 CHANGELOG
    -rw-rw-rw- 1 500 500 3725 Jan 22 2005 INSTALL
    -rw-rw-rw- 1 500 500 17977 Dec 3 2004 LICENSE
    drwxrwxrwx 9 500 500 360 Feb 16 2005 administrator
    drwxrwxrwx 3 500 500 112 Feb 16 2005 cache
    drwxrwxrwx 16 500 500 504 Feb 16 2005 components
    -rw-rw-rw- 1 500 500 2306 Jan 7 23:32 configuration.php
    drwxrwxrwx 2 500 500 272 Feb 16 2005 editor
    drwxrwxrwx 2 root web13 576 Jan 7 20:18 error
    -rw-rw-rw- 1 500 500 1269 Jan 24 2005 globals.php
    drwxrwxrwx 3 500 500 2528 Feb 16 2005 help
    -rw-rw-rw- 1 500 500 580 Jan 22 2005 htaccess.txt
    drwxrwxrwx 6 500 500 384 Feb 16 2005 images
    drwxrwxrwx 9 500 500 1072 Feb 16 2005 includes
    -rw-rw-rw- 1 root web13 1214 Jan 7 20:18 index.html
    -rw-rw-rw- 1 500 500 5332 Feb 16 2005 index.php
    -rw-rw-rw- 1 500 500 3365 Feb 10 2005 index2.php
    drwxrwxrwx 2 500 500 184 Feb 16 2005 language
    -rw-rw-rw- 1 500 500 453 Jan 6 2005 mainbody.php
    drwxrwxrwx 6 500 500 184 Feb 16 2005 mambots
    drwxrwxrwx 2 500 500 112 Jan 7 23:41 media
    drwxrwxrwx 2 500 500 1296 Feb 16 2005 modules
    -rw-rw-rw- 1 500 500 2005 Jan 6 2005 offline.php
    -rw-rw-rw- 1 500 500 451 Jan 6 2005 pathway.php
    -rw-rw-rw- 1 500 500 286 Dec 3 2004 robots.txt
    drwxrwxrwx 6 500 500 208 Feb 16 2005 templates

    ls -la /srv/www/web13/web/administrator/

    total 25
    drwxrwxrwx 9 500 500 360 Feb 16 2005 .
    drwxrwxrwx 15 root web13 792 Jan 7 20:30 ..
    drwxrwxrwx 2 500 500 80 Feb 16 2005 backups
    drwxrwxrwx 31 500 500 1000 Feb 16 2005 components
    drwxrwxrwx 2 500 500 2920 Feb 16 2005 images
    drwxrwxrwx 4 500 500 288 Feb 16 2005 includes
    -rw-rw-rw- 1 500 500 3536 Feb 13 2005 index.php
    -rw-rw-rw- 1 500 500 3201 Jan 6 2005 index2.php
    -rw-rw-rw- 1 500 500 4455 Jan 6 2005 index3.php
    -rw-rw-rw- 1 500 500 1576 Jan 6 2005 logout.php
    drwxrwxrwx 2 500 500 608 Feb 16 2005 modules
    drwxrwxrwx 2 500 500 216 Feb 16 2005 popups
    drwxrwxrwx 4 500 500 144 Feb 16 2005 templates


    ls -la /srv/www/web13/web/images/

    total 38
    drwxrwxrwx 6 500 500 384 Feb 16 2005 .
    drwxrwxrwx 15 root web13 792 Jan 7 20:30 ..
    drwxrwxrwx 2 500 500 1080 Feb 16 2005 M_images
    drwxrwxrwx 2 500 500 152 Feb 16 2005 banners
    -rw-rw-rw- 1 500 500 151 Dec 3 2004 blank.png
    -rw-rw-rw- 1 500 500 564 Dec 3 2004 cancel.png
    -rw-rw-rw- 1 500 500 1457 Dec 3 2004 cancel_f2.png
    -rw-rw-rw- 1 500 500 1406 Dec 3 2004 favicon.ico
    -rw-rw-rw- 1 500 500 44 Dec 3 2004 index.html
    -rw-rw-rw- 1 500 500 7274 Dec 3 2004 logo.png
    -rw-rw-rw- 1 500 500 698 Dec 3 2004 save.png
    -rw-rw-rw- 1 500 500 1822 Dec 3 2004 save_f2.png
    drwxrwxrwx 2 500 500 256 Feb 16 2005 smilies
    drwxrwxrwx 4 500 500 344 Feb 16 2005 stories

    All the files and folders under apache2
    owner root
    group root

    shajazzi
     
  9. admin

    admin Administrator Staff Member Moderator

    Why do most of the files/directories belong to user and group 500?

    In one of the Apache configuration files you should have something like this:

    Code:
    User wwwuser
    Group www
    The permissions of the configuration files are not what I'm talking about.
     
  10. shajazzi

    shajazzi New Member

    OK I`ve found it in uid.conf, uid.conf010106, uid.conf04-01-06, uid.conf28-12-05 and uid.conf17-12-05.
    Silly question:confused:
    What should i do with them?

    shajazzi
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's in uid.conf?
     
  12. shajazzi

    shajazzi New Member

    User wwwrun
    Group www

    shajazzi
     
  13. shajazzi

    shajazzi New Member

    I installed another version of Mambo and these are the results of the following:
    ls -la /srv/www/web17/web/
    ls -la /srv/www/web17/web/administrator/
    ls -la /srv/www/web17/web/images/

    ls -la /srv/www/web17/web/
    total 118
    drwxrwxrwx 15 root web17 864 Jan 9 00:37 .
    drwxr-xr-x 8 root web17 192 Jan 9 00:29 ..
    -rw-rw-rw- 1 root root 32817 Dec 31 19:35 CHANGELOG.php
    -rw-rw-rw- 1 root root 4064 Dec 16 19:04 INSTALL.php
    -rw-rw-rw- 1 root root 17977 Dec 16 19:04 LICENSE
    -rw-rw-rw- 1 root root 454 Dec 16 19:04 README
    drwxrwxrwx 9 root root 360 Jan 9 00:30 administrator
    drwxrwxrwx 2 root root 80 Jan 9 00:30 cache
    drwxrwxrwx 16 root root 504 Jan 9 00:30 components
    -rw-r--r-- 1 wwwrun www 2317 Jan 9 00:41 configuration.php
    -rw-rw-rw- 1 root root 3725 Dec 16 19:04 configuration.php-dist
    drwxrwxrwx 2 root root 272 Jan 9 00:30 editor
    drwxrwxrwx 2 root web17 576 Jan 9 00:29 error
    -rw-rw-rw- 1 root root 1386 Dec 19 04:23 globals.php
    drwxrwxrwx 3 root root 2848 Jan 9 00:30 help
    -rw-rw-rw- 1 root root 578 Dec 16 19:04 htaccess.txt
    drwxrwxrwx 6 root root 384 Jan 9 00:30 images
    drwxrwxrwx 10 root root 1104 Jan 9 00:30 includes
    -rw-rw-rw- 1 root web17 1212 Jan 9 00:29 index.html
    -rw-rw-rw- 1 root root 6094 Dec 21 21:28 index.php
    -rw-rw-rw- 1 root root 3923 Dec 21 21:28 index2.php
    drwxrwxrwx 2 root root 184 Jan 9 00:30 language
    -rw-rw-rw- 1 root root 453 Dec 16 19:04 mainbody.php
    drwxrwxrwx 6 root root 184 Jan 9 00:30 mambots
    drwxrwxrwx 2 root root 112 Jan 9 00:42 media
    drwxrwxrwx 2 root root 1296 Jan 9 00:30 modules
    -rw-rw-rw- 1 root root 2005 Dec 16 19:04 offline.php
    -rw-rw-rw- 1 root root 451 Dec 16 19:04 pathway.php
    -rw-rw-rw- 1 root root 286 Dec 16 19:04 robots.txt
    drwxrwxrwx 4 root root 144 Jan 9 00:30 templates

    ls -la /srv/www/web17/web/administrator
    total 33
    drwxrwxrwx 9 root root 360 Jan 9 00:30 .
    drwxrwxrwx 15 root web17 864 Jan 9 00:37 ..
    drwxrwxrwx 2 root root 80 Jan 9 00:30 backups
    drwxrwxrwx 31 root root 1000 Jan 9 00:30 components
    drwxrwxrwx 2 root root 2920 Jan 9 00:30 images
    drwxrwxrwx 4 root root 288 Jan 9 00:30 includes
    -rw-rw-rw- 1 root root 4144 Dec 16 19:03 index.php
    -rw-rw-rw- 1 root root 4155 Dec 16 19:03 index2.php
    -rw-rw-rw- 1 root root 5046 Dec 16 19:03 index3.php
    -rw-rw-rw- 1 root root 1576 Dec 16 19:03 logout.php
    drwxrwxrwx 2 root root 608 Jan 9 00:30 modules
    drwxrwxrwx 2 root root 216 Jan 9 00:30 popups
    drwxrwxrwx 4 root root 144 Jan 9 00:30 templates


    ls -la /srv/www/web17/web/images/
    total 38
    drwxrwxrwx 6 root root 384 Jan 9 00:30 .
    drwxrwxrwx 15 root web17 864 Jan 9 00:37 ..
    drwxrwxrwx 2 root root 1080 Jan 9 00:30 M_images
    drwxrwxrwx 2 root root 240 Jan 9 00:30 banners
    -rw-rw-rw- 1 root root 151 Dec 16 19:04 blank.png
    -rw-rw-rw- 1 root root 564 Dec 16 19:04 cancel.png
    -rw-rw-rw- 1 root root 1457 Dec 16 19:04 cancel_f2.png
    -rw-rw-rw- 1 root root 1406 Dec 16 19:04 favicon.ico
    -rw-rw-rw- 1 root root 44 Dec 16 19:04 index.html
    -rw-rw-rw- 1 root root 7274 Dec 16 19:04 logo.png
    -rw-rw-rw- 1 root root 698 Dec 16 19:04 save.png
    -rw-rw-rw- 1 root root 1822 Dec 16 19:04 save_f2.png
    drwxrwxrwx 2 root root 256 Jan 9 00:30 smilies
    drwxrwxrwx 2 root root 336 Jan 9 00:30 stories

    But I still cannot install components or modules

    shajazzi:eek:
     
  14. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please try this:
    Code:
    chown -R wwwrun:www /srv/www/web17/web
     
  15. shajazzi

    shajazzi New Member

    Thanks Falko,
    That did the trick OK.
    I would like to know what was causing the problem and why chown -R wwwrun:www /srv/www/web17/web fixed it? Just for future reference.

    Thanks again and I appreiate your time

    Regards
    shajazzi:) :) :)
     
  16. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    It was a permissions problem. Apache is running as user wwwrun, and if all directories and files belong to wwwrun instead of root and wwwrun has write permissions (which the owner usually has), then everything is fine.
     
  17. shajazzi

    shajazzi New Member

    I have installed modules and components and everything is OK until I try to install phpshop. I checked the Mambo forums and their seems to be a lot of others having a similar problem because of PHP safe mode. I tried many times to install PHP shop manually but it still will not work. Is there a work around for this problem?

    shajazzi
     
    Last edited: Feb 5, 2006
  18. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This are known problems with mambo. The only known workaround is disabling PHPSafeMode. But thats a security risk if you host not only your own sites on your server.
     
  19. shajazzi

    shajazzi New Member

    Thanks Till,
    When I searched for a php safe mode patch I came across a suggestion that you might be able to install mambo including phpshop onto a windows server and then copy everything to a Linux server therefore avoiding the php safe mode issue.
    I am using windows XP Pro with phpMyAdmin 2.5.6 with a couple of sites using phpshop and no problems. On the Linux server i am using Suse 9.3, ISPConfig and under tools PHPmyadmin2.6.4.
    I`ve looked at Web-ftp to upload everything from windows to Linux but it looks as if you can only upload one file at a time.I am not familiar with ftp, maybe i am missing something here.

    These are my questions:

    1. Do I need to downgrade to phpmyadmin 2.6.4 from 2.5.6 in Linux?

    2. Can I Zip the windows xp pro web and the phpmyadmin folders to a disc and then just paste them into the Linux folders?

    3. If no to question 2 how do I ftp Folders from windows to Linux?


    shajazzi
     
  20. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I can't imagine how this is supposed to work... :confused:


    I don't think phpMyAdmin has anything to do with your problem...

    Yes. You can also transfer the zip file to your server using FTP (or WinSCP) and then unzip it there again.

    Why don't you use a "real" FTP client like WS_FTP or SmartFTP? Then you can transfer directories, multiple files, etc. And you don't need to copy your files to a disc.
     

Share This Page