ISPCONFIG and External email client integration error

Discussion in 'General' started by Aayush, May 26, 2021.

  1. Aayush

    Aayush New Member

    Hello everyone,

    My client are not able to connect their outlook email client with my ispconfig (Roundcube intergration) server. The outlook shows invalid or expire certificate for the ispconfig server. However I have install letsencrypt certificate for my ispconfig GUI and it is validated by my brower.
    The clients have properly setup email domains, mail boxes and whenever they try to connect using outlook with following details they are greeted with the certification expire or invalid error of the host server:
    Incoming server: mail.client.com
    Username: client
    Password: Somepassword
    Port:993
    Outgoing server:mail.client.com
    Username:client
    Password: somepassword
    Port:587

    But when I entry my ispconfig servers URL (myispconfigserver.com) on the incoming and outgoing server the client is able to connect via outlook. But they are not able to connect via their domainYmail.client.com) hosted in my ispconfig server.
    The DNS record for client.com is also maintained with proper A records and so on The mail.client.com A record is pointed towards the ispconfig servers IP. The ispconfig mail.log shows outlook connecting to the ispconfig servers certificate and not the clients own certificate i.e mail.client.com certificate. Also i have installed my ispconfig servers lets encrypt certificate on the postfix and dovecot as well. May be that is the reason why i am getting certificate invalid or expire error. I think the error is due to the clients domain name and certificate mismatch.
    Can any one help me with the possible reasons and solution to it.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You are using the wrong username. The username for email is not the client name, it is the email address. so username is something like "[email protected]". Besides That, the mail server name that the mail client must use for the connection is the hostname of the server and not a domain or subdomain of a client.
     
  3. Aayush

    Aayush New Member

    Hello Tim,
    Sorry i forgot but i have indeed used the username as the [email protected], but the issues still persist.
    Also you are right when i set the mail server name to my ispconfig servers URL it works. But shouldn't it work using the clients domain/subdomains name like mail.client.com as i have valid dns records for the client as well as a valid certificates also the domain is hosted inside the ispconfig server
     
    Last edited: May 26, 2021
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No. The mail system uses the server hostname name only.
     
  5. Aayush

    Aayush New Member

    Thank you till. I will change the parameters then.
     
  6. Aayush

    Aayush New Member

    Hello till
    After changing the mail server to my ispconfig hostname, i am not still able to connect my outlook to my email boxes hosted in ispconfig server. The mail.log shows the bellow logs:

    May 27 16:15:26 vhost-01 postfix/submission/smtpd[32346]: connect from unknown[someIP]
    May 27 16:15:26 vhost-01 postfix/submission/smtpd[32346]: NOQUEUE: filter: RCPT from unknown[someIP]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10026; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<[192.168.2.111]>

    Also the outlook error is as follows:
    upload_2021-5-27_16-24-44.png

    I have used port 587 for outgoing email and port 993 for incoming email. Can you please help me out
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Outlook seems to have not authenticated itself. Make sure you configured outlook to authenticate for sending (smtp) using the email address and password.
     
  8. Aayush

    Aayush New Member

    I am able to connect to the outlook now. I used the IMAP port 143 instead of 993 and SMTP port as 587. But when using port 993 it is unable to connect to outlook. Is it dovecot error ?
     
  9. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Which version of Windows and Outlook?
     
  10. Aayush

    Aayush New Member

    Windows 10 and outlook client 2016 and also the error occurs from mobile apps too.
     
  11. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Have you selected to use "SSL" for IMAP and "TLS" for SMTP when using port 993 and 587?
     
  12. Aayush

    Aayush New Member

    Hello Thom,
    I have denied sslv2 and sslv3 in ssl_protocals both in postfix and dovecot and only allowed TLS version. Is it the reason ??
    Isn't TLS more secure than SSL.
    And yes i have tried by setting ssl for IMAP and TLS for SMTP. When using port 143 for IMAP and TLS for SMPT it works, but when using SSL(993) for IMAP and TLS for SMPT is doesn't.
     
  13. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Try using the settings set by ISPConfig when doing a update and reconfiguring services (you can always run a update with ispconfig_update.sh --force). They work fine for almost all clients and are secure.
     

Share This Page