ISPConfig and DynDns

Discussion in 'Installation/Configuration' started by Musty, Mar 5, 2008.

  1. Musty

    Musty New Member

    Greetings everyone.
    I have just installed ISPConfig on a fedora 8 Linux. I used webmin without problems before, but I read that ISPConfig is much more user-friendly and a bit more comprehensive than Webmin. The problem is that I have a registered domain name with DynDns and a few free domains for testing purposes. My ISP uses dynamic IP, but this is not a problem since I have configured my router for dyndns and opened all the necessary ports in the router NAT. I have also installed Inadyn daemon to update the IP with DynDns.

    My question is : how do I go about using ISPConfig with dynamic IP? So far, I can only access the ISPConfig panel but that's it.

    In other words, my registered domain name is, say, * and other free domains are, ...etc..., how do I configure them in ISPConfig so they go live?

    Thank you very much for your helpĀ·

  2. zcworld

    zcworld New Member

    i have used the free domain names from dyndns with ISPconfig before
    its just _________ ( TOP level domain ) __________ ( SUB level )
  3. Musty

    Musty New Member

    Thank you for your reply.
    I have had headaches with it so I went back to webmin. But again, I have another problem. Apache displays html files but no php. I have checked php module and it's there. I just don't get it.

    I have never had this problem before. Did I do anything wrong?

    Thanks again for your time

  4. zcworld

    zcworld New Member

    check the setings on the domain you setup
    i think there is an oration for php or
    see if they is enabled

    by default step by step
    the php on the default level of apache is disabled
    @ /var/www/htdocs or /var/www/html
  5. Musty

    Musty New Member

    ow do I know that it is / is not disabled? Here is the loadmodule list from my configuration file. As you can see I added the last line for apache to load module php, restarted apache. Still nothing!

    LoadModule auth_basic_module modules/
    LoadModule auth_digest_module modules/
    LoadModule authn_file_module modules/
    LoadModule authn_alias_module modules/
    LoadModule authn_anon_module modules/
    LoadModule authn_dbm_module modules/
    LoadModule authn_default_module modules/
    LoadModule authz_host_module modules/
    LoadModule authz_user_module modules/
    LoadModule authz_owner_module modules/
    LoadModule authz_groupfile_module modules/
    LoadModule authz_dbm_module modules/
    LoadModule authz_default_module modules/
    LoadModule ldap_module modules/
    LoadModule authnz_ldap_module modules/
    LoadModule include_module modules/
    LoadModule log_config_module modules/
    LoadModule logio_module modules/
    LoadModule env_module modules/
    LoadModule ext_filter_module modules/
    LoadModule mime_magic_module modules/
    LoadModule expires_module modules/
    LoadModule deflate_module modules/
    LoadModule headers_module modules/
    LoadModule usertrack_module modules/
    LoadModule setenvif_module modules/
    LoadModule mime_module modules/
    LoadModule dav_module modules/
    LoadModule status_module modules/
    LoadModule autoindex_module modules/
    LoadModule info_module modules/
    LoadModule dav_fs_module modules/
    LoadModule vhost_alias_module modules/
    LoadModule negotiation_module modules/
    LoadModule dir_module modules/
    LoadModule actions_module modules/
    LoadModule speling_module modules/
    LoadModule userdir_module modules/
    LoadModule alias_module modules/
    LoadModule rewrite_module modules/
    LoadModule proxy_module modules/
    LoadModule proxy_balancer_module modules/
    LoadModule proxy_ftp_module modules/
    LoadModule proxy_http_module modules/
    LoadModule proxy_connect_module modules/
    LoadModule cache_module modules/
    LoadModule suexec_module modules/
    LoadModule disk_cache_module modules/
    LoadModule file_cache_module modules/
    LoadModule mem_cache_module modules/
    LoadModule cgi_module modules/
    LoadModule php5_module modules/

    Thanks for your prompt reply.

  6. zcworld

    zcworld New Member

    its looks enable there
    but try here

    log in to the ispconfig
    admin panel
    and check the domain your working on

    goto the
    try this

    vi info.php
    if its load than PHP is working

    BTW : did u get the free DNS name problem fix ?

    ** edit : left out the "o" in info **
  7. Musty

    Musty New Member

    Thanks again. The phpinfo thing confirmed that php is working fine. Then why I can't view php files?
    For DNS problem, as I told you earlier I went into a fresh install of fedora 8 and installed Webmin instead of Ispconfig. I used the former for quite some time and I am familiar with it.

    I will be trying out a few things and will get back with the outcome.

    Thanks again for your help.

  8. zcworld

    zcworld New Member

    if you made the php files yourself
    check to see if you used

    i was having the same problem for ages
    where php files i was typing myself
    didn't work
    to i worked out what i was doing wrong

    if it something you downloaded
    than try running the
    chown -R zcworld:www /var/www/vhosts

    replace zcworld : with the account you use for normal access
    and the /var/www/vhosts
    with the path they are at :)

    good luck with it
    <personal for me : i dont use any webmain / ispconfig on my www box :) i know what im doing via command line

    but its an nice tool
    webmain is a tab evil / hard i found
    but i will learn it
  9. Musty

    Musty New Member

    He heee. I am pretty sure if I made the php files myself they will NEVER work! :D

    I use webmin to change the vhost folder permissions and user / group are changed to apache. This has always worked for me in the past. I will check DynDns and see if the Dynamic IP has been updated. That causes problems too.

    I am not a real guru in Linux, but I can take care of a few things. Also, all the help you can find on the web is interesting for linux dummies like myself! :D But sure you should try out webmin. It's a great tool!

  10. zcworld

    zcworld New Member

    90 % of the time on linux / BSD
    i cant find my way out of an wet paper bag
    but for what i do and
    i know what im doing 70 % of the time

    well do an an another look at the webmin
  11. Musty

    Musty New Member

    I know Linux is great. A pity I spent a long time on Microsoft garbage. But better late than never.

    But hey zcworld. Check out this :

    <VirtualHost *:80>
    DocumentRoot /var/www/html/phpmyadmin
    <Directory "/var/www/html/phpmyadmin">
    </VirtualHost> is a free dyndns domain. I checked dyndns and my public IP has been updated. Permissions on the phpmyadmin are OK and user/group = apache. Don't know why it wouldn't work! :mad:
  12. zcworld

    zcworld New Member

    i would of done ( if you got wildcard use turn on)

    can you add an info.php
    with the

    its odd
    i get an empty page

    this is my conf file for my sql admin host

    <VirtualHost *>
    ServerName sql.admin.lan
    DocumentRoot /var/www/vhosts/admin/sql
    <Location />
    Order deny,allow
    Deny from all
    Allow from shane.lan laptop.lan
    AllowOverride None
    CustomLog /var/www/vhosts/admin/logs/sql_access.log combined
    ErrorLog /var/www/vhosts/admin/logs/sql_error.log
    Last edited: Mar 6, 2008
  13. Musty

    Musty New Member

    Hey Buddy. I sorted it out. Took the whole afternoon yesterday and part of the night and a few glasses of scotch.

    I removed fedora 8 and went back to my favorite fedora 7. Had to reinstall twice as F7 didn't detect my network card and I couldn't use yum for that reason. So I downloaded the drivers onto another computer and during install, it said there are no compilers installed. So I reinstalled F7 again with all the developer packages and this time it installed the driver.
    Now it works like a charm, both my registered domains and with the free ones.

    Pheeeewwwww !

    But thanks buddy for your support.

  14. zcworld

    zcworld New Member


    have fun with it now

Share This Page