Ispconfig and Apache2 won't run after SSL installation attemp

Discussion in 'Installation/Configuration' started by kmullen, Mar 20, 2012.

  1. kmullen

    kmullen New Member

    I attempted to install an SSL certificate on a virtual host on ISPConfig 3.0, built on a Ubuntu Maverick platform. Now when I attempt to restart Apache2 it fails.

    I get the message "NameVirtualHost xx.xxx.xxx.xx:80 has no Virtualhosts
    Action start failed

    Can someone assist getting the interface up and running again and the SSL resolving correctly.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is most likely caused by a broken ssl certificate. The Namevirtualhost message is not related to this.

    To get your server up again, delete the symlink that is named like the site where you added ssl in /etc/apache2/sites-enabled/ and restart apache. Then create a new ssl certificate in ispconfig, make sure that you dont enter any special chars in the ssl detail fields.
     

Share This Page