ISPconfig and apache on centos 5.5

Discussion in 'Installation/Configuration' started by Hamra, Oct 3, 2010.

  1. Hamra

    Hamra New Member

    i've been trying to understand ispconfig for few days now.
    i have a VPS running centos 5.5 x86_64, i followed the instruction of the perfect server, to install ispconfig 3 on the VPS. after a day of messing with bind, i am finally running my own nameserver, and now to the important part... apache!
    ok, while fixing my nameserver problems, i noticed ispconfig was pointing to wrong directories for bind, not the files of my chrooted bind.
    so now, i noticed some very debian-like configuration entries for apache in ispconfig, which makes me wonder if these need changing or not.
    it says the enabled dir is "/etc/httpd/conf/sites-enabled", but does apache on centos look in this directory?
    i am asking because after creating a test site on a subdomain of mine, entering the subdomain in my browser loaded the file at /var/www/http (centos' default web root)... what am i missing?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This are the correct directories for Centos and ispconfig, no changes needed.

    Regarding your problem, make sure that you created a website for this subdomain in ispconfig and that you selected the correct IP address in the website settings. You can not use * as this causes problems on centos, you have to select a IP address.
  3. Hamra

    Hamra New Member

    thanks for the reply. ok, i think i jumped to conclusions fast. i took the time to read the configuration files, and i noticed how everything is corect, even the sites-enabled is mentioned in httpd.conf.
    and thanks for the IP tip, indeed, i was having an overlap problem when using IPs.
    so all done, i setup 2 websites. one for, with auto-subdomain, and another website for, which i want it to run phpsysinfo.
    i unchecked suExec, and set it to use suPHP.
    i got a 500 error while trying to load it. i looked in its error log, and saw a complaint that index.php is writeable by others. so i went to "/etc/suphp.conf", and changed the security options regarding others, to "true".
    loaded the page, another 500 error, but now different one in the error log. a complaint that index.php is having an ID below min_id.
    a little googling, and i founf its talking about owner's UID, my files are owned by root (i put them there using a root SSH shell). i changed ownership to "apache", which still resulted in same error (apache turned out to be very low too), so i changed min_id to 10.
    again, another 500 error, this time that the directory "web" is not owned by apache... by that time, i was really getting pissed off, specially that it's asking for it to be owned by apache, while apache is lower than the min_id, anyway, i complied and changed ownership from webX:clientX into apache:apache.
    tried loading the page, and it loaded fine.

    but now to the point.... i hardly think what i've done is an optimal solution, but more of dirty hacking. what IS the appropriate way of dealing with suPHP and ISPconfig/apache?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please undo that in suphp.conf. The index.php file may not be writable by others as this is a security risk. Run a chmod 755 on index.php instead and ensure that it is owned by the web user and client group.

    And do not change any foilder ownerships. It is not nescessary.
  5. Hamra

    Hamra New Member

    thanks a lot for the help till :)
    i did as you said, and restored all ownerships to webX:clientY, and chmodded the file, everything is working fine now.
    thanks a lot.

Share This Page