ISPconfig after installation cannot reach www.xyz.de:81

Discussion in 'Installation/Configuration' started by Figth4Linux, Feb 2, 2007.

  1. Figth4Linux

    Figth4Linux New Member

    Hi to you all!
    I've read about a 400 forums here but I cannot solve the problem. I've followed the Perfect Ubuntu Edgy server install and also the installation of ispconfig. All in good condition but I cannot see the domain throught the 81 port..
    Here I give the last lines of the configuration of ispconfig and the error messages of the restarting of the isp server. I put the content of /etc/hosts
    The output of netstat -tap is ok. How can I modify the MySQL server, host name, domain etc. without re-installing all ispconfig?

    Last lines of configuration:

    Please enter your MySQL server:server1.example.com
    OK
    Please enter your MySQL user:root
    Please enter your MySQL password:
    ERROR 2003 (HY000): Can't connect to MySQL server on 'server1.example.com' (111)
    The provided MySQL password is wrong!
    Please enter your MySQL server:localhost
    OK
    Please enter your MySQL user:root
    Please enter your MySQL password:
    OK
    Please enter a name for the ISPConfig database (e.g. db_ispconfig):ispconfigdb
    Please enter the IP address of the ISPConfig web (e.g. 192.168.0.1):192.168.100.1
    OK
    Please enter the host name (e.g. www):www
    Please enter the domain (e.g. xyz.de):xyz.it
    The URL is not reachable!
    Please enter the host name (e.g. www):www
    Please enter the domain (e.g. xyz.de):xyz.de
    OK
    Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system:
    1) HTTPS
    2) HTTP
    Your Choice: 2

    chown: cannot access `/home/admispconfig/ispconfig/backup': No such file or directory
    chmod: cannot access `/home/admispconfig/ispconfig/backup': No such file or directory
    chmod: cannot access `/home/admispconfig/ispconfig/tools/tcpserver/ispconfig_tcpserver': No such file or directory
    chown: cannot access `/home/admispconfig/ispconfig/tools/tcpserver/ispconfig_tcpserver': No such file or directory
    Connected successfully to MySQL server
    no crontab for root
    Restarting some services...
    * Stopping Postfix Mail Transport Agent postfix [ ok ]
    * Starting Postfix Mail Transport Agent postfix [ ok ]
    * Stopping ftp server proftpd [ ok ]
    * Starting ftp server proftpd - IPv6 getaddrinfo 'server1.example.com' error: Name or service not known
    [ ok ]
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    Please direct your browser to

    http://www.xyz.de:81

    and log in:
    Username: admin
    Password: admin

    root@server1:/home/mariou/install_ispconfig#

    restarting ispconfig_server:

    root@server1:/home/mariou/install_ispconfig# /etc/init.d/ispconfig_server restart
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down ISPConfig system...
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    /root/ispconfig/httpd/bin/apachectl stop: httpd stopped
    ISPConfig system stopped!
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting ISPConfig system...
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    ISPConfig system is now up and running!
    root@server1:/home/mariou/install_ispconfig#

    content of /etc/hosts:

    root@server1:/home/mariou/install_ispconfig# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    192.168.100.1 server1.example.com server1
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    root@server1:/home/mariou/install_ispconfig#


    Thank-u in advance!!
     
  2. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    To avoid the errors during restart, 1st change to your home directory. E.g.
    Code:
    cd ~
    The install script deletes the installation directory after finishing, thus the errors.
    Next, what's the output of
    Code:
    netstat -tap
    after restarting ISPConfig again?
     
  3. Figth4Linux

    Figth4Linux New Member

    Thank you very much for your soon answer. You're right, as I'm in my home the reastarting of ispconfig_server is without errors. However I'm still unable to connect http://www.xyz.de:81/
    Here is my netstat -tap output.

    root@server1:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdom:2208 *:* LISTEN 4144/hpiod
    tcp 0 0 *:mysql *:* LISTEN 8068/mysqld
    tcp 0 0 localhost.localdo:41488 *:* LISTEN 4147/python
    tcp 0 0 *:81 *:* LISTEN 14596/ispconfig_htt
    tcp 0 0 host235-51-dynam:domain *:* LISTEN 14857/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 14857/named
    tcp 0 0 *:4662 *:* LISTEN 15310/amule
    tcp 0 0 localhost.localdoma:ipp *:* LISTEN 30334/cupsd
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 14857/named
    tcp 0 0 *:smtp *:* LISTEN 14803/master
    tcp 0 27284 host235-51-dynamic:4662 201-1-14-42.dsl.t:60128 ESTABLISHED15310/amule
    tcp 0 0 localhost.localdo:48002 localhost.localdoma:953 TIME_WAIT -
    tcp 0 0 host235-51-dynamic:4662 183.Red-83-53-250.:4792 ESTABLISHED15310/amule
    tcp 0 15840 host235-51-dynami:49172 177.red-62-57-230.:5476 ESTABLISHED15310/amule
    tcp 0 0 host235-51-dynami:45287 62.241.53.16:4242 ESTABLISHED15310/amule
    tcp 0 8568 host235-51-dynami:57566 ppp3-229.pppoe.mtu:4662 ESTABLISHED15310/amule
    tcp 0 17424 host235-51-dynami:49796 86.203.34.254:4662 ESTABLISHED15310/amule
    tcp 0 0 host235-51-dynamic:4662 host148-147-dynami:1271 TIME_WAIT -
    tcp 0 10080 host235-51-dynami:47578 81.203.32.244:4662 ESTABLISHED15310/amule
    tcp 0 11520 host235-51-dynami:35036 84-123-4-81.user.o:4662 ESTABLISHED15310/amule
    tcp 0 1 host235-51-dynami:35295 couerdalene-cuda2-:4662 SYN_SENT -
    tcp 0 0 host235-51-dynamic:4662 253.Red-88-6-250.s:3562 ESTABLISHED-
    tcp 0 1 host235-51-dynami:57731 49.143.57.82:38909 SYN_SENT -
    tcp 0 17424 host235-51-dynami:49796 86.203.34.254:4662 ESTABLISHED15310/amule
    tcp 0 0 host235-51-dynamic:4662 host148-147-dynami:1271 TIME_WAIT -
    tcp 0 1 host235-51-dynami:40305 36.91.55.82:4661 SYN_SENT -
    tcp 0 39 host235-51-dynami:42798 adsl-153-185.37-15:4662 ESTABLISHED-
    tcp 0 11520 host235-51-dynami:35036 84-123-4-81.user.o:4662 ESTABLISHED15310/amule
    tcp 0 1 host235-51-dynami:49827 151.42.210.58.broa:4662 SYN_SENT -
    tcp 0 0 host235-51-dynamic:4662 a96-235.adsl.palte:2564 TIME_WAIT -
    tcp 0 21210 host235-51-dynamic:4662 pD95F5263.dip.t-di:2552 ESTABLISHED15310/amule
    tcp 0 1 host235-51-dynami:57277 210.161.51.82:7070 SYN_SENT -
    tcp 1 0 host235-51-dynami:36170 server1.howtoforge.:www CLOSE_WAIT -
    tcp 0 19572 host235-51-dynami:58968 87.203.117.61:62697 ESTABLISHED15310/amule
    tcp 0 1 host235-51-dynami:51306 38.253.221.84:4662 SYN_SENT -
    tcp 0 17280 host235-51-dynami:40909 host133-69-dynamic:2541 ESTABLISHED15310/amule
    tcp 0 1 host235-51-dynami:44447 32.178.52.82:54216 SYN_SENT -
    tcp 0 1 host235-51-dynami:46455 simi_valley_ca_bs:11755 SYN_SENT -
    tcp 0 15752 host235-51-dynamic:4662 ppp-139-122.33-151:1634 ESTABLISHED15310/amule
    tcp 0 1 host235-51-dynami:48028 60.171.223.84:4662 SYN_SENT -
    tcp 0 0 host235-51-dynami:52541 a195.22.198-24.depl:www ESTABLISHED7145/firefox-bin
    tcp 0 1 host235-51-dynami:33764 50.107.222.84:4662 SYN_SENT -
    tcp 0 18876 host235-51-dynamic:4662 xs-217-221-21-97.:57321 ESTABLISHED15310/amule
    tcp 0 1 host235-51-dynami:44733 217.72.221.84:4662 SYN_SENT -
    tcp 0 0 host235-51-dynamic:4662 host250-92-dynamic:2022 TIME_WAIT -
    tcp 0 0 host235-51-dynamic:4662 ppp-82-84-222-137.:1119 ESTABLISHED-
    tcp 0 11424 host235-51-dynami:41303 host139-135-dynam:18377 ESTABLISHED15310/amule
    tcp6 0 0 *:imaps *:* LISTEN 4513/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 4552/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 4528/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 4491/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 14697/apache2
    tcp6 0 0 *:ftp *:* LISTEN 14894/proftpd: (acc
    tcp6 0 0 *:ssh *:* LISTEN 4842/sshd
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 14857/named
    tcp6 0 0 *:smtp *:* LISTEN 14803/master
    tcp6 0 0 *:https *:* LISTEN 14697/apache2
    root@server1:~#
     
  4. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    Next time, please use the # image to embed your output in CODE tags. makes it much more readable.
    Means you want to access your panel from the outside?

    Means you have your server behind an ADSL router, right?

    So you need to make sure www.xyz.de forwards/points to your external IP address used for your ADSL connection.
    Next you need to forward port 81 on your router to the server you have with ISPConfig.
     
  5. Figth4Linux

    Figth4Linux New Member

    Code:
    So you need to make sure www.xyz.de forwards/points to your external IP address used for your ADSL connection.
    Next you need to forward port 81 on your router to the server you have with ISPConfig.
    Reply With Quote
    I'm very sorry but I'm not so able to manage this staff now (it's also for my english..).
    Forwards/points to your external IP address means the address of the router?
    I can forwarding port 81 by use of iptables FORWARD?
    Server of ISPconfig is the localhost or server1.example.com?
     
  6. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    yes, the external IP address of your ADSL router.
    no, you should forward port 81 on your ADSL router.
    ISPConfig is installed on 192.168.100.1? And yes, as long as you are on the same server as your hosts file is on as specified below, you can use the server name server1.example.com. But be aware example.com is a valid domain on the internet, so you can get confused. If ISPConfig is installed on the server with IP address 192.168.100.1, you can also reach ISPConfig with the url
    Code:
    http://192.168.100.1:81
    That is if you didn't configure ISPConfig to use https. then replace http with https.
     
  7. Figth4Linux

    Figth4Linux New Member

    Code:
    no, you should forward port 81 on your ADSL router.
    In all this days I tried to do it ... but I can't. iptables or ipchain isn't correct?

    Code:
    you can also reach ISPConfig with the url : http://192.168.100.1:81
    I still cannot reach this URL . . .
    . . . and I still think there's something wrong in my settings of ISPconfig.

    Thank-you all in advance for help.
     
  8. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    What's the output of
    Code:
    ifconfig
    ?
     
  9. Figth4Linux

    Figth4Linux New Member

    Code:
    root@server1:~# ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 00:13:49:25:A4:14  
              inet6 addr: fe80::213:49ff:fe25:a414/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2092 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2102 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:977348 (954.4 KiB)  TX bytes:581130 (567.5 KiB)
              Interrupt:217 Base address:0x4000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:41 errors:0 dropped:0 overruns:0 frame:0
              TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:3520 (3.4 KiB)  TX bytes:3520 (3.4 KiB)
    
    ppp0      Link encap:Point-to-Point Protocol  
              inet addr:82.56.172.204  P-t-P:192.168.100.1  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
              RX packets:1870 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1963 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3 
              RX bytes:922525 (900.9 KiB)  TX bytes:529436 (517.0 KiB)
    
    sit0      Link encap:IPv6-in-IPv4  
              NOARP  MTU:1480  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    
    root@server1:~# 
    
    that's it..
     
  10. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    You have your server configured for IPv6 only. 192.168.x.x is an IPv4 address. Without some help, the system cannot match the two. As I don't use IPv6, I'm unsure how to give you some advise to get this fixed. :confused:

    Checking ISPConfig though can probably be done by using the IPv6 address: fe80::213:49ff:fe25:a414:81 but this is totally untested. You probably need some help from another person at this forum to get things moving....
     
  11. Figth4Linux

    Figth4Linux New Member

    My address is an IPv6, but this is for my hardware? Or if I re-install ISPconfig with other parameters I can solve the problem?

    Anyway thank-U very much.
     
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    ISPConfig does not support IPv6 yet. Please configure your network for IPv4 if you want to use ISPConfig.
     
  13. Figth4Linux

    Figth4Linux New Member

    I searched round the web for reconfiguring my network to ipv4..but I don't know how to start and how to do it. Is it possible in this post or I've to create a new one? T-U
     
  14. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's in /etc/network/interfaces?
     
  15. Figth4Linux

    Figth4Linux New Member

    Code:
    mariou@server1:~$ cat /etc/network/interfaces
    auto lo
    iface lo inet loopback
    
    
    iface eth0 inet static
    address 192.168.100.1
    network 192.168.100.0
    netmask 255.255.255.0
    broadcast 192.168.100.255
    gateway 192.168.100.254
    
    auto eth1
    iface eth1 inet dhcp
    
    auto eth2
    iface eth2 inet dhcp
    
    auto ath0
    iface ath0 inet dhcp
    
    auto wlan0
    iface wlan0 inet dhcp
    
    
    auto dsl-provider
    iface dsl-provider inet ppp
    provider dsl-provider
    
    
    
        pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
    mariou@server1:~$ 
    
    This is its content Falko
     
  16. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I hope you have leading spaces in the eth0 stanza, like this:

    Code:
    iface eth0 inet static
        address 192.168.100.1
        network 192.168.100.0
        netmask 255.255.255.0
        broadcast 192.168.100.255
        gateway 192.168.100.254
    Also, comment out
    Code:
    pre-up /sbin/ifconfig eth0 up
    and restart networking:
    Code:
    /etc/init.d/networking restart
     
  17. Figth4Linux

    Figth4Linux New Member

    I did what you said but I'm still unable to connect to http://www.xyz.de:81
    In my configuration the eth0 is IPv6, i checked through the GUI.
    I'm a little :confused: about this..
     
  18. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Did you follow the Ubuntu Edgy Perfect Setup as close as possible?
     
  19. Figth4Linux

    Figth4Linux New Member

    Yes, of course! I think that maybe there's something wrong in the last lines configuration, I mean the server Mysql and ISPserver..
    On the ISPconfig website they said ISPconfig don't support IPv6..
    You think I can try to re-install ISPconfig?
     
  20. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    This won't help as it's a problem with the system, not ISPConfig.
    Maybe you should try to reinstall the whole system. I've never had this IPv6 problem when I followed the tutorial.
     

Share This Page