ISPConfig admin interface lost after Joomla install

Discussion in 'Installation/Configuration' started by lucius, Mar 31, 2008.

  1. lucius

    lucius New Member

    Hi, I got ISPConfig up and running beautifully on Ubuntu 7.10, started by creating reseller account, all is well and then create new site as part of the 10 steps in getting Joomla CMS operational and I get to step 5 and find that globals.php does not exist so I go straight to testing the new site domain name for ftp upload of the Joomla code. This is where it all starts to go wrong. Firstly the domain name ftp://myjoomlasite.tld/web will not resolve in the ftp client, then I notice the admin portal is no longer available, I get unable to conect, even if I supply the socket in place of the name. Anyone had similar situation? Cheers :D
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please make sure that myjoomlasite.tld is pointing to the correct server. You can check that with
    Code:
    dig myjoomlasite.tld
    Also, please post the output of
    Code:
    netstat -tap
     
  3. lucius

    lucius New Member

    dig on the site was answered by upstream DNS

    Thanks for the feedback Falco, I have the following output from netstat
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN -
    tcp 0 0 *:www *:* LISTEN -
    tcp 0 0 lucius-star-stat:domain *:* LISTEN -
    tcp 0 0 localhost:domain *:* LISTEN -
    tcp 0 0 *:nessus *:* LISTEN -
    tcp 0 0 *:smtp *:* LISTEN -
    tcp 0 0 localhost:953 *:* LISTEN -
    tcp 0 0 *:https *:* LISTEN -
    tcp6 0 0 *:imaps *:* LISTEN -
    tcp6 0 0 *:pop3s *:* LISTEN -
    tcp6 0 0 *:pop3 *:* LISTEN -
    tcp6 0 0 *:imap2 *:* LISTEN -
    tcp6 0 0 *:ftp *:* LISTEN -
    tcp6 0 0 *:domain *:* LISTEN -
    tcp6 0 0 *:ssh *:* LISTEN -
    tcp6 0 0 *:smtp *:* LISTEN -
    tcp6 0 0 ip6-localhost:953 *:* LISTEN -

    So DNS does not appear to point back to my IP 192.168.1.42 instead I get back the following;
    [email protected]:~$ dig joomlasite.tld

    ; <<>> DiG 9.4.1-P1 <<>> joomlasite.tld
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 65426
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;joomlasite.tld. IN A

    ;; AUTHORITY SECTION:
    . 10800 IN SOA a.root-servers.net. nstld.verisign-grs.com. 2008040501 1800 900 604800 86400

    ;; Query time: 17 msec
    ;; SERVER: 194.168.4.100#53(194.168.4.100)
    ;; WHEN: Sun Apr 6 11:22:16 2008
    ;; MSG SIZE rcvd: 107

    Any thoughts on the DNS?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There seems to be no ISPConfig running on your server, run the following command to start ispconfig:

    /etc/init.d/ispconfig_server start
     
  5. lucius

    lucius New Member

    Thanks, I tried the /etc/init.d/ispconfig_server start option and it did not work. I thought that's strange so I did ls -al to check permisions on the file, and it listed it as executable by root, which I was logged in as. Should I try a reinstall?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    What is the exact output that you got on the shell when you run:

    /etc/init.d/ispconfig_server start
     

Share This Page