ISPConfig access lost.

Discussion in 'General' started by n1kol1s, Dec 14, 2006.

  1. n1kol1s

    n1kol1s New Member

    Hello everyone

    I installed debian sarge with ISPConfig and everything worked ok untill i tried to install joomla in one of my sites. I had to edit the root password to make joomla work, with phpmyadmin and sense that i have lost access to ISPConfig and phpmyadmin panel. The joomla web is working with no problems.

    I installed ISPConfig with https access.
    Any ideas?
    Thanks
    n1kol1s
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please change the root password in /home/admispconfig/ispconfig/lib/config.inc.php

    Generally: Joomla does not need mysql root priveliges, it is a security risk to run it under the mysql root user.
     
  3. n1kol1s

    n1kol1s New Member

  4. sgrayban

    sgrayban New Member

    Uhhh bad bad... All you had to do is what Till said.
     
  5. n1kol1s

    n1kol1s New Member

    Yah i know . I still use the same password i had it working before but the problem i think is that the ispconfig had lost the mysql access.. I think i need to manualy add the new password of the root to ispconfig so it can gain the mysql access back.
     
  6. n1kol1s

    n1kol1s New Member

    I tried to put the msql db that i create for the user in joomla but it did not accept it.
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Exactly. An I posted you the solution on how to change the password for ISPConfig.
     
  8. n1kol1s

    n1kol1s New Member

     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Are you not able to login or does the HTML page does not show up in the browser at all?
     
  10. n1kol1s

    n1kol1s New Member

    It doesent load the page of the ISPConfig . I set it up as a https thats why i thing is the db lost.is there a way to swap to http so i can access and the repair the problem?
    thanks
    n1kol1s
     
  11. n1kol1s

    n1kol1s New Member

Share This Page