ispconfig Access denied for user 'ispconfig'@'localhost'

Discussion in 'ISPConfig 3 Priority Support' started by cwtudor, Sep 26, 2014.

  1. cwtudor

    cwtudor New Member

    After upgrade I can not access control panel. I have this error

    Fri Sep 26 09:18:22 CDT 2014 DB::__construct Access denied for user 'ispconfig'@'localhost' (using password: YES)
    Fri Sep 26 09:18:22 CDT 2014 PHP Warning: mysqli::mysqli(): (28000/1045): Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 72

    I have tried manually reinstalling and choose to reconfigure the services. The only thing I noticed is the mysql server failed to stop.

    This should be easy to fix but after searching for an answer for a few days the solution has not come to me.

    I'm sure I did change the root password to mysql sometime after installing ISPconfig.
     
    Last edited: Sep 26, 2014
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If you cahnged the mysql root password, then ensure that you have set the new mysql root password in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf

    after you set the new root password there, download the ispconfig tar.gz, unpack it, run the update.php script in the install folder and choose to reconfigure services during update.
     
  3. cwtudor

    cwtudor New Member

    Access denied for user 'ispconfig'@'localhost'

    Thanks for your response. I looked at the content of

    /usr/local/ispconfig/server/lib/mysql_clientdb.conf it seems right.

    <?php
    $clientdb_host = 'localhost';
    $clientdb_user = 'root';
    $clientdb_password = 'imXXXXX';
    ?>

    Was able to login to mysql with the same creaditioals
    $ mysql –u root –p
    password imXXXXX
    mysql>

    So I did this:

    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php

    And I got this

    >> Update
    Operating System: Debian 6.0 (Squeeze/Sid) or compatible
    This application will update ISPConfig 3 on your server.
    Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]: no
    Checking ISPConfig database .. O|Starting incremental database update.
    Reconfigure Permissions in master database? (yes,no) [no]: yes
    Reconfigure Services? (yes,no) [yes]: yes
    Configuring Postfix
    Configuring Jailkit
    Configuring Dovecot
    Configuring Spamassassin
    Configuring Amavisd
    Configuring Getmail
    Configuring Pureftpd
    Configuring BIND
    Configuring Apache
    Configuring vlogger
    Configuring Apps vhost
    Configuring Database
    Configuring Bastille Firewall
    Updating ISPConfig
    ISPConfig Port [8080]:
    Create new ISPConfig SSL certificate (yes,no) [no]: no
    Reconfigure Crontab? (yes,no) [yes]: yes
    Updating Crontab
    Restarting services ...
    Stopping MySQL database server: mysqld.
    Starting MySQL database server: mysqld.
    Checking for corrupt, not cleanly closed and upgrade needing tables..
    Stopping Postfix Mail Transport Agent: postfix.
    Starting Postfix Mail Transport Agent: postfix.
    Stopping amavisd: amavisd-new.
    Starting amavisd: amavisd-new.
    Stopping ClamAV daemon: clamd Waiting . . .
    Starting ClamAV daemon: clamd .
    If you have trouble with authentication failures,
    enable auth_debug setting. See http://wiki.dovecot.org/WhyDoesItNotWork
    This message goes away after the first successful login.
    Restarting IMAP/POP3 mail server: dovecot.
    [Fri Sep 26 15:17:15 2014] [warn] NameVirtualHost *:443 has no VirtualHosts
    apache2: Could not reliably determine the server's fully qualified domain name, using shv.lsuhsc-s.edu for ServerName
    [Fri Sep 26 15:17:16 2014] [warn] NameVirtualHost *:443 has no VirtualHosts
    Restarting web server: apache2 ... waiting .
    Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -D -O clf:/var/log/pure-ftpd/transfer.log -A -Y 1 -b -E -u 1000 -8 UTF-8 -H –B
    Update finished.
    [email protected]:/tmp/ispconfig3_install/install#

    But when I goto login I get this

    Warning: mysqli::mysqli(): (28000/1045): Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 61

    I'm going out of town so I will not be back online until Monday, please have a nice weekend.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    are you able to login to mysql with the user "ispconfig" and the password of the ispconfig mysql user from the file /usr/local/ispconfig/interface/lib/config.inc.php?
     
  5. cwtudor

    cwtudor New Member

    Musql access

    No I was not.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. cwtudor

    cwtudor New Member

    Database working

    Worked perfectly, Thanks so much for the help.
     

Share This Page