ispconfig 403 forbidden NAT

Discussion in 'Installation/Configuration' started by foobar2, Feb 14, 2014.

  1. foobar2

    foobar2 New Member

    hi all,

    does ispconfig work on server behind a fw?

    installing ispconfig on virgin ubuntu on amazon cloud, i am getting 403 error when accessing cpanel http://mysite.com:8080, mysite.com resolves to IP of the ispconfig installation, do i use the private or real IP in ispconfig server config?

    tail -100 /var/log/apache2/error.log

    Code:
    [Fri Feb 14 00:37:08 2014] [error] [client 164.20.34.33] client denied by server configuration: /var/www/
    [Fri Feb 14 00:37:09 2014] [error] [client 164.20.34.33] client denied by server configuration: /var/www/
    [Fri Feb 14 00:37:10 2014] [error] [client 164.20.34.33] client denied by server configuration: /var/www/
    ispconfig server config
    Code:
    [server]
    auto_network_configuration=n
    ip_address=192.168.28.170
    netmask=255.255.255.0
    gateway=0.0.0.0
    hostname=mysite.com
    #/etc/apache2/sites-enabled$ ls -al
    Code:
    lrwxrwxrwx 1 root root   39 Feb 13 22:43 000-apps.vhost -> /etc/apache2/sites-available/apps.vhost
    lrwxrwxrwx 1 root root   26 Feb 14 00:37 000-default -> ../sites-available/default
    lrwxrwxrwx 1 root root   43 Feb 13 22:43 000-ispconfig.conf -> /etc/apache2/sites-available/ispconfig.conf
    lrwxrwxrwx 1 root root   44 Feb 13 22:43 000-ispconfig.vhost -> /etc/apache2/sites-available/ispconfig.vhost
    #cat 000-default
    Code:
    <VirtualHost *:80>
            ServerAdmin [email protected]
    
            DocumentRoot /var/www
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
    
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
    
            ErrorLog ${APACHE_LOG_DIR}/error.log
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
    
            CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>
    #cat 000-ispconfig.vhost
    Code:
     Listen 8080
    NameVirtualHost *:8080
    
    <VirtualHost _DEFAULT_:8080>
      ServerAdmin [email protected]
    #ifconfig
    Code:
    eth0  inet addr:192.168.28.170  
    #ping somesite.com
    Code:
    50.211.211.211
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There seem to be ubuntu packages missing. Which tutorial did you use to prepare your server for the installation of ispconfig?

    for websites that you add inside ispconfig, you use the private ip.
     
  3. foobar2

    foobar2 New Member

    https://github.com/dclardy64/ISPConfig-3-Debian-Installer

    dont quite understand this part, I have not gotten to adding websites yet. I'm getting error 403 when trying to gain access to ispconfig. I have yet gotten to ispconfig login screen.

    many thanks!
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Sure, that does not matter for ispconfig.

    Thats not a official installer for ispconfig, so I cant tell you which packages are missing when you use it. You should really have used one of the official installation tutorials fom ispconfig.org.

    Seems as if your apache is not loading the ispconfig vhost /etc/apache2/sites-available/ispconfig.vhost

    When you add a website, use the internal Ip address.
     
  5. foobar2

    foobar2 New Member

    thanks for the help Tim

    can you point me to the official installer please? :p

    says installation done when i ran the install.php, did not see any complaints.
    Code:
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xfz ISPConfig-3-stable.tar.gz
    cd /tmp/ispconfig3_install/install/
    php -q install.php
    apache is loading because it responded to :8080. would have been a 404 or no reply otherwise.
    ispconfig is refusing the connection

    add website where? :confused: during installation? i have not seen this option.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    We provide a tutorial and not a installer. With about 15 years experience in installing servers on provider platforms worldwide I know that a simple script installer will fail too often to be useful. Script installers will only work if you have a 100% exact starting platform and thats not the case "in the wild", you just noticed this on your server. For that reason, we provide a install tutorial were you see in detail when a step fails so that you can correct it right away.

    The installer assumes that you followed the tutorial as the tutorial as the tutoriadescribes the system requirements for the installer.

    In ispconfig, after you installed it correctly ;)
     

Share This Page