ISPConfig 3, Z-Push and Android 4.4.2

Discussion in 'Server Operation' started by SONiQz, Jul 10, 2014.

  1. SONiQz

    SONiQz New Member


    I've been tasked with setting up a mail server with Push capabilities. For the most part I think I am onto a winner, however I am having a few issues with Z-Push. It can receive e-mail OK and it works wonderfully, however on trying to send email I have found that if I don't have a subject set in the Samsung default mail app it will refuse to send. As soon as I add a subject, it'll go without hassle. The log files show:

    10/07/2014 13:56:33 [ 4804] [WARN] [[email protected]] /usr/share/z-push/backend/imap/imap.php:470 imap_mail(): No subject field in mail command (2)
    I am assuming there needs to be a method of writing a [subject] header in the event there isn't one.

    Additionally, is there a process that will take Out Of Office from the Android Mail app and store it in ISPConfig? I know Roundcube does it, but it would be nice.....

    Edit: Additionally, I have noticed that the issue relating to 'Subject' appears to affect Blackberry OS 10 also (Not that there is any surprise there).
    Last edited: Jul 11, 2014
  2. SONiQz

    SONiQz New Member

    Correction to the above issue

    After following through the /usr/share/z-push/backend/imap/imap.php file I have found that modifying the else statement at Line 461 to the following:
            else {
                ZLog::Write(LOGLEVEL_DEBUG, "BackendIMAP->SendMail(): subject: no subject set. Set to empty.");
                $message->headers["subject"] = "(no subject)"; // added by mku ZP-330
    Has corrected the issue. The original had
     ...headers["subject"] = "" ... 
    and the NULL return was breaking the header.

    Hope this is of some assistance to someone else.

Share This Page