ISPConfig 3 won't start?

Discussion in 'General' started by Patryk38, Feb 10, 2013.

  1. Patryk38

    Patryk38 New Member


    I will try say what I need to as fastly and easly as its possible, to save my and yours time.

    So, I was doing my staff on ISPConfig 3. Same thing like normally. Adding new domain etc. I wanted to use subdomain, but i did try do it in new way. I always was adding new site, but instead giving the domain adress, i giving the script the subdomain adress. (For example instead of I was giving And it worked well. Always.

    This time, I addes subdomain. After that, the every site on the server stopped work, and instead showing me my sctipt, it was saing "Welcome, this your example page, you can change it in blablabla". Same like you was creating new website.

    But I knew that I had same problem when it was problem with subdomains, because I didn't do the DNS for it or something. So I just deleted this subdomain, because I didn't need it that really and that was only for test.

    After that, after waiting some time, about 20mins to the DNS load again i refreshed the sit. Everything was working now... I mean, it was trying to load the page it had to, but it was showing me the error of port 80. Something like that.

    I did reboot the server by ssh, because I needed fastly to "fix it", and always when I had this error I just needed reboot apache2 or whole server. So... i did it, wait the time i had to and... what I see? nothing. ISPConfig 3 didn't load. The other startup scripts did run. Such as autostart for Team Speak 3, and server is running well. But the ISPConfig doesn't. I did try to run apache2 manually, but it sais
    "Restarting web server: apache2MySQL Connection problem"

    I've disabled cronjob for a while, started the ISPConfig manually, and that's what is said to me

    [email protected]:/etc/init.d# /usr/local/ispconfig/server/
    postqueue: warning: Mail system is down -- accessing queue directly
    FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
    Failed to load mptctl
    PHP Warning: Invalid argument supplied for foreach() in /usr/local/ispconfig/server/mods-available/ on line 1118
    [email protected]:/etc/init.d# FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
    -bash: FATAL:: command not found

    Any ideas?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    First of all, ispconfig 3 is no deamon, so it can not and has not to be started. ISPconfig consist of a interface part, which is basically a apache or nginx vhost, and a server part which is a cronjob.

    Which guide did you use to prepare your server for the installation of ispconfig?

    Regarding your coronjob errors.

    1) Postfix is not started. Start it with its init script.
    2) The other errors can be ignored as they have no impact on the system. They are just from the monitor and get displayed as the ipv6 module is not loaded in your kernel and a reaid druver that is installed but you dont seem to have the raid hardware for that driver installed. So both are uncritical.

    This indicates that mysql is not started.
  3. Patryk38

    Patryk38 New Member

    Thanks for your replay!

    Ouch, alright. Anyway... don't worry about it anymore. After a day of not answearing OVH support I decided to reinstall the server.

    But now I've other problem. So... I added DNS config for my domain, for my subdomains etc. Then in tab 'Sites' added these domains/subdomains and I though that everything works perfectly. I was able to see the welcome script. Then I copied backup of my sites. (client1 folder). Gave to it premissions, and the WordPress script was working. But IPBoard wasn't. I though that's a problem with DNS or something, so I decided wait a sec. I've just changed (on my local PC) from Windows to Ubuntu, and after that when I was trying to check if my IPBoard script is working now - it did! Yey! I was happy as a f... you know what I mean. :p But then I was trying to access to my WordPress script. And what? I see the welcome index.html file. Sure I've changed the rediect settings. Even was trying to do other thing. I've changed the index.html file? And you know what happend? NOTHING! It just looks like it wasnt in that folder.

    About my configuration? Well, I'm using Debian 6 Squeeze + ISPConfig That's all I know about configuration, everything is same like I'd get it all from OVH installation. Didn't change anything.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely you see the index page from another site. This can happen wehn websites with IP and * are mixed. So either use the IP address (which you add under System > Server IP first) or * for all sites, but dont mix that.

    Regarding your dns records, to verify that you dns works correctly you can use e.g.

    or use the dig command:

    dig @ns1.yourdomain.tld yourdomain.tld

    replace ns1.yourdomain.tld with the hostname of the dns server and yourdomain.tld with your domain name.
  5. Patryk38

    Patryk38 New Member

    Thank you very much! It helped me. I've changed from my IP to * on all of my domains - and then started to work. :)

Share This Page