ISPConfig 3 Won't Launch a Website

Discussion in 'Installation/Configuration' started by midcarolina, Sep 8, 2011.

  1. midcarolina

    midcarolina New Member

    I have tried launching sites on fresh installs of ISPConfig 3 on two different servers. Both servers seen to work fine, ISPConfig 3 seems to function fine, and I have tried various nameservers, all of which point to either of the two servers. If I run a reverse traceroute, dns lookup, etc, every different setting resolved perfectly every time. They are both wordpress sites which I have installed my fair share of times. The connection strings from MySql to wp-config are perfect too. Each time, same error....500 internal server error.

    PS, the monitor on both set-ups is all green...all systems go?

    Thanks.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you check Apache's error log?

    Which PHP mode do you use?
    Do you use rewrite rules? If Apache's rewrite module enabled?
     
  3. midcarolina

    midcarolina New Member

    Hi Falko,

    Thanks for the response. Based on the httpd error log, here is a group of basically repeated errors:

    [Tue Sep 06 15:48:10 2011] [notice] Apache/2.2.17 (Unix) DAV/2 mod_fcgid/2.3.6 PHP/5.3.6 mod_python/3.3.1 Python/2.7 mod_ruby/1.3.0 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.17 OpenSSL/1.0.0d-fips mod_perl/2.0.4 Perl/v5.12.3 configured -- resuming normal operations
    [Tue Sep 06 15:48:49 2011] [notice] caught SIGTERM, shutting down
    [Tue Sep 06 15:48:50 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Tue Sep 06 15:48:50 2011] [notice] SSL FIPS mode disabled
    [Tue Sep 06 15:48:50 2011] [notice] Digest: generating secret for digest authentication ...
    [Tue Sep 06 15:48:50 2011] [notice] Digest: done
    [Tue Sep 06 15:48:50 2011] [notice] mod_python: Creating 4 session mutexes based on 512 max processes and 0 max threads.
    [Tue Sep 06 15:48:50 2011] [notice] mod_python: using mutex_directory /tmp
    [Tue Sep 06 15:48:50 2011] [notice] SSL FIPS mode disabled
    [Tue Sep 06 15:48:50 2011] [notice] Apache/2.2.17 (Unix) DAV/2 mod_fcgid/2.3.6 PHP/5.3.6 mod_python/3.3.1 Python/2.7 mod_ruby/1.3.0 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.17 OpenSSL/1.0.0d-fips mod_perl/2.0.4 Perl/v5.12.3 configured -- resuming normal operations
    [Tue Sep 06 15:50:04 2011] [notice] caught SIGTERM, shutting down
    [Tue Sep 06 15:50:05 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Tue Sep 06 15:50:05 2011] [notice] SSL FIPS mode disabled
    [Tue Sep 06 15:50:05 2011] [notice] Digest: generating secret for digest authentication ...
    [Tue Sep 06 15:50:05 2011] [notice] Digest: done
    [Tue Sep 06 15:50:05 2011] [notice] mod_python: Creating 4 session mutexes based on 512 max processes and 0 max threads.
    [Tue Sep 06 15:50:05 2011] [notice] mod_python: using mutex_directory /tmp
    [Tue Sep 06 15:50:05 2011] [notice] SSL FIPS mode disabled
    [Tue Sep 06 15:50:05 2011] [notice] Apache/2.2.17 (Unix) DAV/2 mod_fcgid/2.3.6 PHP/5.3.6 mod_python/3.3.1 Python/2.7 mod_ruby/1.3.0 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.17 OpenSSL/1.0.0d-fips mod_perl/2.0.4 Perl/v5.12.3 configured -- resuming normal operations
    [Tue Sep 06 16:19:59 2011] [error] [client 66.249.68.9] File does not exist: /var/www/html/blog
    [Tue Sep 06 16:34:36 2011] [error] [client 119.255.28.229] File does not exist: /var/www/html/manager

    I have generally been using Fast-CGI of suPHP.

    As far as rewrite rules, no I haven't. I didn't know I should be. My understanding is that this can be done via Apache as a whole (httpd.conf) or via .htaccess. I would rather it be done via .htaccess, but if you will instruct or recommend, I will follow this path. In the past, on a VPS, the rewrite rule was located in .htaccess for each site. Please advise.

    Thanks for your help.
     
  4. midcarolina

    midcarolina New Member

    I checked on the rewrite rules, though these were generally enabled by default on every install that I have done and they were enabled. Although this was the first time I have ever had to try this, I followed the Apache website on creating the filepath for the specific vhost as:

    <virtualhost>
    info
    info
    </virtualhost>

    Still no go. Again, all reverse lookups, domain ns lookups, etc. all resolve perfectly everytime. Still no websites. One on one server and one on the other. The "Monitors" for both servers show all servers online (Green) while the ISPConfig Android App shows DNS for TCP adn UDP offline.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Remove any vhost files that you created manually.
    2) Go to the website settings and make sure that you selected the same IP address in the website settings that you use for the dns a-records of the domain. If the IP does not show up in the select field, then add it first under System > server IP.
    3) If the website contains php code, then select "php-fcgi" as php method and enable the suexec checkbox.
    4) Make sure that you selected "auto subdomain: www" if you want to reach the website with domain.tld and www.domain.tld
     
  6. midcarolina

    midcarolina New Member

    Hi Till,

    Well, I did all of these things, checked the database and connection string to wp-config (WordPress site). Still get 500 internal server error...on both.

    Again, the nameservers resolve using several tools like verisign whois and many more. They all resolve correctly. php set to fast-cgi, ip is correct, you name it. No go....both sites, two different servers.

    The monitor still shows all servers "online".
     
  7. midcarolina

    midcarolina New Member

    Also, just checked Apache error log. This is the outcome:


    [Fri Sep 09 05:43:03 2011] [notice] SSL FIPS mode disabled
    [Fri Sep 09 05:43:03 2011] [notice] Apache/2.2.17 (Unix) DAV/2 mod_fcgid/2.3.6 PHP/5.3.6 mod_python/3.3.1 Python/2.7 mod_ruby/1.3.0 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.17 OpenSSL/1.0.0d-fips mod_perl/2.0.4 Perl/v5.12.3 configured -- resuming normal operations
    [Fri Sep 09 05:45:25 2011] [notice] caught SIGTERM, shutting down
    [Fri Sep 09 05:45:26 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Fri Sep 09 05:45:26 2011] [notice] SSL FIPS mode disabled
    [Fri Sep 09 05:45:26 2011] [notice] Digest: generating secret for digest authentication ...
    [Fri Sep 09 05:45:26 2011] [notice] Digest: done
    [Fri Sep 09 05:45:26 2011] [notice] mod_python: Creating 4 session mutexes based on 512 max processes and 0 max threads.
    [Fri Sep 09 05:45:26 2011] [notice] mod_python: using mutex_directory /tmp
    [Fri Sep 09 05:45:26 2011] [notice] SSL FIPS mode disabled
    [Fri Sep 09 05:45:26 2011] [notice] Apache/2.2.17 (Unix) DAV/2 mod_fcgid/2.3.6 PHP/5.3.6 mod_python/3.3.1 Python/2.7 mod_ruby/1.3.0 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.17 OpenSSL/1.0.0d-fips mod_perl/2.0.4 Perl/v5.12.3 configured -- resuming normal operations
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You checked the wrong error.log. for errors that you get in a website, you will have to check the website error.log and not the global apache error.log.
     
  9. midcarolina

    midcarolina New Member

    My bad Till. Here is that outcome, although the files that the error logs don't exist, clicking the next level, I am staring at them directly???

    Failed opening required '/var/www/clients/client1/web1/web//wp-admin/includes/template.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/clients/client1/web1/web/wp-content/plugins/feedwordpress/feedwordpress-walker-category-checklist.class.php on line 10
    [Fri Sep 09 05:28:36 2011] [error] [client 209.85.224.99] PHP Warning: require_once(/var/www/clients/client1/web1/web//wp-admin/includes/template.php): failed to open stream: No such file or directory in /var/www/clients/client1/web1/web/wp-content/plugins/feedwordpress/feedwordpress-walker-category-checklist.class.php on line 10
    [Fri Sep 09 05:28:36 2011] [error] [client 209.85.224.99] PHP Fatal error: require_once(): Failed opening required '/var/www/clients/client1/web1/web//wp-admin/includes/template.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/clients/client1/web1/web/wp-content/plugins/feedwordpress/feedwordpress-walker-category-checklist.class.php on line 10
    [Fri Sep 09 05:46:31 2011] [warn] [client 70.155.163.2] mod_fcgid: stderr: PHP Warning: require_once(/var/www/clients/client1/web1/web//wp-admin/includes/template.php): failed to open stream: No such file or directory in /var/www/clients/client1/web1/web/wp-content/plugins/feedwordpress/feedwordpress-walker-category-checklist.class.php on line 10
    [Fri Sep 09 05:46:31 2011] [warn] [client 70.155.163.2] mod_fcgid: stderr: PHP Fatal error: require_once(): Failed opening required '/var/www/clients/client1/web1/web//wp-admin/includes/template.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/clients/client1/web1/web/wp-content/plugins/feedwordpress/feedwordpress-walker-category-checklist.class.php on line 10
    [Fri Sep 09 05:47:49 2011] [warn] [client 58.61.164.40] mod_fcgid: stderr: PHP Warning: require_once(/var/www/clients/client1/web1/web//wp-admin/includes/template.php): failed to open stream: No such file or directory in /var/www/clients/client1/web1/web/wp-content/plugins/feedwordpress/feedwordpress-walker-category-checklist.class.php on line 10
    [Fri Sep 09 05:47:49 2011] [warn] [client 58.61.164.40] mod_fcgid: stderr: PHP Fatal error: require_once(): Failed opening required '/var/www/clients/client1/web1/web//wp-admin/includes/template.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/clients/client1/web1/web/wp-content/plugins/feedwordpress/feedwordpress-walker-category-checklist.class.php on line 10
    [Fri Sep 09 05:52:56 2011] [warn] [client 77.88.42.27] mod_fcgid: stderr: PHP Warning: require_once(/var/www/clients/client1/web1/web//wp-admin/includes/template.php): failed to open stream: No such file or directory in /var/www/clients/client1/web1/web/wp-content/plugins/feedwordpress/feedwordpress-walker-category-checklist.class.php on line 10
    [Fri Sep 09 05:52:56 2011] [warn] [client 77.88.42.27] mod_fcgid: stderr: PHP Fatal error: require_once():

    Although, I am wondering why the filepath for wp-admin has two // instead of one. It should show /var/www/clients/client1/web1/web/wp-admin, but instead has two // between web and wp-admin?

    Thanks Till
     
  10. mentes

    mentes Member

    That maybe comes from WP installation.

    Search in WP config file if there are some var with absolute path, and remove the last slash.

    $var = "/var/www/clients/client1/web1/web/";

    should be

    $var = "/var/www/clients/client1/web1/web";
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The path might also be stored in the wordpress database, in case that you moved the wordpress installation from another server.
     

Share This Page