ISPConfig 3 without mod_fcgid doesn't work.

Discussion in 'Installation/Configuration' started by zolitheman648, Jun 29, 2016.

  1. zolitheman648

    zolitheman648 New Member

    Hello everyone,

    I have just installed an Ubuntu 14.04 server basen on your perfect server tutorial. All works except the ISPConfig 3.
    If I wanna go to the :8080 site it drops me to the root folder, and if i click the ispconfig folder it shows only raw php code.

    I think it is because in the 000-ispconfig.vhost i have this:

    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
    Options -Indexes +FollowSymLinks +MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    <FilesMatch "\.php$">
    SetHandler fcgid-script
    FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    Require all granted
    IPCCommTimeout 7200
    MaxRequestLen 15728640

    As I see it would be responsible for the redirection and the php execution.
    The tutorial makes me install PHP-FPM and mod_fastcgi and tells that PHP-FPM doesn't work with fcgid.
    So the mod_fcgid isn't activated.

    I tried to activate it, but i couldn't restart apache then, i think because of the conflict mentioned above. Do i have to change the vhost file, or is it something else? I'm just a beginner so I appreciate all the "tips and tricks".

    Thanks for the help, Zoli
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The tutorial is absolutely fine, just follow it to the letter. The tutorial instructs you to install mod_fcgid AND mod_fastcgi because mod_fastcgi is required as addition to mod_fcgi to run php-fpm. It does not say that mod_fcgi and mod_fastcgi can not be used together.

    There is no conflict.

    The vhost file is perfectly fine and as it should be.

    There is something else, just take a look at the apache error.log and post the error that you get there.
  3. zolitheman648

    zolitheman648 New Member

    Oh, I'm sorry, it seems i misunderstood this.

    So I reenabled fcgid, then tried to restart apache to catch the right problem.
    The log says:
    [Wed Jun 29 06:13:57.670954 2016] [ssl:warn] [pid 20258] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Wed Jun 29 06:13:57.675206 2016] [ssl:warn] [pid 20258] AH01909: RSA certificate configured for does NOT include an ID which matches the server name
    [Wed Jun 29 06:13:57.675576 2016] [suexec:notice] [pid 20258] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Wed Jun 29 06:13:57.738737 2016] [auth_digest:notice] [pid 20260] AH01757: generating secret for digest authentication ...
    [Wed Jun 29 06:13:57.752711 2016] [fcgid:emerg] [pid 20260] (2)No such file or directory: mod_fcgid: Can't create shared memory for size 1200712 bytes
    [Wed Jun 29 06:13:57.760156 2016] [:notice] [pid 20265] FastCGI: process manager initialized (pid 20265)
    [Wed Jun 29 06:13:57.760250 2016] [:alert] [pid 20265] FastCGI: read() from pipe failed (0)
    [Wed Jun 29 06:13:57.760269 2016] [:alert] [pid 20265] FastCGI: the PM is shutting down, Apache seems to have disappeared - bye
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. zolitheman648

    zolitheman648 New Member

    Thank you, that worked!
    After the first suggestion the apache server started, ISPConfig still doesn't, it gave me Error 503.
    Had to change /var/lib/apache2/fcgid permission, but after that all went fine.
    Now i can login into ISPConfig!

Share This Page