ISPConfig 3 with no email

Discussion in 'General' started by wp-killer, Jun 19, 2018.

  1. wp-killer

    wp-killer New Member

    Hi,

    I've installed ISPConfig 3 on VULTR's server with Ubuntu 16.04.
    As I saw the email feature are draining the ram (1GB), I've decided to remove all email related modules (amavis, clamav etc...).
    The thing is, I still have the following 3 tasks running almost always, with over 10% usage of RAM:

    Code:
    /usr/bin/php-cgi -d open_basedir=none -d upload_tmp_dir=/var/www/clients/client0/web3/tmp -d sendmail_path=/usr/sbin/sendmail -t -i -f [email protected]
    As you can see, it states to be a sendmail tasks, though I've made sure sendmail is not installed on my system.
    So, is it maybe something else, using the same name? Or is it indeed sendmail? And if it is - how can I get rid of it?

    TIA!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    No, it does not state to be a sendmail task. This is the php process of your website.
     
  3. wp-killer

    wp-killer New Member

    Wow, till, that was a prompt answer! Thanks (I read you a lot the last days :).
    So, there's no way to cut the MEM usage for this?

    Also, in the logs I can find email related activities such as:

    Code:
    Jun 19 12:27:35 panel postfix/qmgr[1677]: C162243643: from=<[email protected]iller.com>, size=619, nrcpt=1 (queue active)
    Jun 19 12:27:35 panel postfix/smtp[6095]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    How can I disable these?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, at least not if you want to be able to run PHP scripts in your website. The PHP mode that uses the least resources is 'PHP-FPM' and on the options tab of the website you can fine tune it, the mode that you set there should be 'ondemand'.

    A Linux system needs at least a minimal a email daemon and you removed parts of a fully configured mail system which now makes the whole mail system fail. You'll have to adjust the postfix config too after you removed the services: https://www.faqforge.com/linux/cont...ilter-and-antivirus-functions-in-ispconfig-3/ Read also the comments as /etc/postfix/tag_as_foreign.re needs to be edited too.
     

Share This Page