ISPConfig 3 show blank page

Discussion in 'General' started by Uysimty, Jun 19, 2019.

  1. Uysimty

    Uysimty New Member

    I don't know whether you still able to help with this or not. But I found out the blank page didn't generated by ISPConfig. Instead it generate by /var/www/html so I add

    DocumentRoot /var/www/ispconfig/

    To apache. But instead it show the source code of ISPConfig index.php instead of executing it
     
  2. Uysimty

    Uysimty New Member

    My Apache Config
    NameVirtualHost *:80

    <VirtualHost _default_:80>
    ServerAdmin [email protected]
    ServerName mydomain.com
    <Directory /var/www/ispconfig/>
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    </Directory>
    <Directory /usr/local/ispconfig/interface/web/>
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    </Directory>

    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
    Options -Indexes +FollowSymLinks +MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    <FilesMatch "\.php$">
    SetHandler fcgid-script
    </FilesMatch>
    FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    Require all granted
    </Directory>
    IPCCommTimeout 7200
    MaxRequestLen 15728640
    </IfModule>

    <IfModule mpm_itk_module>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AssignUserId ispconfig ispconfig
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
    # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
    Options +FollowSymLinks
    AllowOverride None
    Require all granted
    php_value magic_quotes_gpc 0
    </Directory>
    </IfModule>

    # ErrorLog /var/log/apache2/error.log
    # CustomLog /var/log/apache2/access.log combined
    ServerSignature Off

    <IfModule mod_security2.c>
    SecRuleEngine Off
    </IfModule>

    <IfModule mod_headers.c>
    Header always add Strict-Transport-Security "max-age=15768000"
    RequestHeader unset Proxy early
    </IfModule>

    </VirtualHost>

    <IfModule mod_ssl.c>
    SSLStaplingCache shmcb:/var/run/ocsp(128000)
    </IfModule>

    <Directory /var/www/php-cgi-scripts>
    AllowOverride None
    Require all denied
    </Directory>

    <Directory /var/www/php-fcgi-scripts>
    AllowOverride None
    Require all
    </Directory>
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Go trough the apache and php installation steps from the tutorial again to ensure that all php and apache modules are installed. You seem to have removed the mod_fcgid apache module. and undo the document root change you made.
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What do you have in files
    Code:
    /etc/apache2/sites-enabled/000-ispconfig.conf
    /etc/apache2/sites-enabled/000-ispconfig.vhost
    And please post in CODE tags listings and logs.
     
  5. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    He means that you should use [ code ]your code here[ /code ] when posting codes i.e. without any spaces in the said brackets []. We cannot read posted codes properly if you do not use that code tags.
     

Share This Page