ISPConfig 3 Roundcube Plugin

Discussion in 'ISPConfig 3 Priority Support' started by Gaston Girardi, Jan 29, 2020.

  1. Gaston Girardi

    Gaston Girardi Member HowtoForge Supporter

    Hi everybody, i've follow the guide "ISPConfig 3 Roundcube Plugin on Debian 9 (Stretch)" https://www.howtoforge.com/tutorial/ispconfig-3-roundcube-plugins-on-debian-stretch/, but i have no success in getting the plugins to work.

    I've always get the message "Soap Error: Could not connect to host", my config.inc.php file looks like this:
    Code:
    <?php
    $rcmail_config['identity_limit'] = false;
    $rcmail_config['remote_soap_user'] = 'myuser';
    $rcmail_config['remote_soap_pass'] = 'mypass';
    $rcmail_config['soap_url'] = 'https://mydomain:2763/remote/';
    $rcmail_config['soap_validate_cert'] = false;
    ?>
    
    On the soup url, i've tried with the domain, one of the IPs of the server, even localhost, but i've always get the same message, and on the soap cert, i've tried with 'false', 'true', commented the line, and nothing.

    Because of that i've been trying to find the logs related to the plugins, to have a more clear idea of why is no connecting to the host, but i haven't be lucky, so if anyone can lend me a hand i will appreciate it.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If you use httpS in soap URL, the host must have valid certificate. Have you verified the certificate is OK?
    If the host does not have certificate, you must use http:// as protocol here.
    Is the port number in soap_url correct and you have verified that is a working port in your setup?
    If you use httpS and a valid certificate, I think you must use FQDN in the soap_url so hostname can be compared to the certified FQDN. Plain domainname in soap_url does not work.
     
  3. Th0m

    Th0m Member HowtoForge Supporter

    Also, did you allow the user to remotely access the server?
     
  4. Gaston Girardi

    Gaston Girardi Member HowtoForge Supporter

    @Taleman about your points:
    1- The Cert i have is the self generated by the ISPConfig install, that's why in the soap_validate_cert i let the value in "false", but as a comment i also try it with "true", and commented.
    2- About the port, during the install of ISPConfig I changed it, and i can access the panel with out problems.
    3- About the FQDN, i check it and i have the same message.

    @Th0m
    If you mean go into my panel > System > Remote User, and create a user, yes i did.
     
  5. Th0m

    Th0m Member HowtoForge Supporter

    You have to enable the checkbox "enable remote access" for the remote user (and eventually add the IPv4 and IPv6 of your server for security purposes) and indeed use http.
     
  6. Th0m

    Th0m Member HowtoForge Supporter

    I looked at my own file and it doesn't close with
    Code:
    ?>
    Neither does the one at github, so try leaving it out (weird though)
     
  7. Gaston Girardi

    Gaston Girardi Member HowtoForge Supporter

    @Th0m If you check the tutorial, they put the closing of the php code "?>", that's why i add it to the file.

    With the http i think is not possible because if i try to access the panel without "s", i receive an error message:
    Code:
    Your browser sent a request that this server could not understand.
    Reason: You're speaking plain HTTP to an SSL-enabled server port.
    Instead use the HTTPS scheme to access this URL, please.
    
    So if this simple test didn't work, i think it wont with the remote option either.

    About the checkbox that you mention, yes I enabled it, and is still enable.

    And I think the problem i've got is because i'm using a self certificate, instead of a valid one like LE or other, but i'm not quite sure about this, that's why originally i was asking if someone knows where to find the logs of the plugins to check if theres a better description os the problem.
     
  8. Th0m

    Th0m Member HowtoForge Supporter

    You are right about the https, I think :) But I don't think that the certificate is the problem. Now that I really compare my config and yours, I see a difference:
    Code:
    <?php
    $config['identity_limit'] = false;
    $config['remote_soap_user'] = 'pluginuser';
    $config['remote_soap_pass'] = 'ExamplePassword';
    $config['soap_url'] = 'https:/server1.example.com:8080/remote/';
    $config['soap_validate_cert'] = true;
    So you should remove
    Code:
    rcmail_
    The tutorial is on HTF outdated. Follow this one instead: https://github.com/w2c/ispconfig3_roundcube/wiki/Installation
    Maybe @Taleman can update the HTF tutorial.
     
  9. Gaston Girardi

    Gaston Girardi Member HowtoForge Supporter

    I did that and i still have the same error. :confused:
     
  10. Th0m

    Th0m Member HowtoForge Supporter

    Undo everything you've done and follow the turorial from the wiki I sent :)
     
    Gaston Girardi likes this.
  11. Gaston Girardi

    Gaston Girardi Member HowtoForge Supporter

    I did that, and it's working, at least the plugin to change the password, now i'm going to check the others. :D
     
  12. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I used the Howtoforge Tutorial on December to install the plugins on host running on Debian 10.x. The plugins are working.
    I can not see what significant setting is different on my Tutorial compared to the one @Th0m posted a link to.
     
  13. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    The tutorials are like print publications, they can not be updated after publication. Sorry.
     
  14. Th0m

    Th0m Member HowtoForge Supporter

    Great, hope everything works!
    The config file is different in the newest version of the plugin. It must be possible for @till to change it ;)
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    I can put an editable copy of the guide into your account if you like to update it.
     

Share This Page