ISPConfig 3 redirects to wrong domain

Discussion in 'General' started by SupportMyster, Nov 10, 2011.

  1. SupportMyster

    SupportMyster New Member

    Unbuntu 10.04 perfert setup and updated
    ISPConfig 3.0.3.3

    Scenario: Logged in as a reseller, I created a client. Because the client wants a simple website I set the limits for subdomains and aliases to 0.

    When I went to test the site, I can reach domain.tld but not www.domain.tld

    Realizing that I need the domain to have a subdomain (auto-subdomain) to see www, as the reseller I changed subdomain to 1 but it does not seem to have had any effect.

    The server's name is server1.domain-1.tld. When I try to visit the www.domain.tld it redirects to www.domain-1.tld which resides on another machine and at a completely different IP address.

    I have checked the vhost file and the ServerAlias line changes from * to www when changed in ISPConfig. It seems the limit has not changed for the client. How can I fix this other that delete the client a create anew?

    Also why the redirect to www of the base domain?
     
  2. till

    till Super Moderator

    Then the DNS record for www.domain-1.tld points to the wrong IP address. So thats not a issue with the website on your ispconfig server.
     
  3. SupportMyster

    SupportMyster New Member

    Solved

    The DNS setting were correct.

    It seems I had to flush what Firefox 8.0 knew to get it to work. I had closed and restarted firefox, even shutdown and restarted the machine, but that was not enough. I had to Tools->Options->Privacy->Clear all to get it working.

    Thanks for the quick reply.
     

Share This Page