ISPConfig 3 RC1 Incoming eMail

Discussion in 'Developers' Forum' started by AceFrahm, Jan 28, 2009.

  1. AceFrahm

    AceFrahm New Member

    I think I created a mailuser correctly, but this installation isn't accepting mail for it.

    But I can send an e-Mail to hotmail and to gmail from it ! :confused:

    This is the failure message from hotmail ( I added extra ______ to foil forum-scraping spambots):
    Code:
    Reporting-MTA: dns; dns01.acefrahm._____com
    X-Postfix-Queue-ID: AD9301B6515
    X-Postfix-Sender: rfc822; acefrahm@_____hotmail.____com
    Arrival-Date: Tue, 27 Jan 2009 14:24:50 -0500 (EST)
    
    Final-Recipient: rfc822; ace.frahm@____acefrahm.______com
    Original-Recipient: rfc822;ace.frahm@____acefrahm.______com
    Action: failed
    Status: 5.1.1
    Diagnostic-Code: x-unix; Invalid user specified.
    It fails similarly when sending from gmail too.

    http://www.acefrahm.com/screenshot/ScreenShot2.png

    http://www.acefrahm.com/screenshot/ScreenShot3.png

    http://www.acefrahm.com/screenshot/ScreenShot4.png

    http://www.acefrahm.com/screenshot/ScreenShot5.png

    http://www.acefrahm.com/screenshot/ScreenShot6.png
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the error messages from the mail log of your server.
     
  3. AceFrahm

    AceFrahm New Member

    Last edited: Jan 28, 2009
  4. afredriksson

    afredriksson New Member

    Hi everyone. I have had the same problem on my Ubuntu installation and have after a few days of searching down wrong tracks found the solution.

    The problem is, at least in Ubuntu, that authlib support is absent in the courier-maildrop package. Once I found out that this was my problem, I was able to get it to work by removing the courier-maildrop package and instead install the standalone maildrop package:

    Code:
    sudo apt-get remove courier-maildrop
    sudo apt-get install maildrop
    
    I don't know where else I need to post this solution, someone please direct me. I am a newbee to this site.

    And by the way. WOW! This is a great product! :)
     
    Last edited: Jan 29, 2009
  5. AceFrahm

    AceFrahm New Member

    Replaced courier-maildrop with maildrop

    And I deleted the e-mail domain and recreated it and the user.
    Gmail says:


    user unknown. Command output: ERR: authdaemon:
    s_connect() failed: Permission denied Invalid user specified.
    Status: 5.1.1

    Diagnostic-Code: x-unix; ERR: authdaemon: s_connect() failed: Permission denied
    Invalid user specified.

    Hotmail says:
    user unknown. Command output: ERR: authdaemon:s_connect() failed: Permission denied Invalid user specified.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    This happens when you send an email to your server?
    What's in your mail log now?
     
  7. AceFrahm

    AceFrahm New Member

    BAD_HEADER: Improper use of control character

    I found this line in a file called:
    /var/mail/www-data

    Code:
       554 5.6.0 Reject, id=05252-01 - BAD_HEADER: Improper use of control character (char 0D hex): MIME-Version: 1.0\r
    Here's a screen shot of that file:
    http://acefrahm.com/screenshot/screenshot2009-01-29_002.png

    Here's the Show Mail Log from ISPConfig3:
    http://acefrahm.com/screenshot/screenshot2009-01-29_001.png


    And here's the tail end of /var/log/mail.log
    http://acefrahm.com/screenshot/screenshot2009-01-29_003.png
     
  8. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/posstfix/main.cf? Which distribution are you using?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Your system seems to work properly. You will just have to change the mailscan option for the email account and domain to not rejecet bad headers.
     
  10. Inco

    Inco New Member

    bad maildrop

    problem in master.cf in postfix, with arguments who send pipe to maildrop and .mailfilter don't know this argument.
    known torouble as "user unknown. Command output: /usr/local/bin/maildrop: Invalid user specified."
    I use next configuration master.cf


    maildrop unix - n n - - pipe
    flags=R user=vmail argv=/usr/bin/maildrop -dvmail ${extension} ${recipient} ${user} ${domain} ${sender}

    work fine. ubuntu 8.10
     
  11. jpb77

    jpb77 New Member

    Same problem here with Ubuntu 8.10.

    Now it's working with Inco's solution, but you must put a space between "-d" and "vmail":

    flags=R user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${domain} ${sender}

    Thanks Inco.
     
  12. gemini

    gemini New Member

    Same problem on Debian 4.0, need help (newbie)

    Hello,

    I've got similar problem with mails with ISPConfig and Debian 4.0

    Feb 3 14:58:57 stock postfix/pipe[7008]: C1879109E58: to=, relay=maildrop, delay=0.09, delays=0.06/0.02/0/0.01, dsn=5.1.1, status=bounced (user unknown. Command output: Invalid user specified. )

    Full mail log located here
    Postfix master.cf
    When I tried to change postfix config for listed above then error occured:
    Code:
    Feb 3 15:38:05 stock postfix/cleanup[24092]: 3E9B210A4F4: message-id=<[email protected]>
    Feb 3 15:38:05 stock postfix/qmgr[24084]: 3E9B210A4F4: from=, size=2106, nrcpt=1 (queue active)
    Feb 3 15:38:05 stock postfix/pipe[24097]: warning: file /etc/postfix/master.cf: service maildrop: unknown macro name: "domain"
    Feb 3 15:38:05 stock postfix/smtpd[24095]: disconnect from localhost.localdomain[127.0.0.1]
    

    What is strange, that "to=" parameter isn't specified (log is unedited).

    maildrop -d my_email@my_domain.com
    shows "Invalid user specified"
    while I'm sure there is such user within mysql DB of IspConfig
    Does the maildrop use some cache or something or should it use straight from mysql? Because I don't see any queries to DB.
     
  13. AceFrahm

    AceFrahm New Member

    I followed Inco's instruction, but I don't really know what it does, I was just hoping for something simple that would work.
    I tried Inco's solution with jpb77's extra space added, on a fresh complete reinstallation.
    It did not work for me. I get the same error.

    I also get the same result as gemini:
    But I can see my e-mail user in the MySQL ispconfigdb mail_user table!!!???


    maildrop -d ___ace___.___frahm___@__acefrahm___.com [without the underscores]

    produces the same "Invalid user specified" message for me that gemini got.

    :confused:-------------:confused:-----------------:confused:-----------------:confused:
    I would like to use ISPConfig as a no-brainer IMAP mailbox auto-config, but I'm willing to learn how to make a mail-server run from scratch if I must.

    till: when you said:
    What did you mean exactly?
    This user already has no spamfilter applied, and no other rules of any kind applied.
    Exactly how do I tell ISPConfig to accept bad headers, and if I do, aren't I defeating spam filtering and Clam Antivirus?
     
  14. AceFrahm

    AceFrahm New Member

    AHA! I incorrectly added jpb77's space to Inco's line!

    In

    /etc/postfix/master.cf

    I put this on the maildrop line:
    Code:
      flags=R user=vmail argv=/usr/bin/maildrop -dv mail ${extension} ${recipient} ${user} ${domain} ${sender}
    Notice the incorrect "-dv mail".

    I should have put THIS on the maildrop line instead:
    Code:
      flags=R user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${domain} ${sender}
    Notice the correct "-d vmail".

    A message sent from gmail can now get through.
    :D

    Thank you friends for your help!
    :)

    For anyone else in trouble with your install trying to follow along with this thread, I did not find it necessary to replace courier-maildrop with plain old maildrop as in afredriksson's post:
    Even though he reports his switcheroo worked for him.
     
  15. AceFrahm

    AceFrahm New Member

    Hey gemini, I got it working on Ubuntu Intrepid Ibex. Is there any particular reason you're using ordinary Debian instead?
    Ubuntu is built on debian.
     
    Last edited: Feb 4, 2009
  16. gemini

    gemini New Member

    Well, I've choosed debian because it's more recommended as server distribution while ubuntu is recommended more as desktop (I'm not very advanced linux user, so I relied on others opinions).
    Currently I'd rather avoid changing OS, since I've already moved everything on new server, dropped old one, and reinstall of server would mean downtime of websites as well as a lot of work. Everything works perfectly, except mail.


    P.S. I can't find any maildrop mysql related config.
    Is there any way to test mysql/support/connection with maildrop? I can't find such option ;/
     

Share This Page