ISPConfig 3 RC 1 User domains all redirected to "It works!" apache message

Discussion in 'Installation/Configuration' started by qriz, Feb 24, 2009.

  1. qriz

    qriz New Member

    I don't know how it happened and can't figure out how to fix it.

    Here's what i got:

    I'm sitting behind a router
    Server is DMZ
    Debian lenny
    ISPConfig 3 RC 1
    DynDns Domain

    installation was done using Instructions from your website
    it worked fine for two weeks

    and then it was offline ( this was a problem with DynDNS )
    after refreshing IP it worked till next day

    now i get the "It works" message with all domains on this server.

    Please HELP

    which informations you need me to provide ?

    I have full access to the control panel and all services are online.

    I assume it's configuration problem (I try since two days to find a solution and lost track over changes i made.)

    also i upgraded from etch to lenny

    Thank You
     
  2. till

    till Super Moderator

    thr rc1 is outdated, please update to rc2.
     
  3. qriz

    qriz New Member

    ok I swear it searched for it but how can i update without fresh install?

    i tried to install over the existing one it tells me : "ERROR: Stopped: Database already contains some tables."

    is there an update script or how to ?

    thanks
     
  4. till

    till Super Moderator

    There is a script, it is named update.php and its in the same directory as the install script.
     
  5. merlincc

    merlincc New Member

    To update from rc1 to rc2

    From the ISPConfig 3.0.0.9 RC2 released thread:

    Update
    --------------------

    To update existing ISPConfig 3 installations, run this command on the shell:

    ispconfig_update_from_svn.sh

    Worked well for me.
     
  6. qriz

    qriz New Member

    i got this message:

    ispconfigERROR: Unable to load SQL-Dump into database table.
     
  7. qriz

    qriz New Member

    i tried as well and get this:

    Fatal error: Cannot use string offset as an array in /tmp/trunk/install/update.php on line146
     
  8. till

    till Super Moderator

    Most likely your installation is damaged as you run the install script on It again. the best is to run the uninstall script and then reinstall ispconfig.
     
  9. qriz

    qriz New Member

    It's still not working :-(

    i uninstalled it

    then tried php -q install.php again same result

    ERROR: Unable to load SQL-Dump into database table.

    I'll try to go through the installation instructions again
    and then reinstall everything ( That sucks )
     
  10. till

    till Super Moderator

    And you are sure that you used the mysql root user to install ispconfig?
     
  11. qriz

    qriz New Member

    yes i am and i found the problem

    i had a problem earlier what to many connections and googled for a solution

    i added the following to /etc/mysql/my.cnf

    set-variable = max_connections=500

    after i removed it i could reinstall

    thanks for the help
     
  12. qriz

    qriz New Member

    yes i am

    and i found the problem
    earlier today i added the following line to /etc/mysql/my.cnf

    set-variable = max_connections=500

    it was a suggested solution to a different problem
    after taking that line out the install run succesfull

    but i got this warning: after restarting the services:

    [warn] _default_ VirtualHost overlap on port 80, the first has precedence

    and the domains are still pointing to the "It works" message
     
  13. till

    till Super Moderator

    1) Did you select * or an IP address for the website?
    2) Have you double checked that the domain name really points to the IP of the server?
     
  14. qriz

    qriz New Member

    Ok i checked again

    I tried both (wild card * and manual configured192.168.0.100 )

    The domains are pointed right. At least on my server but i land in the apache index

    I really appreciate your effort and hope we can resolve this soon :)
     
  15. qriz

    qriz New Member

    weird now it works ( maybe a cache problem )

    but now i cant reach the php my admin from the panel anymore

    i'm sorry
     

Share This Page