ispconfig 3 problems

Discussion in 'General' started by betafer, Sep 26, 2013.

  1. betafer

    betafer New Member

    Hello,

    we have ispconfig 3, and because of some faulty installation (after a black hat messed up our server), we have many problems with it.

    For example;
    - We cannot set up a new email user.
    - No logs available from ispconfig.
    - SSH does get disconnected after a very little while (one-two minutes).
    - And so on.

    What can we do to solve the problem? We already tried a new installation/update to the new ispconfig 3 version, but with no result.


    Thank you,
    --
    Betafer
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. betafer

    betafer New Member

    Sorry, here the infos:

    We have Apache/2.2.16 on Debian 6
    And ISPConfig 3.0.5.3
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    At the end of the post that i linked above, there are instructions on how to debug issues when changes were not written to disk.

    Regarding the ssh disconnects, are you sure that the system is really cleaned? These symptoms are not good and I guess that the hacker i still active on your server. Have you checked the server with rkhunter and chkrootkit for rootkits?
     
  5. betafer

    betafer New Member

    Hello,

    technically there was no hacker, just an unsatisfied sysadmin that played with our configurations files. We also checked with those tools, and there was no problem.

    We reinstalled (somehow) the ispconfig. The logs are finally working, and also the email creation.

    There is still some problem with the Apache/cgi/fastcgid; ispconfig continues to rewrite our vhost config files, so the website goes down when it recreates them with its own rules.

    As for the fastcgi problem, some pages are not loading, and the server throws errors, such as:


    [Thu Oct 03 16:38:27 2013] [emerg] [client X.X.X.X] (43)Identifier removed: mod_fcgid: can't lock process table in pid 17320, referer: http://www.betafer.it/it/chiavi-a-b...-esagonali-aas1316-p-22012-8014230429809.html
    [Thu Oct 03 16:56:06 2013] [warn] [client X.X.X.X] (70014)End of file found: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/es/

    We have a wordpress blog, but after this reinstallation, we cannot login in the admin panel, as we have:

    [Thu Oct 03 18:57:37 2013] [warn] [client X.X.X.X] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Thu Oct 03 18:57:37 2013] [warn] [client X.X.X.X] (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function

    We installed PrestaShop for our e-commerce, but it seems to work fine (except those fcgid errors).

    What is the problem? Thank you!


    Best Regards,
    --
    betafer.it
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe your admin placed a not working vhost file in the conf-custom folder /usr/local/ispconfig/server/conf-custom/ as the defaukt files delivered by ispconfig are working out of the box if your server matches the system requirements (perfect setup guides).
     
  7. betafer

    betafer New Member

    Hello,

    in that folder we have only these directory:

    4 drwxr-s--- 2 ispconfig ispconfig 4096 16 mar 2013 mail
    4 drwxr-s--- 2 ispconfig ispconfig 4096 25 ago 17.25 install
    4 drwxr-s--- 2 ispconfig ispconfig 4096 16 mar 2013 index
    4 drwxr-s--- 2 ispconfig ispconfig 4096 16 mar 2013 error

    [EDIT] Those folders are empty...
     
    Last edited: Oct 4, 2013
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok. And which parts of the vhost file are not working?
     
  9. betafer

    betafer New Member

    Hello,

    we have our own folder for the www contents of the website, as well as errors and access files.

    Sometimes, ispconfig decides to rewrite the vhost files, so we lose all our settings, and the website goes down because of the wrong settings ispconfig decides to put in the vhost file.

    How can we put our own vhost file, and be sure ispconfig does not rewrite it in any way?

    Also, we would like to solve the few problems we have with ispconfig and the webserver, as in the prevous posts. We also noticed the following error in the ispconfig error log:


    ven 4 ott 2013, 07.50.01, CEST FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
    ven 4 ott 2013, 07.50.01, CEST Failed to load mptctl
    ven 4 ott 2013, 07.50.01, CEST
    ven 4 ott 2013, 07.50.01, CEST Error: (CLI:003) Specified controller does not exist.
    ven 4 ott 2013, 07.50.01, CEST

    every 5 minutes. We tried to activate the module in the kernel, as it was already present the mptctl in the OS (Debian Squeeze), but with no success.



    Thank you,
    --
    betafer.it
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    a) Create a custom vhost configuration template and store it in the conf-custom folder.

    b) Do not create that website in ispconfig and manage it manually on the shell instead.
     
  11. betafer

    betafer New Member

    Hello,


    1) we have several websites on our webserver; should we put all our vhost conf files in that folder you mentioned before, or what?

    2) What about the problem we have:

    ven 4 ott 2013, 07.50.01, CEST FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
    ven 4 ott 2013, 07.50.01, CEST Failed to load mptctl
    ven 4 ott 2013, 07.50.01, CEST
    ven 4 ott 2013, 07.50.01, CEST Error: (CLI:003) Specified controller does not exist.
    ven 4 ott 2013, 07.50.01, CEST

    There are a lot of those errors in our ispconfig error log; we tried to do something about that module, but with no success, how can we keep ispconfig to throw it? Until now, that would be the only error isconfig was able to log.

    3) The errors we had:

    [Thu Oct 03 16:38:27 2013] [emerg] [client X.X.X.X] (43)Identifier removed: mod_fcgid: can't lock process table in pid 17320, referer: http://www.betafer.it/it/chiavi-a-bu...230429809.html
    [Thu Oct 03 16:56:06 2013] [warn] [client X.X.X.X] (70014)End of file found: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/es/

    was caused by the Apache reloading; we had to put in our crontab the following:

    /etc/init.d/apache2 reload

    to be able to get errors/access logs working again, as the server (maybe) stopped to write them after a while. But, because we reinstalled ispconfig, probably that command is not needed anymore. We will be sure tomorrow/after tomorrow.

    EDIT:
    I forgot to mention a lodbunch of errors, such as:

    [Fri Oct 04 15:28:50 2013] [error] [XXX] Premature end of script headers: index.php, referer: http://www.betafer.it/it/6070-tronchesi-beta
    [Fri Oct 04 16:00:04 2013] [emerg] [XXX] (22)Invalid argument: mod_fcgid: can't lock process table in pid 5553
    [Fri Oct 04 16:00:12 2013] [emerg] [XXX] (22)Invalid argument: mod_fcgid: can't lock process table in pid 6098, referer: http://www.betafer.it/el/el-κλειδιά...ρεφόμενη-καστάνια-192-8-13-8014230572406.html
    [Fri Oct 04 16:00:12 2013] [emerg] [XXX] (22)Invalid argument: mod_fcgid: can't lock process table in pid 6473, referer: http://www.betafer.it/el/el-κλειδιά...ρεφόμενη-καστάνια-192-8-13-8014230572406.html
    [Fri Oct 04 16:00:12 2013] [emerg] [XXX] (22)Invalid argument: mod_fcgid: can't lock process table in pid 5799, referer: http://www.betafer.it/el/el-κλειδιά...ρεφόμενη-καστάνια-192-8-13-8014230572406.html
    [Fri Oct 04 16:01:12 2013] [warn] [XXX] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Fri Oct 04 16:01:12 2013] [error] [XXX] Premature end of script headers: index.php
    [Fri Oct 04 16:40:22 2013] [warn] [XXX] (70014)End of file found: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/102879-termoformato-rigido-con-assortimento-di-utensili-t171
    [Fri Oct 04 16:40:22 2013] [warn] [XXX] (70014)End of file found: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/102879-termoformato-rigido-con-assortimento-di-utensili-t171
    [Fri Oct 04 16:41:59 2013] [warn] [XXX] (70014)End of file found: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/16060-attrezzi-per-ammortizzatori
    [Fri Oct 04 16:41:59 2013] [warn] [XXX] (70014)End of file found: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/16060-attrezzi-per-ammortizzatori
    [Fri Oct 04 16:43:36 2013] [warn] [XXX] (70014)End of file found: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/100659-pressore-per-molle-1556-2a
    [Fri Oct 04 16:43:36 2013] [warn] [XXX] (70014)End of file found: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/100659-pressore-per-molle-1556-2a
    [Fri Oct 04 16:44:30 2013] [warn] [XXX] (70007)The timeout specified has expired: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/16060-attrezzi-per-ammortizzatori
    [Fri Oct 04 16:44:40 2013] [warn] [XXX] (70007)The timeout specified has expired: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/16060-attrezzi-per-ammortizzatori
    [Fri Oct 04 16:48:25 2013] [emerg] [XXX] (22)Invalid argument: mod_fcgid: can't lock process table in pid 12098
    [Fri Oct 04 16:53:45 2013] [warn] [XXX] (70014)End of file found: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/giacca-rea...95020005-giacche-impermeabili-racing-xxl.html
    [Fri Oct 04 16:53:45 2013] [warn] [XXX] (70014)End of file found: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/giacca-rea...95020005-giacche-impermeabili-racing-xxl.html
    [Fri Oct 04 16:58:13 2013] [warn] [XXX] (70014)End of file found: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/101882-giacca-in-softshell-7675n
    [Fri Oct 04 16:58:13 2013] [warn] [XXX] (70014)End of file found: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/101882-giacca-in-softshell-7675n
    [Fri Oct 04 17:03:30 2013] [warn] [XXX] (70007)The timeout specified has expired: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/giacca-in-...ftshell-cappuccio-blue-tgm-8014230654621.html
    [Fri Oct 04 17:03:37 2013] [warn] [XXX] mod_fcgid: stderr: PHP Warning: preg_match() expects parameter 2 to be string, array given in /var/www/clients/client1/web1/web/betafer3/classes/Validate.php on line 177, referer: http://www.betafer.it/mercedes/inde...thread&token=a04c87149ed27ad6d4a5119f4208bc30
    [Fri Oct 04 17:03:40 2013] [warn] [XXX] (70007)The timeout specified has expired: mod_fcgid: can't get data from http client, referer: http://www.betafer.it/it/giacca-in-...ftshell-cappuccio-blue-tgm-8014230654621.html
    [Fri Oct 04 17:17:23 2013] [warn] [XXX] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Fri Oct 04 17:17:23 2013] [error] [XXX] Premature end of script headers: index.php

    The following:

    [emerg] [XXX] (22)Invalid argument: mod_fcgid: can't lock process table in pid

    should not appear again, as I mentioned above maybe we solve that one.

    But still we have very many errors in our logs. What should we do?


    Thank you,
    Best Regards,
    --
    betafer.it
     
    Last edited: Oct 4, 2013
  12. betafer

    betafer New Member

    Hello,

    after a little debug, I finally found out something. The following errors:

    were caused by a wordpress blog installed on the server, when successfully accessing the admin area. Before the reinstallation of ispconfig the blog was working normal. But, after the reinstallation, if you tried to log in the admin panel (by giving the correct username/password) you would get a 500 error, thus a 404 error given by the configuration of website where the blog is installed.

    In the admin configuration file of wp (wp-admin/admin.php), the following lines:

    PHP:
    if ( current_user_can'manage_options' ) )
        @
    ini_set'memory_limit'apply_filters'admin_memory_limit'WP_MAX_MEMORY_LIMIT ) );
    were causing the error. By commenting them out the admin area is working again as before.


    The other errors remain to be solved. I hope to found a solution as soon as possible.


    --
    betafer.it
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Check your php.oni file if there are any functions listed as disabled like the function ini_set.
     
  14. betafer

    betafer New Member

    Hello,


    The disable_functions line was empty in all the php.ini files, as I searched for all ini_set recurrence in those files:

    Code:
    [email protected] / # find / -name '*php.ini*' | xargs grep -i -l -n -r 'ini_set' 2>/dev/null
    [email protected] / #

    These are all the php.ini we have in our server:

    Code:
    [email protected] / # find / -name '*php.ini*'
    /var/www/conf/web1/php.ini
    /var/www/conf/web8/php.ini
    /usr/share/php5/php.ini-production.cli
    /usr/share/php5/php.ini-production
    /usr/share/doc/php5-common/examples/php.ini-development
    /etc/php5/apache2/php.ini
    /etc/php5/cgi/php.ini
    /etc/php5/cli/php.ini
    [email protected] / #

    Best Regards,
    --
    betafer.it
     
  15. betafer

    betafer New Member

    Any ideas ?

    Best Regards
     
  16. betafer

    betafer New Member

    we have made some changes and solved some problems,

    now in ISPConfig Log we got this error every minute:

    Debug Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

    How can we remove it ?
     

Share This Page