ISPConfig 3 problems with autoresponder

Discussion in 'Installation/Configuration' started by raiman, Aug 25, 2010.

  1. raiman

    raiman New Member

    Hi all, first sorry for bad english.

    i have problems with autoresponder, it doesnt work.
    OS: CentOS 5.5 upgraded from 5.4
    ISPConfig first installed 3.0.1.9, now updated to 3.0.2.2
    For installation i used this tutorial http://howtoforge.net/perfect-server-centos-5.3-x86_64-ispconfig-3
    When i first activated autoresponder and send mail to that mailbox i got response from mail server:
    The mail system
    <test1@opensuse.lt>: Command died with status 255: "/usr/bin/maildrop". Command
    output: *** glibc detected *** mailbot: free(): invalid pointer: 0xbfb6bcc9
    *** ======= Backtrace: ========= /lib/i686/nosegneg/libc.so.6[0x1dd1e5]
    /lib/i686/nosegneg/libc.so.6(cfree+0x59)[0x1dd629] mailbot[0x804aa13]
    /lib/i686/nosegneg/libc.so.6(__libc_start_main+0xdc)[0x188e9c]
    mailbot[0x8049631] ======= Memory map: ======== 00154000-0016f000 r-xp
    00000000 ca:02 1438990 /lib/ld-2.5.so 0016f000-00170000 r--p 0001a000
    ca:02 1438990 /lib/ld-2.5.so 00170000-00171000 rw-p 0001b000 ca:02
    1438990 /lib/ld-2.5.so 00173000-002c9000 r-xp 00000000 ca:02 1439062
    /lib/i686/nosegneg/libc-2.5.so 002c9000-002cb000 r--p 00155000 ca:02
    1439062 /lib/i686/nosegneg/libc-2.5.so 002cb000-002cc000 rw-p 00157000
    ca:02 1439062 /lib/i686/nosegneg/libc-2.5.so 002cc000-002cf000 rw-p
    002cc000 00:00 0 002e7000-002ed000 r-xp 00000000 ca:02 697779
    /usr/lib/libgdbm.so.2.0.0 002ed000-002ee000 rw-p 00005000 ca:02 697779
    /usr/lib/libgdbm.so.2.0.0 005b8000-005e8000 r-xp 00000000 ca:02 697281
    /usr/lib/libidn.so.11.5.19 005e8000-005e9000 rw-p 0002f000 ca:02 697281
    /usr/lib/libidn.so.11.5.19 00a00000-00a01000 r-xp 00a00000 00:00 0
    [vdso] 063b9000-063c4000 r-xp 00000000 ca:02 1439884
    /lib/libgcc_s-4.1.2-20080825.so.1 063c4000-063c5000 rw-p 0000a000 ca:02
    1439884 /lib/libgcc_s-4.1.2-20080825.so.1 08048000-08159000 r-xp
    00000000 ca:02 699679 /usr/bin/mailbot 08159000-0815d000 rw-p 00111000
    ca:02 699679 /usr/bin/mailbot 08e50000-08e71000 rw-p 08e50000 00:00 0
    b7f31000-b7f32000 rw-p b7f31000 00:00 0 b7f3d000-b7f3e000 rw-p b7f3d000
    00:00 0 b7f3f000-b7f42000 rw-p b7f3f000 00:00 0 bfb57000-bfb6c000 rw-p
    bffea000 00:00 0 [stack] WARN: quota string '2097152000' not
    parseable

    Then i turned off autoresponder and enabled it again, now i dont get that error mail, but autoresponder dont work to. When i activate autoresponder on mailbox, in /var/vmail/mailfilter/domain_name/user_name is created files *.autoresponder and *vacation.msg. When i try send mail to that mailbox i dont get autoreply, postfix log didnt shows any errors, in /var/vmail/mailfilter/domain_name/user_name file .cache not created. Postfix log:

    Aug 25 12:37:42 hostas postfix/smtpd[1326]: connect from unknown[127.0.0.1]
    Aug 25 09:37:42 hostas postfix/smtpd[1326]: 35DD890063: client=unknown[127.0.0.1]
    Aug 25 12:37:42 hostas postfix/cleanup[1314]: 35DD890063: message-id=<42751.192.168.1.16.1282729060.squirrel@192.168.1.190>
    Aug 25 12:37:42 hostas postfix/qmgr[1656]: 35DD890063: from=<none@opensuse.lt>, size=1393, nrcpt=1 (queue active)
    Aug 25 12:37:42 hostas amavis[1684]: (01684-05) Passed CLEAN, MYNETS LOCAL [127.0.0.1] [127.0.0.1] <none@opensuse.lt> -> <test1@opensuse.lt>, Message-ID: <42751.192.168.1.16.1282729060.squirrel@192.168.1.190>, mail_id: 5OjrkQx7H6K1, Hits: -1, size: 958, queued_as: 35DD890063, 1277 ms
    Aug 25 12:37:42 hostas postfix/smtp[1318]: DD9709011E: to=<test1@opensuse.lt>, relay=127.0.0.1[127.0.0.1]:10024, delay=1.5, delays=0.15/0.05/0.04/1.2, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=01684-05, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 35DD890063)
    Aug 25 12:37:42 hostas postfix/qmgr[1656]: DD9709011E: removed
    Aug 25 09:37:42 hostas postfix/smtpd[1326]: disconnect from unknown[127.0.0.1]
    Aug 25 12:37:42 hostas postfix/pipe[1328]: 35DD890063: to=<test1@opensuse.lt>, relay=maildrop, delay=0.42, delays=0.07/0.07/0/0.28, dsn=2.0.0, status=sent (delivered via maildrop service)
    Aug 25 12:37:42 hostas postfix/qmgr[1656]: 35DD890063: removed

    Maybe someone can help me with this problem ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. raiman

    raiman New Member

    Ty for answer, i commented out MYSQL_QUOTA_FIELD quota, restarted service but still getting the same error.


    here is my authmysaqlrc file content:

    MYSQL_SERVER localhost
    MYSQL_USERNAME ispconfig
    MYSQL_PASSWORD xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    MYSQL_PORT 0
    MYSQL_DATABASE dbispconfig
    MYSQL_USER_TABLE mail_user
    MYSQL_CRYPT_PWFIELD password
    #MYSQL_CLEAR_PWFIELD password
    MYSQL_UID_FIELD uid
    MYSQL_GID_FIELD gid
    MYSQL_LOGIN_FIELD email
    MYSQL_HOME_FIELD homedir
    MYSQL_MAILDIR_FIELD maildir
    #MYSQL_NAME_FIELD
    #MYSQL_QUOTA_FIELD quota
    MYSQL_QUOTA_FIELD concat(quota,'S')
    #MYSQL_WHERE_CLAUSE access='y'
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ensure that you restarted the courier-authdaemon service.
     
  5. raiman

    raiman New Member

    I restarted courier-authlib, when results in logs was the same i just rebooted vm and still the same error occurs.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you selected "y" when the ispconfig installer asked you if the services shall be reconfigured?
     
  7. raiman

    raiman New Member

    Yes, services was reconfigured. Maybe there is a problem with my mistake when i skiped tutorial part where i need to uninstall dovecot ? I had problems with postfix after upgrade becouse dovecot. How can i run service reconfiguration again ?
     
  8. raiman

    raiman New Member

    So my solution was: removed courier, maildrop etc. installed dovecot using this http://www.howtoforge.com/perfect-server-centos-5.5-x86_64-ispconfig-3 manual, reinstalled ispconfig 3, in /etc/dovecot-sql.conf changed query from

    user_query = SELECT email as user, maildir as home, CONCAT(maildir, '/Maildir') as mail, uid, gid, CONCAT('maildir:storage=', floor(quota/1024)) AS quota, CONCAT(maildir, '/.sieve') as sieve FROM mail_user WHERE email = '%u' AND disable%Ls = 'n'

    to

    user_query = SELECT email as user, homedir, maildir as mail, uid, gid, CONCAT('maildir:storage=', floor(quota/1024)) AS quota, CONCAT(maildir, '/.sieve') as sieve FROM mail_user WHERE email = '%u' AND disable%Ls = 'n'

    and all works fine, autoresponder works to.
     

Share This Page