Ispconfig 3 problem with mail

Discussion in 'Installation/Configuration' started by fastformer, May 17, 2009.

  1. fastformer

    fastformer New Member

    Hi,

    I have followed the howtoforge tutorial :
    http://www.howtoforge.com/perfect-se...04-ispconfig-3

    Now I have a problem with emails for my main server. Well as you know in order to create email addresses, you'd have to create a mail domain then a mail box. So I go to ISPConfing and create a mail domain mydomain.tld and then go create a mail box admin@mydomain.tld.
    All good so far, and I can log into squirrelmail, which means the mysql record has been successfully created.
    The problem is with receiving email at this address. When i email this address I says: <admin@mydomain.tld>: unknown user 'admin' and here's the report:

    Reporting-MTA: dns; mydomain.tld
    X-Postfix-Queue-ID: 7162CC953
    X-Postfix-Sender: rfc822; myemail@myhost.tld
    Arrival-Date: Sun, 17 May 2009 13:52:50 +0000 (UTC)

    Final-Recipient: rfc822; admin@mydomain.tld
    Original-Recipient: rfc822;admin@mydomain.tld
    Action: failed
    Status: 5.1.1
    Diagnostic-Code: X-Postfix; unknown user: "admin"

    please help.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/postfix/master.cf?
     
  3. fastformer

    fastformer New Member

    The contents of master.cf

    Hi,

    Here's the contents of my master.cf as per request.

    #
    # Postfix master process configuration file. For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # Do not forget to execute "postfix reload" after editing this file.
    #
    # ==========================================================================
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # ==========================================================================
    smtp inet n - - - - smtpd
    #submission inet n - - - - smtpd
    # -o smtpd_tls_security_level=encrypt
    # -o smtpd_sasl_auth_enable=yes
    # -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    # -o milter_macro_daemon_name=ORIGINATING
    #smtps inet n - - - - smtpd
    # -o smtpd_tls_wrappermode=yes
    # -o smtpd_sasl_auth_enable=yes
    # -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    # -o milter_macro_daemon_name=ORIGINATING
    #628 inet n - - - - qmqpd
    pickup fifo n - - 60 1 pickup
    cleanup unix n - - - 0 cleanup
    qmgr fifo n - n 300 1 qmgr
    #qmgr fifo n - - 300 1 oqmgr
    tlsmgr unix - - - 1000? 1 tlsmgr
    rewrite unix - - - - - trivial-rewrite
    bounce unix - - - - 0 bounce
    defer unix - - - - 0 bounce
    trace unix - - - - 0 bounce
    verify unix - - - - 1 verify
    flush unix n - - 1000? 0 flush
    proxymap unix - - n - - proxymap
    proxywrite unix - - n - 1 proxymap
    smtp unix - - - - - smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay unix - - - - - smtp
    -o smtp_fallback_relay=
    # -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq unix n - - - - showq
    error unix - - - - - error
    retry unix - - - - - error
    discard unix - - - - - discard
    local unix - n n - - local
    virtual unix - n n - - virtual
    lmtp unix - - - - - lmtp
    anvil unix - - - - 1 anvil
    scache unix - - - - 1 scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent. See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop unix - n n - - pipe
    flags=R user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp unix - n n - - pipe
    flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail unix - n n - - pipe
    flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp unix - n n - - pipe
    flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix - n n - 2 pipe
    flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman unix - n n - - pipe
    flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
    ${nexthop} ${user}


    amavis unix - - - - 2 smtp
    -o smtp_data_done_timeout=1200
    -o smtp_send_xforward_command=yes

    127.0.0.1:10025 inet n - - - - smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_client_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks=127.0.0.0/8
    -o strict_rfc821_envelopes=yes
    -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    -o smtpd_bind_address=127.0.0.1
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. Do you have this problem only with admin@mydomain.tld or also with other email addresses?
     
  5. fastformer

    fastformer New Member

    Any email @mydomain.tld

    Hi

    Any email defined for @mydomain.tld has the same problem. All other domains are ok. I think there's something, somewhere that stops the postfix from using the look up in the mysql table?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that you did not use mydomain.tld as myhostname, mydomain or mydestination in postfix main.cf or /etc/mailname.
     

Share This Page