ISPconfig 3 - Postfix - warning: dict_nis_init: NIS domain name not set - NIS lookups

Discussion in 'Installation/Configuration' started by danhansen@denmark, Apr 20, 2013.

  1. danhansen@denmark

    danhansen@denmark HowtoForge Supporter

    Hi,

    Anybody who can confirm this fix - please remember, its an ISPconfig Server:

    Problem:
    warning: dict_nis_init: NIS domain name not set - NIS lookups disabled

    Solution maybe?:
    Nov 21 10:21:13 web postfix/smtpd[30732]: warning: dict_nis_init: NIS
    domain name not set - NIS lookups disabled


    It's a warning, not an error. You eliminate it by removing
    NIS lookups.
    First, find out what setting is using NIS:

    $ postconf | grep nis:

    This outputs something like
    alias_maps = hash:/etc/aliases nis:mail.aliases
    or
    alias_maps = hash:/etc/mail/aliases nis:mail.aliases

    Then, disable NIS lookups (as root):

    # postconf -e alias_maps=hash:/etc/aliases
    or
    # postconf -e alias_maps=hash:/etc/mail/aliases

    The exact command depends on "postconf | grep nis:" output



    Looking forward to hear from anyone :)
     

Share This Page