Ispconfig 3 on php 7

Discussion in 'General' started by lnxgs, Dec 28, 2015.

  1. lnxgs

    lnxgs Member

    Hi,
    do you know if ispcofig 3 runs on php 7?
    I'm suppose no, but maybe there is a road map to code this software for php 7.

    Regards,
    L.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Hi,

    you can use PHP 7 for websites hosted with ISPConfig (as additional PHP version). The control panel itself needs a system PHP 5.x.

    ISPConfig 3.1 will have full PHP 7 support. Currently the installer uses still mysql_* functions with don't exist in PHP 7 anymore.
     
  3. lnxgs

    lnxgs Member

    Thank you for your kindly reply.
    I'm building a deb package to install on my test/preproduction internet server. This would be integrated on a ispconfig 3 installation.

    Regards,
    L.
     
  4. borekon

    borekon New Member

    Hi, 3 years later i wonder the same question. Following the perfect-server guide i suppose it runs on php 7, but what about php 7.1 or 7.2?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig supports all PHP veersions between 5.3 and 7.2. But you should use the PHP version that ships with the Linux OS version that you use on the server
     
    borekon likes this.
  6. nhybgtvfr

    nhybgtvfr Member

    sorry, I know I shouldn't hijack threads, but does this mean I can install ispconfig 3.1.11 without problems on Ubuntu 18.04 which uses php7.2 as default? I know you stated before to use 7.1 and add 7.2 as an additional version. also, any idea on when a perfect server tutorial for 18.04 will be released? i'm keen to start using it but just know if I try working it out myself, i'll do something different, probably with php, and cause myself all sorts of problems down the road.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    No, but you can install ISPConfig from git stable-3.1 branch on Ubuntu 18.04.

    Thee tutorial is finshed already but I will not release it before ISPConfig 3.1.12 is finished which adds support for Ubuntu 18.04 officially.
     
    dmgeurts and ahrasis like this.

Share This Page