ISPConfig 3 on Hetzner Ubuntu minimal

Discussion in 'General' started by McLure, May 10, 2012.

  1. McLure

    McLure New Member

    I (and a friend on a similar server) got HTTP ERROR on Wordpress image upload on new Ubuntu 12.04 server at Hetzner ubuntu 12.04 minimal. I guess this has something to do with wrong setup or something.
    At "The Perfect Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3) - Page 4"
    ( http://www.howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3-p4 )
    I had to PURGE before INSTALL at "apt-get install postfix postfix-mysql postfix-doc mysql-client mysql-server openssl getmail4 rkhunter binutils dovecot-imapd dovecot-pop3d dovecot-mysql dovecot-sieve sudo" - otherwise the "General type of mail configuration: <-- Internet Site" do not show up and postfix never worked otherwise.
    Could this be the reason for the HTTP ERROR ?

    Would be nice with a "The Perfect Server @ Hetzner" guide...
     
  2. till

    till Super Moderator

    First,ensure that you use the current ispconfig version (3.0.4.4). The reason for that are most likely wrong website settings. Wordpress requires the following settings:

    System > Server config > Web: Security Level must be set to high.

    Sites > Website:

    Suexec: On
    PHP mode: php-fcgi

    and make sure that all files and folders from wordpress in the "web" folder of this site are owned by the user and group of this website.
    No.
     
  3. MaddinXx

    MaddinXx HowtoForge Supporter

    Last edited: May 10, 2012
  4. McLure

    McLure New Member

    Configuration..

    Seems I have all correct. PHP is "Fast-CGI" - There is no "php-cgi"
     
  5. till

    till Super Moderator

  6. McLure

    McLure New Member

    Wow! That was all. Now it works!
    MaxRequestLen 157286400
     

Share This Page