IspConfig 3 on external IP shows PhpMyAdmin

Discussion in 'Installation/Configuration' started by noettore, May 20, 2014.

  1. noettore

    noettore New Member

    I've a problem:
    when I access my server throught his external IP address I'm redirected the the login page of PhpMyAdmin.
    Do you know why?
    How can I solve this?

  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Did you install phpMyAdmin in /var/www ?
  3. noettore

    noettore New Member

    No... I don't think so.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post your apache phpmyadmin.conf file.
  5. noettore

    noettore New Member

    Here it is:
    # phpMyAdmin default Apache configuration

    Alias /mysql /usr/share/phpmyadmin

    <Directory /usr/share/phpmyadmin>
    Options FollowSymLinks
    DirectoryIndex index.php

    <IfModule mod_php5.c>
    AddType application/x-httpd-php .php

    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_admin_flag allow_url_fopen Off
    php_value include_path .
    php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp
    php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/


    # Authorize for setup
    <Directory /usr/share/phpmyadmin/setup>
    <IfModule mod_authn_file.c>
    AuthType Basic
    AuthName "phpMyAdmin Setup"
    AuthUserFile /etc/phpmyadmin/htpasswd.setup
    Require valid-user

    # Disallow web access to directories that don't need it
    <Directory /usr/share/phpmyadmin/libraries>
    Order Deny,Allow
    Deny from All
    <Directory /usr/share/phpmyadmin/setup/lib>
    Order Deny,Allow
    Deny from All

    DocumentRoot /usr/share/phpmyadmin

Share This Page