ISPConfig 3 Not Showing Quotas

Discussion in 'Installation/Configuration' started by crypter, Nov 12, 2013.

  1. crypter

    crypter New Member

    For each site I have set up, I have implemented a Harddisk Quota and Traffic Quota. They seem to work, because if I try and create a New Site and I'm already maxed out then it gives me a warning. So that tells me it actually is reading the quota.

    However when I click on Website Quota (under Statistics on the Sites tab) it lists out all my sites, but says they have an "unlimited" soft and hard limit. Which is not the case. Also on my main page where it gives a quick overview of my sites, they also say "unlimited".

    I followed the Centos 6.4 Perfect Server guide (with ISPConfig and Apache).

    Here are some screenshots to help you see what I'm talking about:

    [​IMG]

    [​IMG]

    [​IMG]

    Any help would be appreciated. Thanks!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is quota working on your harddisk? Check with:

    repquota -avug
     
  3. crypter

    crypter New Member

    Hey till, thanks for the reply.

    As far as running that command, it didn't return anything. It didn't even return an error. It basically didn't do anything. Not sure what the issue is.

    Code:
    [[email protected] ~]# repquota -avug
    [[email protected] ~]# 
    
    Is there something else I may be able to try?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if quota is not configured correctly. Please recehck the settings in /etc/fstab and comapre them with the setup that is described in the perfect server installation guide.
     
  5. crypter

    crypter New Member

    From what I can tell, they look similar (excluding the added domains).

    Here is the /etc/fstab from the guide:

    Code:
    #
    # /etc/fstab
    # Created by anaconda on Wed Jul 11 17:52:57 2012
    #
    # Accessible filesystems, by reference, are maintained under '/dev/disk'
    # See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
    #
    /dev/mapper/vg_server1-lv_root /                       ext4    defaults,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0        1 1
    UUID=806910a1-dbdf-4746-bd94-cbe73ce81493 /boot                   ext4    defaults        1 2
    /dev/mapper/vg_server1-lv_swap swap                    swap    defaults        0 0
    tmpfs                   /dev/shm                tmpfs   defaults        0 0
    devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
    sysfs                   /sys                    sysfs   defaults        0 0
    proc                    /proc                   proc    defaults        0 0
    And here is the /etc/fstab from my server:
    Code:
    #
    # /etc/fstab
    # Created by anaconda on Mon Oct  7 16:05:02 2013
    #
    # Accessible filesystems, by reference, are maintained under '/dev/disk'
    # See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
    #
    /dev/mapper/vg_host-lv_root /                       ext4    defaults        1 1
    UUID=4a39bdfc-994a-4a1a-bd76-56df5c4588ef /boot                   ext4    defaults        1 2
    /dev/mapper/vg_host-lv_swap swap                    swap    defaults        0 0
    tmpfs                   /dev/shm                tmpfs   defaults        0 0
    devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
    sysfs                   /sys                    sysfs   defaults        0 0
    proc                    /proc                   proc    defaults        0 0
    /var/log/ispconfig/httpd/domain.net /var/www/clients/client2/web9/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/domain.com /var/www/clients/client2/web10/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/domain.com /var/www/clients/client2/web11/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/domain.com /var/www/clients/client2/web12/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/domain.com /var/www/clients/client2/web13/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/domain.net /var/www/clients/client2/web14/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/domain.cc /var/www/clients/client2/web15/log    none    bind,nobootwait    0 0
     
  6. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    You have not enabled quota.
     
  7. crypter

    crypter New Member

    Ah nice catch, thank you!

    I went ahead and proceeded with the steps mentioned in the guide, but I'm not sure if it's working as it should yet.

    I did as this step instructed:

    Code:
    Edit /etc/fstab and add ,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 to the / partition (/dev/mapper/vg_server1-lv_root)
    Then I ran
    Code:
    mount -o remount /
    which ran fine.

    Then I ran
    Code:
    quotacheck -avugm
    but got some odd results:

    Code:
    [[email protected] ~]# quotacheck -avugm
    quotacheck: Scanning /dev/mapper/vg_host-lv_root [/] done
    quotacheck: Cannot stat old user quota file: No such file or directory
    quotacheck: Cannot stat old group quota file: No such file or directory
    quotacheck: Cannot stat old user quota file: No such file or directory
    quotacheck: Cannot stat old group quota file: No such file or directory
    quotacheck: Checked 12831 directories and 94399 files
    quotacheck: Old file not found.
    quotacheck: Old file not found.
    
    And then I also went ahead and finished it up with:

    Code:
    [[email protected] ~]# quotaon -avug
    /dev/mapper/vg_host-lv_root [/]: group quotas turned on
    /dev/mapper/vg_host-lv_root [/]: user quotas turned on
    
    However the quotas are still showing "Unlimited" across all of them. I'm thinking there was an issue when I ran the quotacheck command considering it returned a bunch of No Such File messages.

    This is what my edited fstab looks like:

    Code:
    #
    # /etc/fstab
    # Created by anaconda on Mon Oct  7 16:05:02 2013
    #
    # Accessible filesystems, by reference, are maintained under '/dev/disk'
    # See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
    #
    /dev/mapper/vg_host-lv_root /                       ext4    defaults,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0        1 1
    UUID=4a39bdfc-994a-4a1a-bd76-56df5c4588ef /boot                   ext4    defaults        1 2
    /dev/mapper/vg_host-lv_swap swap                    swap    defaults        0 0
    tmpfs                   /dev/shm                tmpfs   defaults        0 0
    devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
    sysfs                   /sys                    sysfs   defaults        0 0
    proc                    /proc                   proc    defaults        0 0
    /var/log/ispconfig/httpd/domain.net /var/www/clients/client2/web9/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/domain.com /var/www/clients/client2/web10/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/domain.com /var/www/clients/client2/web11/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/domain.com /var/www/clients/client2/web12/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/domain.com /var/www/clients/client2/web13/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/domain.net /var/www/clients/client2/web14/log    none    bind,nobootwait    0 0
    /var/log/ispconfig/httpd/domain.cc /var/www/clients/client2/web15/log    none    bind,nobootwait    0 0
    
     
  8. crypter

    crypter New Member

    Actually after waiting a bit / resyncing my websites in ISPConfig, the quotas are showing as they should. Thank you both for your help!
     

Share This Page